View Full Version : elevators that dont bloody work

04-25-2002, 01:59 AM
i made a ...nearly... functioning elevator

it operates fine

when i press the button it comes down waits a couple of seconds then goes back up.......unless im standing on it!

why? damnit!! why?

also does anyone now how to make it make the elevator moving humming noise i tried selecting it as a noise in its entites window thing but it didn't work, same deal with the button


04-25-2002, 02:31 AM

c'mon someone must know stuff about elevators



Cmdr. Antilles
04-25-2002, 02:34 AM
Need more info... What kind of func is it?

And that 'noise' command never works. You'll just have to have your trigger target a target_speaker that plays your noise.

04-25-2002, 02:40 AM
the elevators a func plat and the button is a func button
i've got them so that the button makes the elevator go down and then up but it wont return up if my dudes standing on it

with the sounds;
whats my trigger? the button?
is that a similiar thing as making the lights target a specific spot?
cause i can do that


Cmdr. Antilles
04-25-2002, 02:45 AM
Yeah, I guess... Sorry, I'm used to explaining stuff to people who know Radiant a little better. My fault.

I've never messed with func_plats...

For the sound, you'd give your func_button a key 'target' and a value 'plat1' (or something)
Then, give the plat 'targetname', and a value of 'plat1'
Then, make a target_speaker (that is set to play your sound), and give it 'targetname' - 'plat1' too.

Hope that helps.

You may have learned it using the shortcut control+k, but it's good to know how to do it manually. Plus, you can't have multiple targets for the same trigger if you only use the shortcut.

Hope that makes some kind of sense.

04-25-2002, 02:50 AM
sure does

your a question answering machine!



Cmdr. Antilles
04-25-2002, 02:52 AM
Heheh... Thanks. :)

Just don't ask me how to get rid of that strange odor in your car. :p