PDA

View Full Version : i hate assimilate and carcass and raven lol


sirbakk
05-05-2002, 08:12 PM
when i'm building my model, i get an error like "file contain cubic scales keys"...what's that?????
so i tried to build stormtrooper's model, perfect..but i try to import this same "root.xsi " into 3dsmax4.2 ,export it to root.xsi and when i build the model into assimilte, carcass give me the same error!!..what the ****??root.xsi is the file found into jk2editingtools...it should work fine??!! no?
some questions for sithlord:

-the problem is the import and export xsi from 3dstudiomax....what about that?how did you setup your import and export?all check boxes?
-the four LOD (level of detail) are necessary?tags too?
-of course i've weight all vertice(the mesh move really good)..but still the same error
-segement are good..
-ouinnnn..damnit..no explanation into jk2editingtools files..grrrrr

sirbakk
05-05-2002, 08:13 PM
i'm really sorry for my plain english ;-)...damnit french lol

IronFist115
05-05-2002, 08:16 PM
Je parle le francais, et je sais que le probleme la est TOI!
Lol, I don't speak much of it, but, I think the problem is that your CARELESS WITH THE MODELS! *dun dun duuuuuuuuun*

sirbakk
05-05-2002, 08:23 PM
sure...but i need to say i hate those tools..:-)...i'm working on a vador model(it lools like very nice)...but i can't export it two week ago..and i'm crying to see sithlord can use his model into jk2 ..snif

ps: good french :-)

sirbakk
05-05-2002, 08:26 PM
should i triy to make a wookie model?lol

Madjai
05-05-2002, 09:16 PM
i really wish modeling was more user friendly.

sithlord-II
05-06-2002, 05:14 AM
hey sorry haven't looked thru here much
here is what i do for export/import in carcass
1) create directory on drive, ex. c:\base\models\players\

2)extract assets0.pk3 to a folder, say c:\jk2edit

3)take humanoid.gla file out of base\models\players\_humanoid\
folder

4)make folder c:\base\models\players\_humanoid\, put GLA file in there

5) extract jedi knight editing tools - i put tools into c:\base\ folder

6) run assimilate, then go into edit/preferences
i deleted the path to quake dir and enum file
i put in path to carcass file, for instance since i'd extracted to c:\base, located the carcass.exe there

7)goto file\add files, locate humanoid.gla file from c:\base\models\players\_humanoid\, then add it

8) you will export your XSI file from 3d studio max into this directory, the humanoid directory. A tip on setting up your model in 3d studio: when you set up your textures, put them pathed to what you will have them in the JK2 folders. Example for vader, i have his textures located in c:\base\...\vader\, and i have them in the materials, located thru those directories. When i export i have all options checked

9)OK back to assimilate. SO lets say you've done steps 1-7, and have your XSI file already in the humanoid directory (NAME IT ROOT.XSI). You want to go to build (B button on toolbar in assimilate)
now you should have the command window popup. If you dont' get an error message, great, it will create a GLM file, and if you want to, a SKIN file (to do that, within assimilate, after adding the humanoid file, double click on the folder humanoid there and goto MAKE EF-1 TYPE SKIN FILE.

some possible errors: 6210 (i think that is it..) - that seems to mean you have mesh which has not had the skin properly applied. I find you can apply a skin modifier, then apply an edit mesh modifier to that same mesh afterwards and maintain the bone setup, so long as you DO NOT delete any vertices. You can however detach polygons etc (ie... caps...) and still have it work.
other errors are fairly self-explanatory, just make sure everything is linked together.

oK next step, test it out in modview and see how it works
:)

sithlord-II
05-06-2002, 05:14 AM
accidental double post.. my bad
hehehe
and i realized i didn't answer the question, damn.... personally i ran into that error once and i don't even remember how i corrected it
i would recommend checking over the mesh, going into heirarchy setup and resetting the pivots, as well as the transforms and scales... try that out and see what happens
try it from even just the base root.xsi file for kyle from the editing tools

cabraswel
05-06-2002, 03:10 PM
Sithlord, you're a great help. I too have a problem which seems altogether nonsensical to me. When I try to Build my model, Assimilate tells me that I have multiple mesh_root files. I have checked at least a dozen times and resaved and reexported. I can assure you there is only 1 mesh_root. Any ideas?

sirbakk
05-06-2002, 03:26 PM
ok great thanks sithlord..

my hierarchy is perfect ..like original kyle's model..
but i didn't build uvw on my mesh..maybe that s the probleme..and i saw there was a lot of objects can be wrong..i think i ll try to use xform and set the pivots up...

spacermonkey
05-06-2002, 03:42 PM
have you uvw mapped your model?

sithlord-II
05-06-2002, 05:07 PM
not sure about multiple root files
technically even in kyle's mesh there is only one root, since that is from the skeleton, and all the LOD's and tags are attached to it.
UV mapping isnt necessary for the model to export, but if you want the texture to show up, you should do it before you assign the mesh to the skeleton.
what might be happening though is because of the linked heirarchy, everything should link back up to stupidtriangle_off, then down into hips, then everything goes back into the hips.

sirbakk
05-06-2002, 05:16 PM
oups...i said a big mistake...i ll use resetXform not "xform".

spacermonkey:
no i didn't mapped my model..it's necessary at this step?..can't build uvw later?

sirbakk
05-06-2002, 05:22 PM
ok lol..i known now for uvw...
and i think use resetxform can be fix the error message get by carcass.."cubic scales keys"
what do you think about that?

sirbakk
05-06-2002, 07:54 PM
ok Proto fixed that error "cubic scales keys"...but now i get a new error..
rd_eff was not found
rd2_eff was not found
rd3_eff was not found
rd4_eff was not found
rd5_eff was not found
rarm_eff was not found
ld1_eff was not found
ld2_eff was not found
ld3_eff was not found
ld4_eff was not found
ld5_eff was not found
larm_eff was not found
motion_eff was not found

grrr...i weighted all vertices of course(tags too..etc)...i have to do special somethings with those little bones ?

sirbakk
05-06-2002, 08:18 PM
ok i found the solution....
none vertex muste be weight at those bones...but into skin modifier you have to add those bones !!