PDA

View Full Version : Evil curve texturing


fabrikashon
05-07-2002, 10:10 AM
Is there anyway to solve this problem:

http://riseupperth.com/images_temp/curvemesh.jpg

Seems to happen on all curves that run into a solid brush. Any way to fix this? The texture appears brighter as well.

tofu
05-07-2002, 10:28 AM
Is that an ingame shot? I know that my curve textures look wierd in the editor, but ingame they look ok.

fabrikashon
05-07-2002, 10:38 AM
Yep its an ingame shot - the top part is the curve, the lower part is the solid. I thought about making the whole thing a curve yet if it isnt neccessary then I'd rather not :)

PainGod
05-07-2002, 10:50 AM
Hmm. Every once in a while I create a brush with oddball angles and it glows strangely under the light, including what little light the saber makes. I fix the problem by selecting the brush and hitting the CSG Subtract button. Even tho, near as I can tell at least, the brush isn't interfering with any others. Dont know if that will fix your problem.

Try moving the light source away from it, too, maybe....

fabrikashon
05-07-2002, 11:35 AM
It does it without any light as well.

Gizmo2k
05-07-2002, 09:32 PM
If its still full bright without any lighting near its becuase your not compiling with patch shadows enabled (raven in there wisdom seem to have left out this compile set up out of JK2rad compile menu god knows why????)

i cant see from that screen shot if it is full bright or not if it is let me know any i'll post the needed compile options for ya

laters
gizmo

fabrikashon
05-08-2002, 01:25 AM
Nah thats a lighted version up above, it still did it on BSP Fullvis -extra, does that include the patch shadows?

Gizmo2k
05-08-2002, 10:18 AM
no the - extra does not add proper patch shadowing :(

add this line to the bottom of the compile option in your StarWarsMP.qe4(or StarWars.qe4 if your making sp maps)
just above the line "autosave"

"bsp FullVis+patchshadows" "__QERPATH\sof2map -bsp -samplesize 16 $ && __QERPATH\sof2map -vis $ && __QERPATH\sof2map -light -extrawide -patchshadows -samplesize 16 $"

now when you fire up JK2rad you'll have a new option in your compile menu

but plz backup your work before using this it works ok for me but i cant say the same for you

hope this helps

fabrikashon
05-08-2002, 12:38 PM
Cool, thanks for that :) I'll give it a shot.

fabrikashon
05-09-2002, 01:19 AM
My guess is, that it isn't supposed to take 9hours + just to render? Thats the BSP as well ;)

Manquesa
05-09-2002, 02:04 AM
Here's a question, for the curve, did you try selecting it, then hit "s" (the surface inspector menu) and clicking the natural button.

fabrikashon
05-09-2002, 04:06 AM
I thought that only worked for the caps? Either way, it still appears brighter than a solid brush...

Gizmo2k
05-09-2002, 09:58 AM
no i dont think it should take 9 hours+ how big is your map?

you could try reducing the sample size(will reduce light compile time but shadow's wont look as good)and remove the extra wide option(or just set it to extra again shadows wont be so AA'ed)

ive ammended the compile option for you same as before just copy and paste to your Qe4 file(s)

"bsp FullVis Sam256+patchshadows" "__QERPATH\sof2map -bsp -samplesize 256 $ && __QERPATH\sof2map -vis $ && __QERPATH\sof2map -light -extra -patchshadows -samplesize 256 $"

which of the compiles is taking the longest?

if your using a lot of detail brushes your -bsp will be short but you pick up alot of time in the light compiler and if your just using structural brushes your -bsp+vis will incress but lighing will take less time....
also as Manquesa says try resetting your texture on the curve with natural via the surface inspector
hope this helps

fabrikashon
05-09-2002, 10:45 AM
It's a medium sized map and there are some detail brushes around. But it was only taking 58 minutes before I put the patch shadow render to the test...

I've done a lot of changes since last night though so I'll give it one more shot tonight and then try this one tomorrow night. Thanks for all the help.