PDA

View Full Version : radiant prob I cant seem to find any solution for


Jessicka
05-08-2002, 08:31 AM
OK all my paths are correct , so I thought I would get that out of the way. I checked with the developers on that, still there is this problem i cant fix - i cannot make bsps. I use win xp too and even in admin options i cannot turn off read only to the folder that would write a bsp. I get this when i bsp the weird characters change all the time but here's the line towards the end i see-

SetQdirFromPath: no 'base' in x


completed.
Run time was 0 hours, 0 minutes and 1 seconds


IF ANYONE can help i would appreciate it more then you can possibly imagine.

UniKorn
05-08-2002, 10:41 AM
Make sure you have saved your map. Then try again :)

Dark Cloak
05-08-2002, 04:21 PM
Yoiu have to put your .map file...or whatever you saved it as, in a folder called "maps" in your base directory. :) I had the same problem.

Jessicka
05-08-2002, 07:22 PM
i already have that maps folder but its saving to the tools folder for some reason

sights0d
05-08-2002, 11:56 PM
The dumb answer:
Every once in a while I do something stupid that someone brings to my attention... Did you try "save as" and direct it to the proper directory?

akurtz
05-09-2002, 01:01 AM
I am having the same problem...correct paths, maps in the "maps" directory, also running WinXP -- but can't create BSPs. I have tried every BSP setting (including the recommended "bsp FullVis (extra)"). The compiler reports that it took only 1 second (sometimes 2) to compile the map. A thorough search of my hard drive reveals absolutely NO .bsp files. I have even tried using sof2map manually, but nothing works.

I was able to get one of my smaller maps half-working by making a copy of the .map file, renaming it to filename.bsp, and THEN running bsp FullVis (extra), which took about 45 seconds to compile instead of just 1 second. The map will load in JK2, but then boots me, giving a "no spawning points" error message (even though I have an "info_player_start" entity).

"Save As" only allows the map to be saved as a .map or .reg file.

Please help!

lordkaz
05-09-2002, 01:28 AM
I agree with sights0d,

Try doing a 'Save As', open the \gamedata\base\maps directory and just type the name of your map, 'mymap' enter. Shouldnt need to type .map, but I dont see why you couldnt.

Then just run the BSP from the editor.

Do you have the tools installed in the default directory?
\LucasArts\Star Wars JK II Jedi Outcast\GameData\Tools\?

Uh, Im not running win XP, nor have I used it yet, but you may need to allow for write-access I dunno? SoF2map creates temporary files while compiling, aside from making the BSP itself hehe.

Cant think of any other reasons why your getting that error, sorry =(

-Kaz

sights0d
05-09-2002, 02:00 AM
If you check on the sticky thread, there is a reference to a place to check what ALL of the quake 3 errors mean. I'd have looked it up for you but Enterprise is on in 5... 4... 3... ACK!

akurtz
05-09-2002, 02:48 AM
Hmmm...okay...here's what I've found out in the past two hours or so...

The "Read-Only" attribute is set for all XP folders and can't be changed (as far as I have been able to tell) so I don't think that's the problem (files themselves that are created in the folders do not have the "Read-Only" attribute checked by default). Regular batch (.bat) files don't have a problem creating files in XP folders, so sof2map shouldn't either.

The directory JK2 is installed into doesn't matter. I originally had it buried somewhere in my G:\ drive so I uninstalled it and reinstalled it in the default path (C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast)...still didn't work.

I have tinkered extensively with the paths in the "Project Settings" box. I tried the default JK2 directory and even test directories in completely different locations (with the word "base" somewhere in the path). In every case I receive the same error message (SetQdirFromPath: no 'base' in xxxx) and no BSP file is created.

I checked the page of errors for the Quake 3 version of Radient...it did have a similar error to the one I am receiving, but the only suggestion was to make sure the word "quake" was in the folder path somewhere (or the word "base" in the case of JK2).

The only thing I can think of that would be causing the problem is some conflict between the program and WinXP. I have tried running it in Win2000 compatibility mode which fixed some problems with the program crashing frequently but did not fix the BSP problem. If anyone who reads this is able to successfully create maps w/ JK2Radient on WinXP please let me know.

sights0d
05-09-2002, 03:42 AM
I have a possible answer... could you move your file manually to the maps folder and then drag it over the sof2.? file and release? It might let you do the whole thing without having to go through radient. Or.. you could start radient and have it open the file that would now be in the correct directory. Give it a go.

Jessicka
05-09-2002, 04:42 AM
you guys have been most helpful. I like this site. Well i'm having trouble if you care to work with me to correct this, my Yahoo messenger name is Jessicka_Machiko

or if you use another program email me at machiko@inhell.com and let me know what you use and we can hook up and beat this problem and contribute some nice maps (hopefully) to the community.

Microsith
05-11-2002, 06:35 PM
Jessicka , i just sent this to your email addy and i figured id post this here just incase anyone else is having the same problem . i run XP pro , but it shouldnt matter home or pro , I was having trouble with the compiler flashing its window and creating a .bak file. I reinstalled JK to f:/programfiles/SWJK2 and its been working great ever since. Hope this helps !

Jessicka
05-12-2002, 04:02 AM
hmm what if mine already is in program files though? I can create a .bak but not a bsp. I WOULD check my email but the provider is down. Well if youuse aim, icq or ym and yu can help or anyone can, email me or post your username for one of those 3. I have 3 different names or i'd post mine. my email is machiko@inhell.com

Darth Yoda
05-12-2002, 05:24 AM
I did the following running Windows 2k Pro and i can edit/compile maps perfect:
installed both the game and editing tools in default directory
followed the steps at this tutorial: http://eq3.co.uk/mapping/mapone.asp
saved the .map in base\maps directory
compiled from jk2radiant with bsp FullVis and it works perfect
only thing in the tutorial is its telling u to use some texture thats in q3, that isnt in jk2, so use another one... im thinking of putting out a small radiant noob tutorial, will post here if i go through with it :)

Llawnroc
05-12-2002, 10:12 AM
I'm running Radiant on a Win XP Pro system and everything works perfectly.

I've had to make no changes to any folder permissions or change any of my installation folders to run or compile maps for JK. The only thing I changed was some of the project paths to get the entities working. I installed Radiant into the default game directory it worked!!

If anyone wants to know my settings then I can be reached on any of the following:

ICQ: 120014510
MSN: lucknow01@hotmail.com