PDA

View Full Version : Invalid PK3 Files


DocUK
05-16-2002, 08:17 PM
The most often thing that occurs when a user connects to my dedicated Win32 JK2 Server is that a message displays saying that invalid PK3 files were referenced.

I suppose this is because the server is pure and it will not allow people to join with modified PK3 files? The thing is that there are so many of these messages?

Does the message also display for users that haven't updated to 1.03?

DocUK

MatrixCPA
05-17-2002, 05:01 AM
1.02x clients connecting to 1.03 servers produce a download request for assets2.pk3 which generally fails because either the server, client or both have downloads disabled. 1.03 clients will produce the invalid pk3 file message if they try to join a pure server with a custom skin selected that the server does not also have installed. Generally, if the client switches to a default skin and reconnect they should be ok. 1.02 didn't complain about this situation, it just let them in and everyone else on the server saw that player in a default skin instead.

Skidley
05-20-2002, 04:58 AM
Hey Matrix, I know that you have regular contact with Raven from your other posts. Have they mentioned why they changed it?

1.02 didn't complain about this situation, it just let them in and everyone else on the server saw that player in a default skin instead.

I think it would be benificial if they changed it back to the original setup (as all quake 3 dedicated servers were originally setup that way, if I am not mistaken). It makes it seem to the client that there may be something wrong with that ded. server version. There in turn making the server less friendly and less likely to be played on. Do you not agree?

Maybe someone from Raven could respond to this as well, if they are reading the forums.

:confused: