PDA

View Full Version : OpenGL Problem


Oz_84
05-17-2002, 05:08 PM
with Windows XP Jedi2 complaints something about OpenGL not working and doesnt start. any suggestions?

Nexus2002
05-17-2002, 05:41 PM
Im running XP Pro and get the same thing

Anyone got any ideas on what to do about this??

Here is the error.

JK2MP: v1.03 win-x86 Apr 30 2002
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Games\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets2.pk3 (289 files)
C:\Games\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets1.pk3 (8011 files)
C:\Games\LucasArts\Star Wars JK II Jedi Outcast\GameData\base\assets0.pk3 (6674 files)
C:\Games\LucasArts\Star Wars JK II Jedi Outcast\GameData/base

----------------------
14974 files in pk3 files
execing mpdefault.cfg
couldn't exec jk2mpconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
------------------------------------
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
...setting mode 3: 640 480 FS
...using desktop display depth of 16
...calling CDS: ok
...registered window class
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() - could not load OpenGL subsystem

teleguy
05-17-2002, 07:28 PM
http://support.lucasarts.com/trg/tgd.asp?id=2399&g=120&s=4

SithMaster2003
05-17-2002, 08:56 PM
The first time i tried to run Jedi Outcast on XP Pro, I got the same error. So I went and downloaded up to date drivers for my geforce2 gts card and the game runs great now. so if i were you, i'd snag some drivers.

ltj2002
05-18-2002, 04:55 PM
Originally posted by SithMaster2003
The first time i tried to run Jedi Outcast on XP Pro, I got the same error. So I went and downloaded up to date drivers for my geforce2 gts card and the game runs great now. so if i were you, i'd snag some drivers.

well i downloaded the Detonator XP drivers but for some reason they dont work. I have a TNT2 (pro i think) and it come up with an error saying the patches were specified for the Windows Logo..... I dont know why but this happens EVERY time. I reeeeeeeeeeally wanna play but this is pissin me off. Anyone know what is wrong? (i tried the thing teleguy said and it didnt work for me)

bar-bar mandrel
05-18-2002, 05:42 PM
I think its just saying they weren't certified as OK by microsoft. If so, just continue with the install.

Also note that with the "detonator XP" drivers the "XP" doesn't mean "for windows XP". Make sure you have downloaded the proper set for WindowsXP