PDA

View Full Version : geforce 4 and still sluggish


Adogg
05-22-2002, 04:35 AM
I am getting awful performance from my GeForce 4 Ti 4600. I have tried everything I have read on the boards so far and I am at my wits end.

The game looks like so much fun but I can't get into it because of the sluggish gameplay. It feels like I'm using a TNT1 instead.
I have tried messing with the settings on the openGL tab of my card. I have directx 8.1 and the latest Nvidia drivers (detonator 28.32) installed. I tried 800x600 resolution and set the in-game settings to as low as possible and turned off shadows and detailed shaders. I tried disabling GL extensions.

I know the GF4 card isn't on their list of supported cards, but has anyone else ran into this problem and found a solution or have any ideas?

My system specs:
p4 1.6ghz
gf4 Ti 4600
512mb RAM

teleguy
05-22-2002, 01:45 PM
Does this only affect JK2 or are all your games running slow?
Did you uninstall the old drivers before you installed the new ones? If the old drivers were Geforce drivers you should run Detonator Destroyer http://guru3d.com/detonator-destroyer/ .
Check that vsynch and AA are disabled. Optimize your BIOS settings http://www.techspot.com/tweaks/bios/index.shtml. You may also find help here:
http://www.techspot.com/tweaks/geforce/index.shtml

I had the same problem with a Radeon 8500. Nothing worked. I brought it back to the shop.

Adogg
05-22-2002, 02:26 PM
I noticed really crappy performance when I tried running Quake1 also, maybe it has something to do w/ the quake engine and the card? My other games work fine though (Half-Life, Dungeon Siege, Morrowind etc.).

I uninstalled the previous video drivers before installing the 28.32 drivers but I will try detonator destroyer and then a reinstall to see if that clears up any registry issues. I'll try out the other optimization links you sent also. Thanks for the input bud, much appreciated. I hope it get it fixed soon I'm dying to play it.