PDA

View Full Version : SP Error Message - Skin related?


Angry Sandwich
05-27-2002, 10:05 PM
I've run into a problem and maybe someone can tell me what it is. When trying to play Single-Player, as my game boots up, in the small window I get this message:

**************************************************
JK2: v1.03 win-x86 May 3 2002
Initialising zone memory .....
----- FS_Startup -----
ERROR: filename length > MAX_QPATH ( strlen(Program Files/LucasArts/Star Wars JK II Jedi Outcast/GameData/base/levelshots/) = 78)

**************************************************

What is this error? (it mentions levelshots, so I'm thinking its map related but I don't know.)

Strangely enough, I have no problems playing Mulitplayer. It loads fine. The only thing I can think of that may be causing the problem is I replaced Tavion (evil female Jedi) with the Lady Brena model. That file comes with (I think) 4 variations of Lady Brenna. Since I only wanted the red version of Lady Brena (Lady Maul), I eliminated all of the other unnecessary Brenna .jpg images, as well as the other default.skin until I only had the one Brena model that I wanted. I then reconfigured the file and changed all of the Lady_Brena names to tavion and saved it.

It worked fine, and I was able to play against the new model on the hidden map: Pit (I use command console: map pit to access it to test the model out). But now, after being able to play it earlier, the SP game won't load anymore, giving me an error message instead. Any ideas why? Is it possible that the game will not allow Tavion to be replaced therefore corrupting it? Or is it possible that the map "pit" is a faulty map and should never be accessed (using it may corrupt the sp game later)? Any advice would be appreciated. Again, Im able to play the Multiplayer. I tried out my tavion model on a server and she showed up as Lady Maul. So if the SP game is corrupt then why isn't the MP game (assuming the problem "is" the Lady Brena/Tavion replacement).?

Klorel
05-27-2002, 11:45 PM
it has to do with the reactor.pk3, delete it and your single playin' once more! :duel:

Angry Sandwich
05-27-2002, 11:47 PM
Is the reactor.pk3 map known to cause this problem (corrupting the SP game)?

Nanodagiardino
05-28-2002, 12:53 AM
The error seem to do with the lenght of the file path. Prob it hasn't been packed correctly. If you know a little about PK3 and JO you can try to extract it and fix the problem manualy. JO supports max lenght of 64 char. I would start looking in the folder the error points to "program Files/LucasArts/Star Wars JK II Jedi Outcast/GameData/base/levelshots/" Ohterwise mail the author and ask him.

Angry Sandwich
05-28-2002, 01:24 AM
Thanks for helping me out guys, I really appreciate it. I'm certainly glad that it has nothing to do with my Lady Maul model. I hate the awful looking Tovion model thats in the game. She has now been "officially" replaced. :D

Thanks again! :)



By the way, this is what I replaced my Tovion model with:
http://modcentral.jediknightii.net/files/index.php?link=file&id=317

She's the 3rd picture... the one in red. Now I can take her seriously when I play the single player game again. And yes... Lady Maul also shows up in the between level and in-game cut scenes. :)