PDA

View Full Version : still unable to do mirrors or reflective surfaces after reading other threads!!!


Luvac Zantor
06-20-2002, 11:32 PM
I've searched this forum manually and checked out jk2files.net's forums.

I think I understand there are two ways to do reflectives. One is by using a "shader" with an alpha channel or something. I have not looked deeper into that, because it looks like it would require more work and I don't "get" shaders yet.

The other way was using a texture system>mirror or system>mirror_yavin place that on the surface to you want to reflect and put a misc_portal_surface above it but not farther than 64 units.

well I've moved it as close as I can, and moved it further away and never does it reflect anything.

Can anyone help me? I realize thatif I want glossy surfaces, I should probably learn how to do shaders. Any suggestions, instructions or links to be directed to would be greatly appreciated!!!!

D.L.
06-20-2002, 11:36 PM
The glass and reflective textures are in the textures/common dir.

Hope this helps.

Luvac Zantor
06-20-2002, 11:46 PM
I appreciate the reply, but what are those textures going to do for me?

I already used glass textures ( I forget what default texture list I loaded) of course that glass is blurry, and look better on table tops than an actual window.

Are these textures for reflective surfaces and if so, do I need to extract them from one of the asset files?

Luvac Zantor
06-21-2002, 01:48 AM
LZ make you wanna

bump
bump

Luvac Zantor
06-21-2002, 02:44 AM
in an effort to help, i took some captures of 3d radiant.

I've hacked a room up so it's quick to compile to try to solve this mystery.

so don't critique the room, it's just being used to figure out mirrors.

http://wkp.zantor.net/images/mirror1.jpg

http://wkp.zantor.net/images/mirror2.jpg

Luvac Zantor
06-21-2002, 03:02 AM
well for whatever reason I can't post an image, but it shows the link

Hopefully someone can help me out.

Luvac Zantor
06-21-2002, 03:07 AM
I'm trying all sorts of things here, it just seems like the misc_portal_surface isn't "looking on" to any textures.

Luvac Zantor
06-21-2002, 03:41 AM
ARGH, and I need to learn Neverwinternights TOO!!!!

hehe. it's gotta be something ultra simple i'm missing.....

Luvac Zantor
06-21-2002, 03:49 AM
ok, using mirror_yavin and everything similiar to what I posted

exception 1 misc_portal_surface

and that is 8 units from the surface

looks invisible, unless I get RIGHT UP ON IT in spectator mode, then it mirrors.....

but if I'm not kissing it, it's see through... ?

i'm inverting the brush now and checking that out.

Luvac Zantor
06-21-2002, 05:37 AM
well, the only mirror effect I Get is if I'm a spectator and push into where the mirror is suppose to be, then I see it.

otherwise, it's just a "dark shadow" around most (not all) of the box that should be a mirror.

any ideas?

Luvac Zantor
06-21-2002, 05:41 AM
would a leak cause a mirror not to work?

Xcom
06-21-2002, 05:43 AM
Well, you probably read about my peculiar findings in this thread:

http://64.246.44.70/~lucasforums.com/showthread.php?s=&threadid=63133

and judging by the screenshot you provided this setup isn't gonna work.

Luvac Zantor
06-21-2002, 05:47 AM
yeah, seen that.

My problem isn't that it gets lighter as you get closer.

it STAYS DARK until you are RIGHT UP ON IT. if you are third person mode, you can't get RIGHT UP ON IT.

no mirror effect.

first person or spectator,,, only if you are flush against the mirror does it reflect.

this one has got me stumped.

Luvac Zantor
06-21-2002, 05:57 AM
here's the current screenshots of what works and what doesn't........

http://wkp.zantor.net/images/mirror3.jpg
http://wkp.zantor.net/images/mirror4.jpg
http://wkp.zantor.net/images/mirror5.jpg
http://wkp.zantor.net/images/mirror6.jpg
http://wkp.zantor.net/images/mirror7.jpg


notice from afar, it's black
when i finally get close enough to see the mirror effect, if I turn, it goes black

also notice in third person right against it, nothing, still black.

Xcom
06-21-2002, 06:00 AM
I might have solved the mirror problem..yey. Would do some testing for me?

Create mymirror directory under base/textures and leave it empty.

Open Notepad and paste this shader code in it:


textures/mymirror/mirror_fix
{
qer_editorimage textures/tests/qer_mirror
portal
q3map_nolightmap
{
map textures/tests/qer_mirror
blendFunc GL_ONE GL_ONE_MINUS_SRC_ALPHA
depthWrite
}
}

Then save the file as mymirror.shader under base/shaders. Also add "mymirror" to the shaderlist.txt. In radiant you should now find mirror_fix texture under mymirror (which is totally black but that's ok). Try applying that and see if it works. Use only 1 misc_portal_surface entity.

Im my case, this texture seems to work everywhere now. :eek:

edit:

-bug fix

Luvac Zantor
06-21-2002, 06:06 AM
I will test now and post my findings

*crosses fingers*

Luvac Zantor
06-21-2002, 06:12 AM
when i add mymirror to the shaders.txt file

system goes away from an option under textures and mymirror shows up

if I load mymirror, it doesn't load any textures. Maybe I'm not following your instructions

Luvac Zantor
06-21-2002, 06:14 AM
ok if I "list directories" i can load system from there

if I just click textures and look at the list shown immediately there... system is removed.

wierd, but I think i found the work around,, going to compile now

Luvac Zantor
06-21-2002, 06:18 AM
it's fixed

works like a charm. My next goal after finishing this mapping is to learn shaders better.

Thanks!! as you can tell, i've been at it all day. I suspected shaders, but to be honest, don't grasp them completely yet.

Time that I do.

Xcom
06-21-2002, 06:18 AM
edit:

Oh, you fixed it. Phew. Glad it worked. :D