PDA

View Full Version : Assimilate error. What am I doing wrong here?


VampireHunterD
06-21-2002, 07:58 AM
I did everything I was supposed to that involved getting
a player model into the game. I followed Tim Spacermonkey's
tutorial steps exactly.

But when I run assimilate and try to convert it to .glm, it gives
me this error:

lleg_eff and rleg_eff not found.

What does this mean? Am I doing something wrong here? If
I am, please let me know.

Madjai
06-21-2002, 08:02 AM
well it seems like your missing two things, one for each leg...
im not sure what they are, could be tags or something...
eff doesnt sound familar

Duncan_10158
06-21-2002, 09:05 AM
Thats easy to fix.

first you need to have original model, for example that of the stormtrooper, saved as .max file. if so open your model and do merge in the file menu. from the following list highlight these two things and click on select. the two bolts will be added to you model. find them (somewhere at the legs) bring them in place, weight them and your problem is solved.

I hope that helps you.

sithlord-II
06-21-2002, 12:03 PM
however you are missing one important thing about those names: those are not tags, those are end effectors for bones.

I remember you were talking about deleting bones from the skeleton. Assimilate does not like that, i learned that by deleting the face bones one time with exar, and it did not bode well.

VampireHunterD
06-21-2002, 12:44 PM
But I didn't delete any bones from the root.xsi. I also went back
and checked to see if those parts were missing.

I found out that those parts were bones and they were still
in the model. So why does it keep saying they're not there?

I also tried the merging thing, it didn't work at all. I got the exact
same error as I did before.

VampireHunterD
06-21-2002, 03:55 PM
bump

alaris
06-22-2002, 02:27 AM
some of the error messages in assimilate aren't very helpful. I got a similar errors about various different bones.

Try this.
1 Hide everything except the mesh.
2 Select the whole frickin mesh.
3 unhide the pelvis bone
4 Assign a skin modifier and add only the pelvis bone.
5 Take the envelopes on both ends and wrap that sucka around the whole mesh
6 Export away.

If assimilate gives you no errors this time, it is a weighting issue, and you need to find the prob or just reweight the WHOLE mesh. pain I know, but assimilate doesn't actually tell you the correct bones that need reweighting.

If you did deleted ANY bones at all (excluding root.xsi skeleton) I would delete all bones and re-merge the root.xsi skeleton.

alaris
06-22-2002, 02:38 AM
let me clarify step 1---hide the skeleton, so when you select the whole mesh, the tags will be selected as well.

aL BeasTie
06-22-2002, 02:45 AM
sorry I can't help, but I was wondering what you were working on and whether it's a starwars character, if so can I include in the WIP section at www.jk2models.com ?