PDA

View Full Version : Map to Bsp ????


Kyle_KatarnJedi
06-25-2002, 07:26 AM
how do i convert the .map to .bsp thanks
:vadar:
:duel:
:lsduel:

RichDiesal
06-25-2002, 07:39 AM
Compile.

BSP Menu -> Choose One.

More questions = http://richdiesal.jedioutcastmaps.com/tutorials/gc102lsn2.html

Grets Sirob
06-25-2002, 07:41 AM
K in the editor, you should see a drop-down menu, called "BSP"(or something like that...)
Go into that menu. You should see a bunch of non-sensical(at least for now) options. Choose the one called "FullVis"
A dos window will open, do not close it, it's bsping. When it's done, it should say "finished" at the top, now you can close it. Then, go into the game bring down the consel in the main menu, and type in "map (mapname)"
If it says "could not find maps/(mapname).bsp" then type in "sv_pure 0" and then "map (mapname)"
That's to test it. If you want it slelectable in the game menu, that's a whole different topic entirely. Ask in a new thread, or find a topic about the same thing.


Dang you rich! At least I had a more detailed explaination though...




:dangit jk2.net, make smilies for the ranks!: Grrarroooaaar!!!

RichDiesal
06-25-2002, 07:56 AM
I dunno, my link is a bit more detailed than your explanation. :p

Grets Sirob
06-25-2002, 07:58 AM
But he doesn't have to go through all the work involved in clicking on that link, and then trying to find the thing, geese, makes me tired just thinking about it...




:dangit jk2.net, make smilies for the ranks!: Grrarroooaaar!!!

Kyle_KatarnJedi
06-25-2002, 09:37 AM
i was using rich's tutorial and i accidently changed the project settings. Now when i startup radiant, it does nothing.

RichDiesal
06-25-2002, 03:34 PM
How did you do that when trying to compile? :p

Go through the tutorial that actually tells you how to set your project settings (GC101:Lsn2 I think) and make them like those.

Make sure to convert your path to the right one tho.

Kyle_KatarnJedi
06-25-2002, 11:54 PM
Works now...but when i go to complie firstmap.map the dos window pops up and then says finished....I assumed that it was finished so i closed the window. Now when i go to play it it says map not found. I looked in Game data\base\maps\ and i have firstmap.bak THis is where i need help

ellwood25
06-26-2002, 06:33 AM
hi there,
i just got a similar problem and partially solved it. if i have a error in my map my editor will quit the bsp command with no error message, a very short runtime (less than a minute) and without creating the .bsp! errors can be leaks, or structural brushes touching the ´outside´...
to make sure you don´t have a problem in your map
try building the simplest map there is: one room, light, player start. there is plenty of advice in the forums how to do so. then try to compile it.
if this works you should have generatet a
yourmap.bsp in your maps directory automatically!
this will also mean you have an error in the map you tried to compile beforehand. this is when partially solved becomes important: i don´t know how to find errors in huge maps effectivly. you could start by making prefabs (like saved parts of your map) and test them individually...
other than that i dunno
cheers

Kyle_KatarnJedi
06-26-2002, 07:39 AM
This is from Darth Knight :

If evrything is at the default place then do this...

To set up your project settings. Open up radiant and go to File>Load Project and then find the Tools directory and select the .qe4 file that you need. If you're gonna map for single player, then select StarWars.qe4 and if you're gonna map for multiplayer, select StarWarsMP.qe4. This will setup your project settings correctly for you assuming you have the game installed into the default Program Files directory. You'll need to restart Radiant afer you do this.

:jarjar: Mesa So Stupid