PDA

View Full Version : bsp compiling problem AGAIN!!


Syntax
07-06-2002, 08:22 PM
I am officially jinxed!

having switched to using the gtkradient instead of the jk2 radient due to bsp compliling problems. i am now getting problems with gtkradient when compiling.

When i compile everything works fine but alas NO BSP, this is driving me mad. It was working fine yesterday but in the space of 10 hours with the computer turned off it has managed to break itself

here is the readout from the junk txt file it creates, this is what seems to be the problem in my book:

WARNING: Couldn't find image for shader noshader
WARNING: node without a volume
node has 1 tiny portals
node reference point -6363.87 -2632.08 222.00
**********************
******* leaked *******
**********************
NumPoints (87) exceed MAX_POINTS_ON_WINDING (64). Sample points: (-12382.00 8712.00 514.00) (-12970.00 8714.00 514.00) (-13456.00 8714.00 514.00)
SoF2Map v1.0c (c) 2000 Raven Software Inc.6

the whole file can be found here:
http://hosted.barrysworld.net/soharditsstooscary/junk.txt

any suggestions? ive reinstalled a number of times now and it still doesnt work

la$her
07-06-2002, 09:30 PM
Firstly, you need to fix the leaks. You should get a huge red line going through your level in the 2d view indicating where these are. Secondly, I think the MAX_WINDING_POINTS error is because a brush has too many vertices - feel free to correct me on this one if I'm wrong - so basically you have a brush that's too complicated for the engine to handle and it goes a bit mad.

As for the 'can't find shader <whatever>' line, I get that almost every time I compile - haven't been able to figure out what causes it, but then again it never causes me any problems, so maybe just ignore that one for now and go the first two.