PDA

View Full Version : disabling cheat protection?


scribble
07-08-2002, 09:10 AM
how do you do it? i tried to bind devmapall to a key, but it didn't work. i want to remove cheat protection period.

Joben
07-08-2002, 10:01 AM
:rolleyes: This wasnt exactly worth its own topic, just look around dude.

type either Devmap or helpusobi 1 into the console.

Wes Marrakesh
07-08-2002, 11:46 AM
i have found that:
devmapall only works in sp
helpusobiwan 1 DOES NOT work in either,
for mp cheats it is devmap *mapname*
so if you wanted cheats at bespin streets in mp you would type in console
devmap ffa_bespin

scribble
07-08-2002, 12:05 PM
*sigh* ok. people. your advice is well and good. but this is what i really want to know. is there a way to SHUT OFF cheat protection. for good. so you never have to do anything to it again. no tilde no typing, just excise it out of the overall program. there must be a string that controls the cheat protection measures inside the game files themselves. i am just not sure where to look.

Wes Marrakesh
07-08-2002, 12:06 PM
i think if that is possible at all it would be acomplished by fiddling with the coding and i'm not sure that is a good idea b/c you could totally screw your game

RichDiesal
07-08-2002, 01:12 PM
Only with coding. You could technically write it into the config files, but the map/devmap commands override that anyway.

When you load map, just type "devmap mapname" instead of "map mapname" and you'll be in cheatmode automatically. Not hard. :)

Graphicsgod
07-08-2002, 09:08 PM
I've been having a problem with "g_dismemberment 10 or 2", or what ever.

Every time I put that into the console, it says it's "write protected", yet when I check all files and folders in that dir. they are not "write protected". I'm also having the same problem with Quake3. Both programs just spontaniously started giving me "write protected" errors when I use a cheat.

Any ideas?!!? Please!! I miss chopping up the characters in JO :(!

RichDiesal
07-09-2002, 01:32 AM
Just load the map in cheat mode and you should have access to all commands. (i.e. if you want to play bespin_streets, pull down the console at the title screen and type devmap bespin_streets) Also try using g_saberrealisticcombat

Arkule
07-09-2002, 02:58 AM
If you really want to disable cheats, just open up the source code, goto the "game" project, open up the file g_cmds.c (i think), look for the function that returns whether cheats are allowed, i think its CheatsOk or something, and make it always return that cheats are allowed.

Smart_Saber
07-09-2002, 04:21 AM
Originally posted by Wes Marrakesh

helpusobiwan 1 DOES NOT work in either,


You wanna know why? Because the cheat is "helpusobi 1" not "helpusobiwan 1"

Wes Marrakesh
07-09-2002, 04:43 AM
i think that was only a typo just then
i certanly hope it was!:o :D :lol:

Joben
07-09-2002, 05:20 AM
o ok...

Just add the line "helpusobi 1" into your autoexec.cfg file.
the cheats will get enabled during startup every time.
Thats how you do it for singleplayer anyway...