PDA

View Full Version : two questions: Water and Meshes


Karshaddii
07-10-2002, 10:58 AM
Ok--

Im making a cave--and having problems.]

(1) My patchmeshes on the cave walls and floors are bright--seem to be almost like shaders--like there giving off light. I'm using the yavin/rock_2 texture for the meshes--which isn't a shader. How do I make them--well--not bright?

(2) Having problems with water--I seem to have chosen all the Yavin Waters and tested them--but none of them seem to fit.

Soooo

Whats a clear water shader--one that acts like water--but doesnt show up--is perfectly clear.

And what is the water that Raven/Lucasarts used in Yavin_Final on either side of the ramp--at the beggining. You know, that crystal clear green water?

If you guys could solve my problems I would be most graetful.

Karshaddii
07-10-2002, 12:42 PM
And if I could also learn to spell--that would be great as well. Then grammar would make more sense.

winner_rex
07-10-2002, 12:57 PM
Try the darker yavin rock. I don't know why, but it's unlit.

Try the Bespin set for a water texture--should work.

Dunno about that green water

Karshaddii
07-10-2002, 09:20 PM
Well thanks, the rock suggestion DID work--but it was actually the lighter rock that didn't light up--for futer reference.

And the water is a just a problem period---some water I choose acts like water--but appears black with a white, glowing grid. Does anyone know what causes this?

Karshaddii
07-11-2002, 01:05 AM
I would like to know how I have so much trouble getting people to answer my questions--add that to my list of questions

And thanks a bunch winner_rex for sacrificing 2 mins of your time to keep me from committing suicide from frustration.

Kyle_KatarnJedi
07-11-2002, 01:58 AM
use bespin/water2

winner_rex
07-11-2002, 02:14 AM
no problem

Karshaddii
07-11-2002, 02:18 AM
Still no luck with bespin/water_2

There must be something else wrong---

You can place light entities inside water brushes right???

Hmmm....Can you place brushes inside a water brush?

RichDiesal
07-11-2002, 03:47 AM
Light are no problem...

And you...CAN...place other brushes inside a water brush, though it's generally not a good idea. What problem are you having with it?

Karshaddii
07-11-2002, 05:11 AM
Ok, My water--no matter what kind it is--does one of two things.


(1)--it does not act or look a thing like water--instead it acts as a giant hole in the void--I AM using caulk as the inside and applying water texture to the top and bottom of the brush.

(2)--It acts somewhat like water on the top--splashes and ripples--but does not act like water on inside--you fall right through to bottom....plus the top is black with white, glowing lines in a grid pattern.

RichDiesal
07-11-2002, 11:48 AM
How strange. Try covering all sides of a brush with bespin/water2 and see if that works.

Emon
07-11-2002, 12:59 PM
Yeah, I think water brushes have to be textured all the same.

Karshaddii
07-12-2002, 04:51 AM
You mean it has never done that for you RichDiesal?

Strange...

Well, anyways, its working now. And I have NO clue why--Maybe cause I compiled it in JKRAD instead of GTK...

I wish so bad that the navigation in the 3d vied in JKRAD was a good as the nav in GTK

Then I could work in JKRAD--which seems to be much more suited for JKII editing then GTK.


Thanks for all yalls help.

RichDiesal
07-12-2002, 05:12 AM
Never had that problem... but I've never used GTK. And you don't need to texture all sides of a water brush with water in JK2... maybe that's just a GTK oddity. Everyone I've heard having problems with water brushes was using GTKRadiant. :)

Emon
07-12-2002, 05:48 AM
It's impossible for GTK to have that problem and JK2Rad to not. Maybe if each editor used a different version of sof2map, but they don't.

Grets Sirob
07-12-2002, 07:08 AM
Rich, I figured out my water problem.
A simple reinstall of gtk fixed it, it also gave me back all my shaders, and shows white lines around the shaders.
Now I just need to find a good water shader(maybe bespin/water_2...)...




:emperor: I shall rule the galaxy.

RichDiesal
07-12-2002, 10:14 AM
Originally posted by Emon
It's impossible for GTK to have that problem and JK2Rad to not. Maybe if each editor used a different version of sof2map, but they don't.
Well whatever. :p I'm just saying...

It is possible that GTK is giving some "invisible" properties to the brushes that makes water compile incorrectly.

Someone sent a map to me with water brushes he made in GTKRadiant with nonworking water. I moved two of the water brushes - literally moved then 5 grid units one direction and back again - and compiled. Worked fine.

Sent it back to him, and it compiled fine for him after that too.

*shrug*

:)

And yes! bespin/water2 is my favorite stock water. :p

Karshaddii
07-13-2002, 12:11 AM
This is just peachy---

In GTK:

my water no longer works at all
my meshes do not show up at all
half of my textures are missing
most of my models are missing

In JKRad:

navigation sucks
no matter what settings I choose, models ALWAYS show up as solid boxes
My hint, trigger, and clip brushes all dissapear as soon as you place them--but continue to work--but are undeleteable
all my models are missing from my maps.

In Outcast--

I cannot take screenshots. Period. They take only 1/4 of the screen--same with levelshots--and I even tried special software which takes screens exactly how they show up ingame (fraps).

No luck.

Ingame SP the screen tears--making gameplay impossible without me getting to nautious to continue.

You know when two brushes with two different textures are placed inside each other--they cause that flashing?--well guess what--for some reason that doesn't happen to me--but when I made a few errors like that in my maps they all showed up for my friends.

I swear--Massassii Catacombs is never going to get finished if I keep having problems like these.

You know what the worst part is?

----It all worked just FINE----and NOW it doesn't

And no--re-installing Outcast, GTK--JKRAD--DX8-and my video drivers does not help.....which makes these the wierdest bugs of all time.

I give up.

If anyone would like to take my MP Map I have been working on--fix it up a bit--and publish it--they are more than welcome to take half credit--even thought it is basically a finished work.

Cause I sure as heck can't finish it like this.