PDA

View Full Version : The Raven's Claw Doesn't Show Properly In My Mod -- Why?


Listlurker
07-10-2002, 12:40 PM
Okay, I'm no noob when it comes to modding, but I'm no expert either, and this one's got me totally stumped.

Whenever I put the Raven's Claw ship model into my map, it shows up fine in the Radiant preview window (all properly textured), but when I actually load my map, only the engine and tail textures show up -- the fuselage (body) and the cockpit textures don't show up at all -- they're replaced by a flat black color.

I know better than to sub the physics model for the actual model, so that's not the issue.

I've tried everything I can think of, but nothing has changed; the ship still won't show as properly textured in-game. Any of you Yoda-level modders out there have an idea what's wrong here? I can't fix the problem if I don't know what's broken.

Thanks for your time and attention,

Listlurker

Emon
07-10-2002, 02:12 PM
It's because your map is for MP, is it not? Go download the new Raven's Claw prefab from like www.jedioutcastmaps.com and that one should work in MP.

Listlurker
07-10-2002, 02:30 PM
Thanks, Emon, but my map is set for SP not MP.

I will look into using the prefab you mentioned, but I'd prefer to have the game itself carry the model, rather than having to jam one more thing into the .pk3 add-on.

I appreciate your speedy response, though. Thanks again!

LL

volrathxp
07-11-2002, 12:12 AM
i'm the one who converted that for usage...

some things you should know about the Raven's Claw model:

sometimes it just doesn't work. there's an issue w/ the shaders as well as the texture references in the model. they reference .tga files on the engine body and fuselage so the game doesn't find them sometimes. i wonder how they got it working in real single player. it baflles me. i did figure out one thing: when i converted it and moved it to another folder it worked great.

it's still something i've been meaning to go back to, just haven't had the time to yet (i.e. Neverwinter Nights/Mod/CTF Map take all your time away if you get the drift).