PDA

View Full Version : following Spacemonkeys tutorial-assimilate problem


Bucke
07-18-2002, 05:11 AM
"Extract humanoid.gla to your own base/models/players/_humanoid/ folder. Now we have our folder structure and we can export our model (xsi format) your own folder. Save your model as root.xsi into your own modelís folder. (e.g. models/players/aurra)

Open assimilate - the front end program for the compiler carcass. Select the add file option and add the humanoid gla. Go to the control panel and press B - for build and assimilate will ask you what you want to save your .car file as. You can save it as anything you like, but I recommend you save it as model.car in your folder. Then carcass will compile everything. If thereís an error it will tell you so that you can fix the problems."

i followed the above but when i try to add the humanoid.gla file in assimilate it comes up with an error and says file not found - even though i extracted it and put it in the right directory. i even tried renaming the file to "humanoid.gla" as oppossed to "_humanoid.gla" but i still cant get it to work.
does anyone know what i might be doing wrong?

Psyk0Sith
07-18-2002, 01:13 PM
hi,

open assimilate, go to edit then preferences,
add the path where your carcass compiler is located:

eg. c:/base/models/players/_humanoid/carcass.exe

remove everything in the "Quake Dir path"

to make sure i dont get things mixed up, i created the base folder straight on the root drive...some people had problems but it works for me.

when using assimilate i always have to load the gla file or else it wont work.

hope this helps.

Bucke
07-19-2002, 05:18 AM
Originally posted by Psyk0Sith
hi,

open assimilate, go to edit then preferences,
add the path where your carcass compiler is located:

eg. c:/base/models/players/_humanoid/carcass.exe

remove everything in the "Quake Dir path"

to make sure i dont get things mixed up, i created the base folder straight on the root drive...some people had problems but it works for me.

when using assimilate i always have to load the gla file or else it wont work.

hope this helps.
thanks for your help but....

well i copy pasted the carcass.exe into the humanoid folder

the preference window of Assimilate
views like this

Enum File: w:/bin/gamesource/anims.h

Buffer: 4906

Compiler: c:/program files/lucasarts/star wars jk ii jedi outcast/gamedata/base/models/players/_humanoid/carcass.exe

Quake Dir: (blank)

Multiplayer: (unticked)

i then start it up and
when i try to add the GLM file it says
error: GLA File"models\players\_humanoid.gla"not found

i didnt undertstand what you meant about the "root drive"
am i doing anything wrong?

Psyk0Sith
07-19-2002, 08:15 AM
1.create this directory tree:
c:/base/models/players/_humanoid/
(root drive means c:\)

next you put the gla file in the _humanoid dir
(c:/base/models/players/_humanoid/_humanoid.gla)
then carcass...
(c:/base/models/players/_humanoid/carcass.exe)

2.Not sure if this makes a difference but i installed the raven tools in that same directory:
c:/base/models/tools

3.Open assimilate (preferences), add the correct path for the compiler:
c:/base/models/players/_humanoid/carcass.exe

Quake 3 Dir is blank...
leave the other paths to default.

i then start it up and when i try to add the GLM file it says...

you meant GLA file right?...GLA and GLM are not the same thing

GLA is the anims and GLM is the compiled mesh, which is pretty much useless for carcass.

sorry if i wasnt too clear the first time, try it this way and let me know if it worked.

MacD
07-20-2002, 10:38 AM
And don't forget carcass doesn't like spaces in a directory name.