PDA

View Full Version : Old problem solved, final hurdle! Help, please, someone!


JRA_Wolf
07-21-2002, 02:44 AM
sigh...I get that error whenever I try to make saber hilts, as well...noone seems to know how to fix it either :/

MacD
07-21-2002, 08:04 AM
Hmmm. I've been rooting around in some other model.glm files (well, one; jar jar's :) ) and I've noticed that that contains all kinds of references to .tga's. So does the default_model.skin file. But the pk3 also only includes .jpg's!?!

My default_model.skin look alright (correct paths, correct jpg names), and the .glm contains [nomaterial] for bones and bolts, while the tags and actual bodyparts refer to my jpg's, instead of tga's like jarjar. I used the jpg's in 3dsmax, and they're in the correct folder...I just don't really know where to go now...except for maybe changing the textures I'm using in max to .tga's...but then what would I include in the pk3?

Does anyone know what the **** is going on? Any ideas on how to fix this?

Also, I just mapped the tags and the body meshes (head, torso etc.)...should I also map the bolts and stuff like stupidtriangle?

Oh, I also collapsed the UV maps on the caps and the geometry...

MacD
07-21-2002, 09:39 AM
I've been working on my Battle Droid for a while now. Looking at it run in modview is just a'ight! Here it is (with it's temporary skin):

battle droid (http://macd.netfirms.com/roger_mk5_4.jpg)


But now I have yet another problem :) : When I try to see my model in modview, I get an error with my skin. When I open it the model.glm, I get this:

"JPEG read error: requested feature was ommitted at compile time"

The model shows up all white (you know the colour :( ). The odd thing is, assimilate did write a propper default.skin file.

Then, when I pk3'd the file (for the hell of it, just to see what would show up), I could see my headshot, but when I selected it, JK2 errored out to the console you see just before startup, with same error msg.

Blast! Just running animations in modview, it looked SOOOOOOO SWEET!

Anyway, does anyone know what might be the problem here? Could it be that I have to set up something in the model.car file (I used silentmobius' method)? Or is there something else I could set up in assimilate?

Twisted Vertex
07-21-2002, 11:28 AM
ARe the texture maps the right size. 512x512. The file names in the .skin can be tga or Jpeg.

Contact me on msn....I will be able to help you troubleshoot it more.

Joe@williamirvine.com

MacD
07-21-2002, 12:09 PM
Thanks for the help, but I've solved it in the meantime; I replaced the jpg's with tga's, and now it works! Check my new thread :)! YEHAW!