PDA

View Full Version : In need of serious help.


Phr00t
09-07-2002, 11:40 PM
I'm having trouble compiling my vm files. I've tried all the updated Batch files, reorganized directories, and I still can't get it working. Could someone go through a step to step walkthrough of how to get it working? Thank you.

Azymn
09-08-2002, 12:39 AM
You're compiling JediMod, aren't you?

Phr00t
09-08-2002, 01:04 AM
No.
Just a simple mod I made. Trying to make VM's.

Azymn
09-08-2002, 01:44 AM
Oh....sorry. I assumed that because there are a number of exceptions when compiling it.

Anyway...

Tell me if you're following these steps:

1) Open a command prompt
2) Change the command prompt to the directory you're working in (like game, cgame or ui)
3) type game, cgame, or ui (this runs the batch file), according to the directory you're in

Is that what you do?

Phr00t
09-08-2002, 02:49 AM
Yes. It keeps giving met his error:

compiling g_main.c:
C:\MOD\SOURCE\LCC\BIN\LCC.EXE: cpp: No such file or directory

Primesghost
09-08-2002, 04:04 AM
Bo to the path:

C:\MOD\SOURCE\LCC\BIN\LCC.EXE

and make sure the file LCC.EXE is there. If it's not, then find it and put it there. (it should be somewhere in the "mod" folder)

Azymn
09-08-2002, 04:31 AM
If you're running Windows, get the old, original batch files from the SDK.

Try the oldest batch files you can find.

Phr00t
09-08-2002, 04:51 AM
Primes: LCC is there, but for some reason it's having difficulty finding the CPP file that's in the same directory. I don't know why...


Syrup: I've tried the oldest and newest versions of batch files, none work.

Azymn
09-08-2002, 05:02 AM
Hmm...i had the exact same problem, and i re-extracted the original SDK and used those batch files, and it worked.

The Eternal
09-08-2002, 09:42 AM
if the path is in any way not set to that directory it can't find them indeed. just add the folder with lcc.exe etc. to the path and you should be fine. else you did something weird ;)

Phr00t
09-08-2002, 01:59 PM
Eternal: You talking to autoexec or something?

ASk
09-08-2002, 02:25 PM
Well, you can execute a set path command before compiling, it does not matter. just insert it into the batch file before any reference to lcc/cpp

The Eternal
09-09-2002, 01:17 PM
that's another possibility :P
batches are slow anyway... you should ALWAYS use dll compilation untill you're releasing the mod...
(you should check once in a while if you coded some QVM incompatible stuff tough)

The Eternal
09-09-2002, 01:20 PM
and phr00t, i use windows XP, it uses a diffrent way of setting the path variables (so does windows 2000)...
it's somewhere in the system option in the config screen.

if you're using windows 9x you can add it into the autoexec.bat indeed..
(PATH=%PATH%;C:\jedioutcast\GameData\bin) for example

Phr00t
09-09-2002, 03:14 PM
Thanks for that path stuff, that worked...

Now just wait for my simple stupid mod :P

(First Person MP Sabers)

hehe