PDA

View Full Version : CMI/Grim Fandango on Win2k


marklittle
09-16-2002, 12:36 PM
Hi! I know there's a patch to play CMI on w2k. I saw a link in the scummbar's archive but it's broken. Does anyone know where to find this patch?

Thanx

Marklittle

MrManager
09-16-2002, 01:05 PM
Try this: http://www.lucasforums.com/showthread.php?s=&threadid=71839

marklittle
09-16-2002, 01:40 PM
Thanx for the Tipp, but that's not exactly my problem. I just try to run the CMI Webdemo and as an answer it appears a message which says that DirectX is not installed (I installed version 8.1b). If I try to launch from the executable I see just a black splash screen and then the whole goes back to windows.... NO IDEA!

Cheers

Marklittle

MrManager
09-16-2002, 02:03 PM
Moved to Help forum. Could be somebody have had the same problem.

marklittle
09-16-2002, 03:05 PM
Tnx. Let's wait for somebody to come...

bgbennyboy
09-16-2002, 04:26 PM
Im sorry but I cant help here.
Ignoring the launcher problem I cant get comi.exe to run properely, same issues as you.

Skyfox
09-16-2002, 07:05 PM
Ok, ok.. i know the answer to this one... but I am a little fuzzy on the filename aspect as i have not used it in ages.

But basically, all you need to do is create a blank text file and name it as dxhelp.exe
Put this in your windows/system32/ folder and it should work perfectly.

the thing is, i can't remember the file name exactly. i think it is dxhelp.exe but I am not 100% sure anymore. Shall look into it.

But the solution really is that simple.
All the Best
~Skyfox

bgbennyboy
09-16-2002, 07:17 PM
Ooh great stuff!
dxhelp.exe doesnt seem to be the right name.

Heh and I was only just saying, I cant wait to see what mad solution someone comes up with to solve that problem......

marklittle
09-16-2002, 07:48 PM
Doesn't work for me too...

I'm sure u can remember that name... I propose u not to sleep this night, ok? ;)

Cheers

Skyfox
09-16-2002, 07:50 PM
or maybe it was in the windows folder directly... stupid brain! try that and let me know if you have any success

UPDATE: ok, i think it is DDHELP.EXE in the System32 folder, pretty sure of that now... well, 75% sure

Let me know!

bgbennyboy
09-17-2002, 04:03 AM
Pre-uni update, im going to miss my train here I can tell.
Yep, works for fixing the launcher, unfortunately it then goes on to launch comi.exe which still doesnt work.
I'll have another mess with it tonight to see if I can get it working.

scabb
09-30-2002, 07:15 PM
I too have had this problem, only with Grim Fandango, and creating the dummy 'DDHELP.EXE' file didn't help. :(

I have searched the web for answers, and RemiO kindly pointed me to this site (http://www.ntcompatible.com), which you may find useful.

On another note...one bgbennyboy (You may have heard of him ;)) used his majestical Microsoft prowess to try and help me, and one of the things he mentioned was a Compatability mode. Now, Im using 2k (Service Pack 3), and didn't know that this actually existed for 2k. But you can get a tool kit here (http://msdn.microsoft.com/compatibility/act.exe ), and tinkering around may help.

In my case, If I run DXDiag.exe (Found in the Grim Fandango Folder), I do find that I have some DirectX files missing - you can create a TXT file with the details, which may help the...erm...helpers (bg)

For instance, I have missing:

ddraw16.dll: <File Missing> Date: Size: 0 bytes
ddraw.vxd: <File Missing> Date: Size: 0 bytes
dxapi.sys: <File Missing> Date: Size: 0 bytes
dinput.vxd: <File Missing> Date: Size: 0 bytes
vjoyd.vxd: <File Missing> Date: Size: 0 bytes
msanalog.vxd: <File Missing> Date: Size: 0 bytes
gchand.dll: <File Missing> Date: Size: 0 bytes
dxsetup.exe: <File Missing> Date: Size: 0 bytes
dsetup.dll: <File Missing> Date: Size: 0 bytes
dsetup16.dll: <File Missing> Date: Size: 0 bytes
dsetup32.dll: <File Missing> Date: Size: 0 bytes


If anyone can help me, then please go right ahead.

Well, I hope you enjoyed all this information, although it will probably just add to the headache level of the helpers/helpees.

I'm going to tinker with my "Application Compatibility Toolkit", Ill update you on the progress I'm making, like it or not.

EDIT: For those that you who are bi-curious, this may or may not be a necessary fact.
I have a NVIDIA RIVA TNT2 Model 64/Model 64 Pro.
Hurray for budget graphics cards.

bgbennyboy
09-30-2002, 07:39 PM
Ok, deep breath <> here we go.

Ignore dxdiag in the grim folder its an old directx5-native one.
If you want to run dxdiag, Start>Run>dxdiag
The application compatibility toolkit can be a real pain in the arse. Good luck with it:p

Now, I remember similar problems with Grim when I tried to get it working on XP but I did get it working. There are quite a few ways to start/alter Grim (most of which ive already gone over with you:D ).

Tomorrow is my 'hefty day' at uni but when I get back i'll uninstall Grim and reinstall it, test the various methods and post back here.

scabb
10-01-2002, 04:37 PM
Originally posted by bgbennyboy
[B]The application compatibility toolkit can be a real pain in the arse. Good luck with it:p [B]

Update: The application compatibility toolkit is a real pain in the arse, and I haven't managed anything with it yet.

BG: Thanks for helping me out, I look forward to your reply

Admins: Wouldn't it be a great idea if these posts were neatened up and archived?

bgbennyboy
10-01-2002, 06:08 PM
Yeah I probably should post some more stickys for different games i'll get round to it.....eventually.

Right, Grim Fandango!
I'll fill this in as I go along (remember I am using XP though):
The solution to your problem with Grim exiting on the loading screen can be solved I think by running in software mode.

1)After uninstalling Grim deleting all registry keys and re-installing I start Grim.
2)It loads fine, in the options, 3D Hardware Acceleration is off and its running in software mode. I assume that this is the default state for Grim to be in so perhaps you are already running in software mode (obviously you cant get far enough into Grim to see).
3)I turn hardware acceleration on and switch to direct3d acceleration instead of software. I exit and restart - it works fine! I dont remember it being like this when I last installed it, hmmm.
4)I remember you installed the patch (ftp://ftp.lucasarts.com/patches/pc/Gfupd101.exe) so I do too.
5)I make Grim as I previously had it - with the data files on hd so I dont need the cds. From the CD1 GRIMDATA folder I copy Data001.lab, Data 003.lab, Movie01.lab, Movie03.lab, Vox0001.lab, Vox0003.lab, Year1mus.lab, and Year3mus.lab to my Grim folder. From the CD2 GRIMDATA folder I copy Data002.lab, Data 004.lab, Movie02.lab, Movie04.lab, Vox0002.lab, Vox0004.lab, Year2mus.lab, and Year4mus.lab to my Grim folder.
6)I remove the cd's and start the game. Doh, it wants the cd in.
7)I start regedit (Start>run>regedit)
I go to /HKEY_LOCAL_MACHINE/LucasArts Entertainment Company LLC/Grim Fandango/v 1.0/
I add a new string value called "good_times" (without quotes)
I set the value of this to TRUE
I start the game. All is fine.
I can also now run in windowed mode by selecting DIBsection windowed display in 3d hardware setup.
I can also run in a window by starting with the -w parameter eg. Grimfandango.exe -w

Okely dokely you can try all those things in order, ive listed all I can think of.
The only other thing I can think of is modifying registry values to make grim start in a particular mode. These values *may* not work for you since they may be dependant on the 3d hardware in your machine but you could give them a try.

So in /HKEY_LOCAL_MACHINE/LucasArts Entertainment Company LLC/Grim Fandango/v 1.0/


Fullscreen Software mode:
Last3DDevice key: all 0's
LastDisplayDevice key: all 0's

Fullscreen Hardware mode:
Last3DDevice key: e0,3d,e6,84,aa,46,cf,11,81,6f,00,00,c0,20,15,6e (the commas just seperate the hex values obviously).
LastDisplayDevice key: all 0's

Windowed mode:
Last3DDevice key: all 0's
LastDisplayDevice key: 00,9f,a6,92,fa,13,d1,11,97,c0,00,a0,24,29,30,05 (again the commas just seperate the hex values).

I can export the reg keys and put them up for download if you cant change the values yourself.

Hope this helps, I cant think of anything else.

megumi
10-22-2002, 06:46 PM
bg, I'm having Grim problems similar to scabb (although I'm running Win98SE) and I followed all the directions you gave. But, I don't know how to do that last part about the Software and Hardware mode registry entries. (Although I did know enough to get the good_times string entered.) Could you please post those registry keys you mentioned?


I posted my problems in a forum the other day http://www.lucasforums.com/showthread.php?threadid=81621

bgbennyboy
10-22-2002, 08:18 PM
Remember that the registry keys thing is a last resort, ive no idea if it'll work, also keys may be different on different systems.
Here's my keys (http://www.gorman.btinternet.co.uk/GrimRegKeys.zip)

Once youve made the good_times key you can also can also try starting grim as:

grimfandango.exe -w
To start in a window

megumi
10-30-2002, 05:53 PM
thanks for the registry keys, but it didn't help. by the way, I already had the happy_times key and have tried opening Grim in windowed mode. A blank (black) window opens and then . . . nothing happens. I've been bugging some poor LucasArts tech for a while now, but he hasn't given me more than the cut and pasted canned answers that are probably from some outdated database.

Thanks again, anyway. But I'll have to wait for GF2 (fingers crossed).