PDA

View Full Version : "WARNING: RE_AddPolyToScene: NULL poly shader"


AKPiggott
10-16-2002, 01:51 PM
I've been getting this error in my map, the message "WARNING: RE_AddPolyToScene: NULL poly shader" repeatedly comes up and all GLM files appear textured solid bright white. This only happens when I compile my map with lights (using Q3Map2). Can someone please tell me how to fix this?

WhiteShdw
10-16-2002, 02:20 PM
SP map right? Try running it in MP, just for testing purposes. It should work there. The same thing happens with some MP maps that are run in Sp. Some people say it's because of they use a lot of custom textures, but i'm not sure that's it.

If your running it in a pk3 try unpacking it. Maybe that will help.

AKPiggott
10-16-2002, 05:08 PM
Yeah.. the level is Single Player, so it's important that it runs under SP mode. All the files are unpacked already.... hmmm... is there some sort of limit to the amount of textures that a level can use? If so, that's a bit bloody stupid.

WhiteShdw
10-17-2002, 12:41 PM
mmm, that's weird. I'm currently working with Shadriss on DoTF v2 and that one had the same problem. I mean the original version had that problem. I unpacked the file and after a little editing in the map file i put all the custom textures in one directory. I can run it fine now in SP. The original map had 4 different custom texture directories and 5 different shader files. I have it now in one custom texture directory and 1 shader file. Maybe you should try that, but it's a lot of work.

AKPiggott
10-17-2002, 01:51 PM
Hmm... it seems to have fixed itself. I just carried on editing my level, inserted some new entries into my shader and it works now. Thanks for the info anyway, it may prove handy at a later.

AKPiggott
10-18-2002, 04:58 PM
The plot thickens...

I only get this error when I compile with Q3Map2. Shame, I'm gonna have to stick with SOF2Map.

WhiteShdw
10-18-2002, 07:02 PM
Well, that's weird, because i'm pretty sure some of the maps that have this problem were compiled with Sof2map. I think LDJ compiled his Episode 1 map with sof2map.

I'm using Q3map2 right now to compile the new version of that one and i'm having no problems. So i don't think it's a compiler issue. Try running the map in MP and you'll see it will run without problems(i hope:D ), no matter what compiler you use.

I still think the SP game has problems when you use too many custom texture directories and different shader files. But that's just my theory(not based on any real facts :D)

I really want to get to the bottom of this, because i saw some pics of your maps and it looked great.

Emon
10-18-2002, 08:24 PM
E-mail ydnar about it, I'm 86.52% sure he knows what it means.

AKPiggott
10-19-2002, 05:01 PM
I'm gonna stay away from Q3Map2 for the meantime anyway... it's obviously not finalised. Flicking/strobe lights in my level appear the same as normal ones.

Leslie Judge
10-19-2002, 05:42 PM
Yep, ydnar wrote the light styles are waiting for implementation.