PDA

View Full Version : useless compiles


Altus_Thrawn
11-19-2002, 07:10 PM
It seems my compiles arent doing a thing. I make changes, save, compile, save, and go in game. But the changes are not there.

legameboy
11-19-2002, 09:04 PM
in the editor, in what modwe are you editing? singleplayer or multiplayer, if your editing in singleplayer open it in single player, if your editing in multiplayer, open it in multiplayer

Leslie Judge
11-20-2002, 05:40 AM
:) OK


Altus_Thrawn, isn't your map leaked? Check the compilation results! You probably can find it in C:\WINDOWS\TEMP\junk.txt. Anywhere is, the file name is junk.txt.

Altus_Thrawn
11-20-2002, 07:03 AM
There are some leaks, but it worked before....and the compile does say junk.txt

WhiteShdw
11-20-2002, 09:03 AM
Originally posted by Altus_Thrawn
There are some leaks, but it worked before....and the compile does say junk.txt

Fixing leaks should be you first priority. Don't just continue mapping if there are leaks. Fix them first and then try again.

Altus_Thrawn
11-20-2002, 04:09 PM
There is no junk.txt in windows/temp.

Spoon_Gouge
11-20-2002, 05:35 PM
They're right you know. While it may have worked before, it's not working now. What you're seeing in the map IS in fact, your previous map. Since the compile failed, the old one was not written over with anything new.
Also don't look for junk.txt in windows, it's a temporary file under your user name ie.: "C:\Documents and Settings\Spoon_Gouge\Local Settings\Temp\junk.txt":rolleyes:

Incedently, my system is XP and the location would be similar for 2000 and I think ME. I offhand don't remember the location under 98.

Altus_Thrawn
11-20-2002, 07:27 PM
What's the easiest way to check for leaks?

WhiteShdw
11-20-2002, 08:09 PM
There is only one way to check for leaks: LOOK.

If there was a better way i'd love to hear it.

Just look systematically. Most of the time leaks occur at doors and stuff. Mostly area's where 2 rooms are connected.

Altus_Thrawn
11-20-2002, 09:49 PM
True, but if I make I large box around the level wouldn't it also have no leaks?

acdcfanbill
11-21-2002, 03:51 AM
load the pointfile... :D

Leslie Judge
11-21-2002, 04:25 AM
If you can see the progress of compiling, then there will be no junk.txt. If you can see only one line in that command prompt window ending with >....junk.txt where .... is a path, then you can find it.

And yes, load the pointfile. JK2Radiant does it for you automatically, in GTKRadiant you have to do it by selecting Pointfile from the File menu.

After this there will be a few red lines which connect the "leak spots". This will help you find out where the hole is. You can also use CTRL+SHIFT+K and CTRL+SHIFT+L to cycle through the spots if I remember. They are in the Misc Menu as Find next/prev leak spot.

SunBurN
11-21-2002, 01:43 PM
The fastest way is to run the bsp compile no vis/no light and then when it finishes, look for the (very noticable) red line that will show up in your map and run from one of your entities to the area that the light is escaping (ie your leak). You can also load your pointfile which will also bring up the "red line" in the middle of your map.

I hope this helps :)

SunBurN

Altus_Thrawn
11-23-2002, 06:21 AM
I did the pointfile and the fast compile, and saw no big red lines. I might have missed some small ones though because I have a few models. It is still not working...

Tigris
11-23-2002, 07:04 AM
Ok, try to load the Pointfile as soon as it says ***LEAKED***- then you'll see a red line: You can miss it, it really stands out ;)