PDA

View Full Version : Use on a Mac


sinclair44
12-01-2002, 11:27 AM
Screenshots look cool, I cannot wait to try this mod, however, I am having problems getting it to work on a Mac; OS X 10.1.5.

I have unzipped the Broadband archive into a 'dark' directory with all the .pk3, .cfg, .txt, etc. files inside in there. JK2 MP recognizes and loads the mod, but JK2 SP has an empty mod list. The same happens with another mod I downloaded, however, so it may have something to do with Windows-compiled mods... (but MP loads it and displayes the splash screen just fine)

Thanks for anyone's help!

sinclair44
12-01-2002, 12:03 PM
For some reason, almost every time I post a question, I find the answer 15 seconds later: after 2+ hours of tinkering, I posted that; 10 minutes later I got it running.

I found that dumping the .pk3 files into [JK2Directory]/base on a Mac and then loading JK2 SP will automatically load the mod and play the intro movie; the DF mod playes as I assume it should from there on.

Great work guys, enjoy your vacation! :p [but please get it done soon]

Darth_Linux
12-01-2002, 01:22 PM
only problem with that solution is that you have to move those pk3 files around everytime you want to play JO.

It might be an issue with the patch level of the Mac binary. Windows is at 1.03 for single player, which added a MOD directory that actually works, so maybe Mac is lagging in functionality at the moment or something.

You might try making an alias to jk2sp instaed, and specifying the fs_game variable with the value "dark"

The_One
12-01-2002, 02:00 PM
I've actually had this problem before with the PC version. I had JKII patched to the latest version and nothing would show up in the mod menu. No idea what was wrong. Anyway, I just made a shortcut and it worked fine. I think that is your best option, and you can play regular JKII aswell.

Emon
12-01-2002, 11:59 PM
Try running from a console.

jk2sp +set fs_game Dark

Or:

./jk2sp +set fs_game Dark

Or whatever you would do on Mac OS. On Linux I can do something like:

winex -flagthingforswitchesblahblah jk2sp.exe +set fs_game Dark

And that would work. Since you're probably using BASH, the first or second should work.