PDA

View Full Version : GF on windows XP


blueangel4xtc
12-10-2002, 08:32 AM
hi everyone...i tried to play GF on windows XP but after clicking "play grim fandango" button in the launcher this disappears and nothing happens... i think that's a directx problem but i don't know how to solve it... can anyone help me?
thanx a lot!

Tall Guy
12-13-2002, 06:52 PM
make sure you have the latest directx version installed.

try running the game in 16bit color mode.

see if that works first.:)

blueangel4xtc
12-14-2002, 07:57 AM
the directx version is 8.1b... i also tried to play the game in 16 bit and download the patch but it doesn't solve the problem... i think there's nothing i can do....

bgbennyboy
12-14-2002, 05:21 PM
More info needed, when you click play what happens? Does absolutely nothing happen or does it start to load the game and then exit?

Try loading the game by running GrimFandango.exe in your Grim folder instead.

blueangel4xtc
12-14-2002, 07:13 PM
When i hit "play GF" button, the launcher disappears and absolutely nothing happens! The game doesn't start... already tried to play GF from the .exe in gf folder but it's the same!!!

lucymc
12-15-2002, 02:53 PM
I had the same problem! I have XP and only bought GF about a week ago!

You need to right click the mouse on the play GF icon and then select properties, then click on compatibilty up the top right,
then select it to run in compatibility mode for windows 98/ME.
Then tick all the boxes for graphic options underneath, like running it with 256 colours etc!

Hope this helps! :-)

blueangel4xtc
12-15-2002, 05:15 PM
thanx for the hint but this doesn't work too! :(

bgbennyboy
12-18-2002, 08:55 AM
Try it without the cd in, does it pop up an error message asking for the cd when using the launcher or grimfandango.exe ?

blueangel4xtc
12-18-2002, 09:08 AM
yes it does! it shows this message: "no disc inserted"...

jburton
12-22-2002, 10:57 AM
Hi,

I've tried playing GF on XP and am also having trouble. I have tried playing it in the compatibility mode but all I get is the screen just turning black with the occasional flicker back to the desk-top for a split second and does nothing else.


Jon

bgbennyboy
12-24-2002, 07:42 AM
Until I replicate this, I cant really help any of you. For the record what graphics card do you have blueangel4xtc and jburton. Other info on your system spec would be useful too.

blueangel4xtc
12-24-2002, 12:30 PM
i have an Athlon XP 2100+, 256 Mb RAM, a GeForce 4 MX 420 video card with 64 MB ram, 80 GB Hard Disk and my OS is win XP professional... hope this can be useful!

bgbennyboy
12-29-2002, 04:43 AM
Hmm, another Nvidia graphics card. Thats the only thing ive been able to narrow it down to. Everyone ive spoken to whos had this problem in 2K or XP seems to have an Nvidia card. Unfortunately I cant really help, since I have a Radeon :p

Soiledslacks
01-17-2003, 09:23 AM
I have a Pentium4 3Ghz, 512Mb RDRAM,GeForce4 ti4600 128Mb, DirectX 9.

I get to the bit where u get in the car and drive to the poisoning and at the end of the cinematic it just returns to windows, also every few minutes or so the sound hangs. It just makes an awful repetetive noise of the last sound it was making as it crashed, i have to save quit game and load GF again to get my sound back :S and yes i have the patch :o

Soiledslacks
02-08-2003, 04:25 PM
well..........

ZaXeriaw
02-11-2003, 08:27 AM
...and it's installed correct? With all the *.lab-files?

Soiledslacks
02-11-2003, 01:15 PM
yes :(

Super
02-17-2003, 02:20 PM
I believe the problem lays in DirectX 8.1

Here is an e-mail which we recieved:

I managed to get both sound and text going in the cutscenes, after having neither since installing (and re-installing) the game and the patch umpteen times!

It was - surprise oh gee what a surprise - a DIRECTX problem.

DirectX 8.1 DOES NOT WORK WITH GRIM FANDANGO!! It just DOESN'T. This despite MS's claims of "backward compatibility" oh yeah right.

DX 8.1 will allow neither sound nor text in the cutscenes (text installed from the GFUPDATE patch of course).

The solution was (with GF installed and the GFUPDATE patch):

Remove DirectX 8.1 (I used the DXRemove.inf file that Russian dude wrote, its findable on any search engine. This is easier than reinstalling 'doze.)

Install DirectX 7.0a - this was the last version I believe before they made sweeping changes to the DX API.

(At this point had sound but it was very broken up in cutscenes and in the game).

Reinstall sound drivers.

Make sure sound devices in Control Panel -> System -> Devices had DirectSound ON.

Make sure using dxdiag that Direct3D was Enabled so that the hardware video acceleration could work.


Then it worked like a charm!

Soiledslacks
02-17-2003, 05:32 PM
I have DirectX 9 and im definately not going back to DX 7, i have graphics intensive games that depend on it. I think its up to lucasarts to release some kind of patch if that IS the problem :rolleyes:

bgbennyboy
02-17-2003, 05:34 PM
Its also worth noting that XP comes with dx 8.1 and so cant be downgraded.