View Full Version : Serv Problems [plz read!]

01-20-2003, 11:43 PM
I have an SMc router and the computer i wans to use as a firewall is set as DMZ to save some time. When i use jedi runner to set up my server eveyrhting works perfectly fine. But i can only see the server locally (because the Ip is set at, aka the local adress). I can join from my other computer and all, but it won't show on the net. when i set the Ip to the public one. (aka the one my ISP gave me) it won't show on the net and I can't connect, not evn manually. And yes i do have jedi runner set to "internet" and not "LAN" or "listen"

01-21-2003, 10:31 PM
Surely this is not a hard question to answer? maybe there is jsut too many people who don't care, either the more servers on Jk2 the more it benifeits the community. so pipe up ppl, help me out here!

01-21-2003, 11:34 PM
You'll need to open a port in NAT in your SMC router to foward UDP port 28070 (which is the default unless you have your JKII server running on a differnet port) to the internal IP address of your JKII server. Your router manual should show you how to do this. When you connect from the outside world you'll connect to the address of the router, which will foward the request to your JKII server.

Setting your JKII server's IP to the public IP given by your ISP took your computer off the network because that public IP is outside the subnet on your LAN.

Hope this helps! :)

01-22-2003, 08:35 PM
okay i think i got it, correct me if im wrong. I should make the IP in jedi runner the public Internet IP address, then configure my router so that anyhitng related to that specific port gets forwarded to the other computer local address. I tried that, but look. Shouldn't these settings work?


01-22-2003, 10:46 PM
I don't really know anything about SMC routers in particular, but it looks like that should work. If all else fails give SMC a call and say "Hey I'm trying to foward UDP port 28070 to how the heck do I do this?" :)