PDA

View Full Version : Need help with flaming beavers


dancingdead
02-15-2003, 08:41 PM
Hi All,

Finally received Grim Fandango! The demo sure helped out with the first part of Year One but now I'm stuck. I'm in the petrified forest by the beaver dam. I have a load of stuff in inventory but don't seem to use it well. I've tried using the fire extinguisher - sometimes I can retrieve it from the inventory and sometimes I have to go through so much stuff that the beavers chase me out. And sometimes the game stalls when Manny gets the fire extinguisher out. I've tried throwing bones at the beavers but then I can't seem to get the fire extinguisher out fast enough. The only other game I have is Heretic and you have a key for each thing in the inventory. This game seems to require you to cycle through each item. There must be a more efficient way to get stuff outta Manny's coat pocket. Any ideas?

Thanks,
dancingdead

Thrik
02-16-2003, 07:46 AM
You have to go down to the little area beneath the cliff thing, then throw the bones there. You then have to get the fire extinguisher out and shoot it forwards as they jump - it'll douse them on the way down.

GinnyW
02-16-2003, 09:49 AM
You can pull out the extinguisher by pressing the apropriate number. I don't quite remember, but if you have your scythe then the number's 2, and if not then 1. the numbers are according to the location in the inventory, and scythe is 1st, unless it's missing. That't how I pull things out quickly.;)

dancingdead
02-16-2003, 05:29 PM
Thanks for the help!

Just finished drowning those suckers and stocked up on some extra bones just in case. I tried the tip about using the numbers for the inventory and it works great. Thanks! This is so much fun - LOL!

dd