PDA

View Full Version : Sound in MP - Workaround Idea...


Silverhawk2000
04-11-2003, 03:35 PM
Hello all,

Iím just about to add some sound to my MP Map and I have read a few times in the forums that there is a issue with playing sounds in MP.

Specifically, that sound can not play in a continuous loop. Is this true, or has anyone been able to get the sound to play without the one (1) second delay between loops, which I have read is the case.

If there is this 1 second delay problem (Is it one second precisely?) then I have an Idea for a possible workaround to the problem.

Take the sound that you want to play, create a copy, and edit it so that there is a one (1) second duration of silence in front of the .wav or .mp3 file.

Have two (2) triggers, each targeting a separate target_speaker.
2nd Trigger is inside the first and slightly smaller (this way the player will trip the 1st one first, then the second inner trigger second.

Have the first trigger activate the regular sound.
Have the second trigger activate the copy of that sound with the one (1) second delay.

Timing may be tricky (if the interval is not exactly 1 second, or other factors), but the idea is that the first sound will play, then the second, then the first, then the secondÖ.. and so forth and so on. Thus without the delay of silence.

What do you think?

:cool:

wedge2211
04-11-2003, 05:39 PM
Originally posted by Silverhawk2000
Specifically, that sound can not play in a continuous loop. Is this true, or has anyone been able to get the sound to play without the one (1) second delay between loops, which I have read is the case.

.mp3 format sounds cannot be looped in a target_speaker without some sort of short delay. Luckily for us, many of the Outcast game sounds are in .wav format, and those loop FINE, back-to-back, no delay. (If you don't believe me then go download Mars and stand in the fan room. There's a target_speaker in there constantly playing a fan noise. There are also some humming noises in the ducts, they loop as well.)

Silverhawk2000
04-11-2003, 09:51 PM
Originally posted by wedge2211
.mp3 format sounds cannot be looped in a target_speaker without some sort of short delay. Luckily for us, many of the Outcast game sounds are in .wav format, and those loop FINE, back-to-back, no delay. (If you don't believe me then go download Mars and stand in the fan room. There's a target_speaker in there constantly playing a fan noise. There are also some humming noises in the ducts, they loop as well.)

Thanks for the Info wedge2211.

I guess i could convert the .mp3 files to .wav files, I assume you could loop them then.

:cool:

Karshaddii
04-12-2003, 03:43 AM
Remember--anything you convert from MP3 to wave is going to be many, many, MANY times bigger--so go easy on the poor 56kers ; )

Tigris
04-12-2003, 07:28 AM
Yeah- I an to be honest- especially with music you won't notice it... I tried it in ffa_cantina with the band music... But to get a good result you have to have a wav of decent length...

wedge2211
04-12-2003, 12:24 PM
Remember--anything you convert from MP3 to wave is going to be many, many, MANY times bigger--so go easy on the poor 56kers ; )

To limit your file size, try to use some sound from assets.pk3, which every gamer will already have. :)