LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   JO Mapping (http://www.lucasforums.com/forumdisplay.php?f=359)
-   -   target_print weird error (I mean: really weird) (http://www.lucasforums.com/showthread.php?t=100719)

rgoer 05-29-2003 02:32 PM

target_print weird error (I mean: really weird)
 
So I know it was just wishful thinking when I created a target_print entity with a "message" of "%s says: hello world"--but I never expected this to happen. After a compile (in which nothing out of the ordinary seemed to take place) I loaded up the map to test out whether or not "%s" worked like it does in some of the MODs... lo and behold, whenever I passed through the trigger_multiple brush that targeted my target_print, the all the controls would get reversed! This was just too bizarre... the "w" key would still do the animation for "running forward," but the character was moving backwards! "s" would do the backpedal animation, but more forwards, the crouch key made you jump and the space bar made me duck (but doing a "jumping animation")! Has anybody else encountered this? Is this bug related to something besides putting a "%" sign in a target_print entity (which, by the way, didn't work--I just got ".s says: hello world")? Just thought I'd share the weirdness...

lauser 05-30-2003 04:25 AM

LOL my good friend rgoer...isn't it strange what the editors do to your comp? I can't even run or exec any binds.cfg at ALL!! Not only that I get NO AMPSAYS. I can't use this function or even use any ampsay binds!! Also get this...I can't empower myself...but I can still rcon and sleep/slap terminator..LOL!!

Yeah...so any GENIUS that reads this can ponder how the universe was made on top of figuring out our dilemas!!

Hehe....you thought this would be a solution eh? sorry....:rolleyes:

rgoer 05-30-2003 04:33 AM

Your problem, GiNG, can probably be solved by trashing any copies of jk2mpconfig.cfg you find lying around. AcademyMOD doesn't play so nice with that file, sometimes... trash the one from base/ and from academy/ and then see if the problems persist...

Obsidian-Jovani 05-30-2003 12:00 PM

Instead of the % in front of your text try using a !

In scripts with the print command that is what you must use for your text. Such as: print ( "!Hello World." );

lauser 05-30-2003 01:19 PM

AAAAACK!! Stop posting stuff I've already done!! I'm just kidding rgoer. I really wish that would work. Believe me I have tried everything but deleting ALL and never doing any JK2 stuff again.

YES THAT'S HOW BAD IT IS!!

Can you believe this? After deleting ALL I still get the problem?

And your print problem, I did it the way you told me and it works great!! Why would you use % and !?

rgoer 05-30-2003 02:10 PM

Somtimes JK2 uses the symbol "%s" to be "target player's name"--so I was experimenting with a trigger brush that, if GiNGii walked through it, would hit a target_print and "/ampsay" "GiNGii says: hello world!"

It was really just wishful thinking... I'm not sure how %s is really hooked into the engine.

How is the "!" character used in scripting? I've never screwed around with SP scripts, so I'm clueless in that department ;^)

As for you, GiNG: have you reinstalled JK2? I know it sounds drastic, but if things are as screwed up as they are... it couldn't hurt. Although, even if you do, you'll just break it again in less than a week ;^)


All times are GMT -4. The time now is 05:08 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.