LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Technical Help (http://www.lucasforums.com/forumdisplay.php?f=159)
-   -   Invalid Game Folder Error when trying to join multiplayer over internet (http://www.lucasforums.com/showthread.php?t=111408)

mccartney 09-17-2003 01:36 AM

JA Tech: Invalid Game Folder Error when trying to join MP over Net
 
How do I fix this? I'd suggest that it is because the servers I'm trying to join are bootlegged, but from what I have heard, Siege wasn't in the beta, so that can't be why I get that error on the 3 siege servers I tried to join.

Kurgan 09-17-2003 01:44 AM

Raven.. can you help this person or offer an explanation?

ChangKhan[RAVEN] 09-17-2003 01:57 AM

Yes, this is, indeed, the case. Unfortunately, there are servers out there being run by people with old, illegal copies of the game and their servers sometimes show up (especially right now when very few people legally have the game so far). This really sucks because people with a legal copy of the game cannot play on those illegal servers (they're not compatible). We're trying to do something about this, but, unfortunately, the servers are out there (for now).

I suggest this, for the time being: select a server and hit "serverinfo". If the date in the version is "August 5th", that is an illegal copy of the game and you won't be able to connect to it. Find one that doesn't have that date in the version number and you should be able to connect to that server. I know this is a pain in the ass right now, but we're working on it...

:(

mccartney 09-17-2003 02:01 AM

Thanks chief, I'll try and see how many are good

mccartney 09-17-2003 02:09 AM

It would appear that my version is:

JAmp: v1.0.0.0 win-x86 Jul 21 2003

And all the servers I tried (all of them availlable actually) are:

JAmp: v1.0.0.0 win-x86 Aug 5 2003

or they say internal and don't have a date

If the bootleg is Aug 5th, why would the real one be Jul 21, wouldn't it be a later date?

jodiuh 09-17-2003 02:15 AM

Quote:

I suggest this, for the time being: select a server and hit "serverinfo". If the date in the version is "August 5th", that is an illegal copy of the game and you won't be able to connect to it. Find one that doesn't have that date in the version number and you should be able to connect to that server. I know this is a pain in the ass right now, but we're working on it...
It's not your fault and we thank you for actually representing your product. I can't tell you how many times I've needed to hear from some *cough* BF1942 *cough* *cough* *cough*

Jod ;-)

ChangKhan[RAVEN] 09-17-2003 02:22 AM

Quote:

Originally posted by mccartney
It would appear that my version is:

JAmp: v1.0.0.0 win-x86 Jul 21 2003

And all the servers I tried (all of them availlable actually) are:

JAmp: v1.0.0.0 win-x86 Aug 5 2003

or they say internal and don't have a date

If the bootleg is Aug 5th, why would the real one be Jul 21, wouldn't it be a later date?

It's a hacked version, don't believe anything it says... :)

We released the Linux and Win32 dedicated servers, hopefully there will be a bunch of legit MP servers up tomorrow when most people get the game. Until then, enjoy SP (or MP if you happen to find a legit server tonight!)

Kurgan 09-17-2003 02:43 AM

Thanks for responding so fast on that one Mike!

Well, at least you guys will have an easy time tracking down those servers if the IP's are listed right in the dang server list.

But as was said, not your fault...

Andy867 09-17-2003 02:47 AM

Would it be possible to put a filter on the master servers that will search for any specifics that only relate to the bootlegged copy and block them from hosting, by giving them some kind of error when trying to create the game or something?

JeepThang 09-17-2003 03:02 AM

Game Folder and various other errors
 
Hi gang!
New to the whole JK series.. but will be here from now on.
I received Academy today.. started the game up and went to multi, and there was not a server to be found.. LOL.. thats the first time I've ever seen that! Anyway.. came back later and found a few.. one I could actually participate in, Sithblister something-or-other.. The other servers giving me the same message as McCartney had.. and a couple others, like "unpure files" and such. Believe me, I'm running the game straight out of the box. So.. thinking I was already behind the curve, I set out looking for patches and updates. Not surprisingly, I found nothing. So.. these servers that a "straight from factory/on release date" game can't connect to are bogus servers? Thats good to know! I'm sure in less than a week's time there will be more servers than one could shake a sabre at! :D
Thank You Raven for calming my anxiety on the server issues!
I have recommended Academy to my clan (an AvP2 clan) as an expansion title.
We are looking forward to some friendly gaming sessions with you all !

=SA= JeepThang
Co-Leader =Soul Assassins=
www.iart.ca

The KONG 09-17-2003 10:16 PM

Quote:

Originally posted by mccartney
It would appear that my version is:

JAmp: v1.0.0.0 win-x86 Jul 21 2003

And all the servers I tried (all of them availlable actually) are:

JAmp: v1.0.0.0 win-x86 Aug 5 2003

or they say internal and don't have a date

If the bootleg is Aug 5th, why would the real one be Jul 21, wouldn't it be a later date?

That's a good question... Does anyone know?

To me it would make more sense if the leaked software had an older date. :confused:

Zem 09-20-2003 12:38 PM

Quote:

Originally posted by ChangKhan[RAVEN]
It's a hacked version, don't believe anything it says... :)

Yeah? What if mine says Aug 5th and it came from an Electronics Boutique in Texas on the 17th?!! Do I believe what it says then?

Chang, I'd be willing to bet that a lot of those servers out there ARE legitimately purchased games. If I have an Aug 5th build with software from a reputable outlet like EB, I bet a lot of other paying customers do as well. Any idea what the REAL story is on the retail version?

Versaden 09-21-2003 12:20 AM

This happened to my server company, too. They bought a legit copy and tried starting our server, but still had the Aug 6 date when I use ASE.

Our server rep's totally at a loss, because he swears he paid for a retail copy.

Good to know this is happening to others out there (well, it sucks that it's happening period). Come to think of it, they're in TX, too.

V.

Dino_Rat 09-28-2003 06:56 PM

bah, and here I spent 3 hours digging through the internet to look for the 1.1 patch that doesnt exist :rolleyes:

TehPropheT 10-18-2003 07:37 AM

not happy
 
i have purchased a box version of JK Acad.

i am unable to join any servers due to the missing folder error, and when i play solo game (with a few bots), after a minuter or so i get kicked and recieve a CL packet error, i am really starting to get annoyed now, and have considered getting a refund, unless someone can help me out. thank you.

(email your replies please to: tehprophet@hotmail.com)

richard10101 10-24-2003 04:41 PM

wouldnt it be easier if you could get the game to send a heartbeat to you in any state ( in game or dedicated server ) to send you a date of its version etc... and the ip of that machine, then you'd know whos got a ilegal copy

Kurgan 04-23-2004 10:29 PM

CL_ParsePacketEntities is an error that occurs because you are using a CD CRACK (or you patched your EXE with some kind of crack or trainer that was not made by Raven software).

Likewise a warez version of the game (which is most certainly using a cracked or hacked exe of some kind) will give this error.

Delete all your CD cracks and use only a legit copy of the game patched with the official 1.01 patch and join servers that are using the legit version of the game. The original disc or a 1:1 clone of disc one should be IN the drive when you play. If you still have problems substitute the actual disc 1 for the clone.

This should solve 99% of problems people have been reporting.

Invalid Game Folder means one or both of you have an illegal version of the game. Try another server is the best advice we can give.

Kurgan 07-30-2005 12:43 AM

To amend the previous post, some of us discovered that sometimes a mod can cause the error to occur, so if you are joining a server that's running some mod, be sure you have that mod before you jump to any conclusions! Thanks to RazorAce for discovering this one... ;)


All times are GMT -4. The time now is 02:31 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.