LucasForums (
-   Tech Centre (
-   -   directx8 (

jema 03-13-2001 03:10 PM

Sine installing directx8 i get something like "unable to initialise resource manager" when trying to run rogue squadron.

Any ideas?


Moff_Kioet 03-13-2001 06:12 PM

how dumb can a person be? no offense or anything meant.

Direct X 8 is completely NOT compatible with rogue squadron, so i suggest you downgrade to 7.0a or b if you'd like to play it.

IoanStefanovici 03-13-2001 07:03 PM


I have DirectX 8 and Rogue Squadron works perfectly fine with it.

Gold Squadron Leader 03-13-2001 07:35 PM

Hello jema. I play RS with DirectX 7.0a and Windows 98 SE. It is rock solid. Although I don't doubt some people can play RS fine with DirectX 8.0, I have heard WAY too many problems with this version of DirectX with lots and lots of games, not just RS. Therefore, I will not touch it. In the future, I will upgrade to a later release if necessary and leapfrog DirectX 8.0 entirely. IMHO, it is bad news.

Gold Squadron. The brightest star of the Rebellion Fleet!

Moff_Kioet 03-13-2001 07:42 PM

i've been wondering what IMHO meant for over a year now, can anybody explain to me what it stands for?

Lujayne 03-14-2001 01:59 AM

IMHO, anyone who calls someone else here dumb does not deserve to know what IMHO means.

jema 03-14-2001 04:52 AM

I will just point out that RS comes with dx6 unless I'm mistaken and no one suggests you stay on dx6.0.
The directx drivers are meant to be upwards compatible. In fact there is no official way to uninstall dx8. I installed dx8 when it first came out on the promise it held of better performance.

Please reassure me that mindless abuse is not the usual standard of this BB. No one has really managed a technical answer to the question beyond it doesn't work in dx8.
For example is this the common problem with RS in dx8 and has LucasArts a position on it?


[This message has been edited by jema (edited March 14, 2001).]

Gold Squadron Leader 03-14-2001 02:45 PM

Sorry for the other posters, jema. Some tend to overreact and stray off topic too fast and too often.

You'll have to ask LucasArts support if they have received many inquiries on this common problem and if they have a solution. As for my statements I stand behind them as the truth to the best of my knowledge. Just because Microsoft released DirectX 8.0 with promise of better performance doesn't mean it delivers, LOL. DirectX 8.0 IS buggy and uncompatible with many games and system configurations. You can research this yourself. And you are right, there is no official DirectX uninstaller but you can find ones available from third party vendors. Or maybe get the latest version, I think 8.0a or greater is available now. Good luck.

Gold Squadron. The brightest star of the Rebellion Fleet!

Rogue Renegade 03-14-2001 03:38 PM

I too use DirectX 8.0 (Windows ME) with NO problems. I think it has a lot to do with your video card. 8.0 may still need to knock out some bugs with various video cards.

Tell me something-- Which did you load first DX 8.0 or RS? You may want to try uninstalling/reinstalling RS.


"I am the Alpha and the Omega," says the Lord God, "who is and who was and who is to come, the Almighty." (Rev. 1:8)

Rogue Renegade 03-14-2001 03:39 PM

IMHO -- In My Honest (or Humble) Opinion

"I am the Alpha and the Omega," says the Lord God, "who is and who was and who is to come, the Almighty." (Rev. 1:8)

jema 03-14-2001 03:54 PM

The problem has occurred with both orders of installation. It is occurring now on a GeForceII card, but has also occurred on some voodoo cards.
I really thought this problem would be common knowledge and the position of Lucas Arts on it would be known.
BTW I have gold on all missions, I'm just trying to resurrect the game for my son to see if he can manange it I may deinstall dx8, but certain things like the new 3dmark2001 require its installation.


stevo 03-14-2001 04:55 PM


I too experienced problems with DirectX 8.0a with RS and my MS Force Feedback 2 joystick. I don't know what joystick you're using, but RS was randomly and frequently crashing back to the Win98 desktop until I removed DirectX 8.0a and reinstalled 7.0a. Now RS is rock solid. See the thread "Is anyone using a MS Force Feedback 2 stick with RS?" in this forum for details. Gold Squadron Leader helped me out, so listen to his advice.

Redwing 03-15-2001 06:02 AM

I too had DirectX 8 problems. Fortunately my brother solved it somehow...he says he uninstalled then reinstalled RS and told it to install DirectX 6.1. Somehow this seems to have installed both at once, because RS works now, and I have DirectX 8.

DirectX 8 is very buggy.

And just ignore our little Imperial turncoat Moff Kiwi. He likes driving people nuts.

At last we will reveal ourselves to the Jedi.
At last we will have revenge.

jema 03-15-2001 04:40 PM

Thanks I will try that. It sounds a good idea. I will post if it works!



speculative 04-01-2001 08:20 AM

I'm having probs with DX8 as well, and would just like to add that in order to "uninstall" DX8 on win98SE you need to reformat your hard drive. Not a very tasty option IMHO Just another reason I have no love for the "Empire"


A Team Picard Gnome

All times are GMT -4. The time now is 11:30 AM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.