LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Ebon Hawk's Machine Room (http://www.lucasforums.com/forumdisplay.php?f=524)
-   -   Avoiding broken quests in Kotor 2 and solving some freezing issues (http://www.lucasforums.com/showthread.php?t=141517)

Darth333 12-16-2004 11:50 AM

Avoiding broken quests in Kotor 2 and solving some freezing issues
 
Freezing issues

This does not concern all the freezing issues since they acan also have something to see with loading time. However, make sure that your main PC is the party leader when you save your game and go to another module. All the freezing issues I had were due to the fact that I was using another NCP as party leader. Loks like a script is missing here.


For Other freezing issues try cleaning the cache by loading three other games and then try to load Kotor again.

Broken quests

There seem to be several problems with scripts setting/checking for global/local variables that fire when you enter a module. I did not directly verified the files yet but all the symptoms are there. At some places, I got the feeling that some of the scripts that set some plot globals are fired when you enter some modules and not when the action is perfomed.

Here are some examples of broken quests:

Dantoine
spoiler:

I was on Dantoine and saved my game just when entering a module and before talking to Vrook and fighting him. I died during the fight and reloaded my game. Vrook never reappeared, even when exiting and re-entering the module and it was really a big turning point in the plot.


Nar Shadaa
spoiler:

Exact same thing happened on Nar Shadaa: I was suppose to meet "Visquis" ( in the "toxic" bar. I was playing as a Dark Side female sentinel. I saved my game just after I enterering in the area where you meet the Wookie if you are DS or Mira if you are LS. I met with the wookie. Until then, everything is fine. However, in the next sequence, I was transported to another module where Atton has to fight alone, he was ill equipeed and died. When I reloaded, the wookie never appeared. I got Mira instead and it was all messed up.


Peragus
spoiler:

From what I have seen, this also happened to someone else with HK-50 on Peragus. After reloading the game, hk-50 would never attack you. I have also seen similar problems at other places but I don't remember them all but one involved a quest with t3-m4


Korriban
spoiler:
Someone also mentionned a similar problem in the Tomb on Korriban when you enter the tomb with the "visions" and the door at the end would not open.


The above problems won't show up if you don't save/die at the wrong place at the wrong time...but when you happen to reload your game at one of those moments, it is really annoying as those affect major sequences in the main plot and you won't be able to finish the game.

How to deal with these problems

a. The solution I found is not to die or save before entering a module. Once you are in a module, you can also save safely after an event (examples: after the npc has spawned, after talking to the Wookie on Nar Shadaa but not before) but this rather annoying and not practical, especially for people who are not familiar with how plot advancement works .

b. Save often at different locations - I keep a rotation of 5 saves/planet and make sure they are not all in the same module.

- note: although I really hope Obsidian will fix this for the PC version, this issue will be fixable by modders - it is a matter of verifying some scripts and adding a few code lines here and there.

bneezy 12-18-2004 09:43 PM

Thanks for the info. I've run into my fair share of broken quests. Although, I only keep a 10 slot rotation. But 5 per planet? Hmmm.... God knows we have the space.

Darth333 12-20-2004 08:42 AM

I know that is a bit much but I do this for a reason...We're gonna mod this game in less than two months, gotta get ready :D

cork 02-03-2005 01:13 PM

I did exactly what you told me to (about 10 times) and my game keeps acting weird when t3 gets disabled on peragus. The screen goes black, but you appear to be in control of the exile, but everything goes black (you can press pause and scroll through the menu's normally. You can also save your game, load it again and find the exile in the spot t3 was standing when he got shot. Then you can start walking with the exile, but you can only enter the lift and when you do, yo get switched back to t3 who's still disbled). Does anybody have any suggestions cause I'm freaking out.

cork 02-04-2005 05:40 AM

Already solved that problem.

Seewolf 02-12-2005 11:47 PM

i dont know but i think here is another broken module

at narshadda after i fight against the wookie, i ran trough the Base and open the Door for the Jedi. Mira ran trough the door and meet the jedi master. I ran with my main char to the Arena to fight against viquis. Then the guards attack him after a small talk. then came the scenes in with keira talk to the dying wookie and my game get frozen after the talk. My Main Char stand in a room of the base at the ventilationcontrollconsole.

have someone a fix for the problem.

Drazin 02-14-2005 05:37 PM

I had the exact same problem once Seewolf.
I reloaded a previous save (When I entered the base after Mira opened the door.) it took 3 reloads before it actually made it past Kreia and the Wookie.
I am still not sure what went wrong, but on the last try I saved at the top of the ramp leading to the arena. Perhaps that save fixed my issue. Only happened once out of 6 play throughs.

Seewolf 02-17-2005 04:58 AM

can you write what exactly you have done

Seewolf 02-20-2005 07:28 AM

a small question
What happened after the cut scene with kaira und hanhar. Did Atton do something?
i used the Warp cheat to go to annother module/lvl and wanted to travel back with the epon hawk to nar shada. But in the Cockpit i only saw the dead body of atton.

Duiker 03-01-2005 08:58 AM

Cork, how did you solve the problem with T3 in Peragus? I have exactly the same problem!

Seewolf 03-01-2005 09:45 AM

Duiker i think
its easier to start a new game

The Hidden One 03-20-2005 09:40 AM

For the tomb on korriban, to get out you have to a real strong affinity with the light or dark. or you'll just have to reload from the autosave from when you first landed on korriba.

Hope that helps

The Hidden One 03-20-2005 09:45 AM

Duiker about your question...
spoiler:
Atton fights the Twin Suns and has to win before you can advance. one way to win is to lay the whole floor with mines before you go to the Jek'Jek tar. Or you can equip him with your best armor before you leave and hope for the best.

DarthHenson 04-21-2005 08:04 PM

Should Atton be doing this?
 
I'm new to the boards, maybe because I havent had a problem with anything lucas since Anakin's acting skills in episode II! But this is just "Pure Pazak," as Atton would say!

I'm playing Knights of the Old Republic II The Sith Lords on xbox, at least 5 hours into the game and upto the part in Peragus where Atton t3 and I get back onto the Ebon Hawk. After my Jedi Guardian wastes all the sith on the ship the cutscene loads where Atton says something like, "Hang on guys, im gettin ya out of here!" And he never does. He just sits there typing on the keys the same way over and over while the music loops.

Is this one of those, "Broken Quests or Freezing issues," like the post says? If so, how do I fix it?

VHKnight1 05-04-2005 09:10 PM

hey duiker and cork did you fix that problem with the t3, b/c i have the same problem. i even tried to start a new game, and i didn't save all the way up to that point, and it still did it. can some one help?

Aidy 05-05-2005 11:33 AM

I find it very hard to believe that Obsidien would releash such a shoddy game with so much missing. And the x-box version will no doubt stay that way...I have half a mind to go to their offices with some wolverines, let the ****ers loose in the buliding and mace any bastard who tries to get past me to freedom. Who's with me???

stingerhs 05-05-2005 11:37 AM

^^^^
just so you know, thats not likely to solve anything. if you need more info as to why the bugs are in the game, consult the thread i have posted below. ;)

the link: http://www.lucasforums.com/showthrea...hreadid=148337

Aidy 05-05-2005 11:44 AM

Maybe, maybe not...but it'll give 'em something to think about, and maybe next time they wont be in such a god damn hurry to sell ME inferior products.

stingerhs 05-05-2005 12:06 PM

keep in mind that is wasn't entirely OE's fault. just read the thread link i posted, and you should understand. if not, there is usually nothing to gain at these forums by trying to start some sort of insurrection of sorts.

generally, its accepted that discussion is fine and dandy. but calling for violence or boycotts is likely going to get you a deaf ear. and i say this not as an attack, but because thats what has happened in the past. trust me, you are not the first person to complain about the game's incompleteness.

Aidy 05-06-2005 09:26 AM

well, to be totally honest with you Guv' I wasnt actually thinking of doing the whole assualt with rabid mammels plan anyway. I was just letting of steam. I really enjoyed the game...not as much as kotor but still I enjoyed it...however how much cooler would the game have been if it was complete? You also cant argue that the x-box users really got the ****ty end of the stick. And that whilst p.c. users will have patches and mods, we (x-box users) have a game that is not complete...end of story. Venting my spleen is all that I can do...I am a broken shell of a man. I was speaking out of frustration. I have no agenda to rock ze tribant.

Darth Manus 05-04-2006 11:01 AM

Well, there was one time my entire inventory disappeared. After I noticed it, I just replaced the items I could remember via a saved game editor (KSE), but every time I tried to get off the Ebon Hawk on Dantooine, the game crashed. It never happened again, and I never found out what triggered it, but it ruined the game, so I had to start over.

RedHawke 05-04-2006 10:20 PM

Quote:

Originally Posted by Darth Manus
Well, there was one time my entire inventory disappeared. After I noticed it, I just replaced the items I could remember via a saved game editor (KSE), but every time I tried to get off the Ebon Hawk on Dantooine, the game crashed. It never happened again, and I never found out what triggered it, but it ruined the game, so I had to start over.

From what tk102 says you cannot add items to an Xbox save with KSE you can only change stack sizes of items you already have. If you are talking about the PC verson of the game you have the wrong forum, this one is for the XBox. ;)


All times are GMT -4. The time now is 04:10 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.