LucasForums (
-   Galactic Discussion (
-   -   EAW system requirements (

michaelforce 02-02-2005 08:27 AM

EAW system requirements
Does anyone have system requirements for the Empire At War game? I haven't read all the posts but was hoping someone might know.

This will be the first PC game I have bought in about 3 1/2 years, so I want to be ready. Thanks in advance!

Jan Gaarni 02-02-2005 09:52 AM

There is another thread concerning this very same issue further down. Here's a direct link.

I have not read anything about the system announcement. I could have missed of course. :)

Still there's still some time before we have to really worry about that though. ;)

All times are GMT -4. The time now is 09:52 PM.

Powered by vBulletin®
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.