LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Dedicated Server (http://www.lucasforums.com/forumdisplay.php?f=334)
-   -   Need help with this Dedicated server (http://www.lucasforums.com/showthread.php?t=150972)

DaveCreator0430 08-15-2005 04:00 PM

Need help with this Dedicated server
 
Hello everyone. I've been using these forums and tweaking things for about 8 hours now trying to get this dedicated server to work. Well here is my problem, I am using JAMPDed.exe up to date at 1.011. I am also using the bat file inlcuded with JA+ v. 2.3 due to this is a JA+ server. I have done all the server cfg stuff, unlocked ports 29022-29075 just as a precaution. I turned off both firewalls. I am using a Linksys Wireless-G Broadband Router on the Host computer. Now here comes the really icky part, I can log on to the server from one of my computers that's on the LAN, however it appears in Local AND Internet lists. My friends cannot see the server however. I have looked in the forums for a long time, surfed the net for a long time and tinkered with a lot of things. I need help and will be thankful if anyone could help me. Even if I missed something, I don't care if I was stupid, it's better than not being able to start up a server. Oh and before anyone says anything the server is set to dedicated 2. That would be the internet. and it does send heartbeats to the master server so I don't have a clue what's going on. Also my friends used the connect console command to try to get in, they also tried a player name search which I read about, that still didn't work. So any help would be appreciated. Thanks

Jamps 08-15-2005 10:01 PM

maybe they don't have the same version as you.

DaveCreator0430 08-16-2005 05:07 PM

They do have the same version. It is the newest and most recent and I have played with them before in JA+ on version 2.3 so it does work. Thanks for the suggestion though. However what I need is a step by step guide on port forwarding, and disabling DHCP on a linksys Broadban wireless-G router. So far I've had vague instructions and I don't know what I'm doing. So any help would be great. I think that's the main problem.

Kramerika 08-17-2005 01:41 PM

What type of ports did you open? UDP? TCP? The only port I have ever had to open/forward for the Jedi Academy servers that I have set up is UDP 29070. If you have a software firewall on the host computer, you will also need to disable the firewall or forward the same port, but since you can see it on the LAN, I am assuming that much is working. Maybe try putting the host computer in the DMZ so that it is open to the internet without needing ports forwarded. Is "dedicated 2" a Quake III command? I have never set that in my command line to launch the server or in my server.cfg file. It's always an internet server by default.

DaveCreator0430 08-17-2005 02:26 PM

I unlocked the UDP from 29025- 29079 and turned DMZ on the host computer
My friend just tried directly connecting you know, the connect command. And it brought him to the awaiting gamestate screen. instead of looking for the connection. He said he got stuck there. So now I don't know what else to do. Oh and in reply to the +dedicated 2 command, I followed that from this forum's instructions.

UPDATE
Ok, I read on the internet that I had to have a static IP and that there is a certain way for doing it with Linksys. So I did what they said. Made the static IP outside of the DHCP server range. So with high hopes my friend tried it again. Still nothing. I really need help with this. I have disabled anti-virus software, firewall software. I just can't figure it out. Is there a game setting or something that I over looked? Please someone help me.

DaveCreator0430 08-17-2005 03:38 PM

REALLY CONFUSED
 
Ok here is an update. I was asking my friends to try out the server and they can't get in so I was just hanging out on my server and all of a sudden SOMEONE JOINED!!!! A REAL LIVING BREATHING PERSON. SO now I don't understand how he could join and they couldn't. I'm so damn confused. Please help

DaveCreator0430 08-17-2005 05:29 PM

Another Update
 
Ok, I see the game in my local list with the IP I provided for it. However it is also in the MASTER list as a different IP but it's the same server. Any explanation for this?

Kramerika 08-18-2005 11:58 AM

I probably should have asked the obvious question. What IP address are your friends trying to connect to? LAN addresses are different from WAN addresses. Those not within your local network (LAN) who are joining from the internet need to connect to your WAN/internet address. You can find this in the status of your router configuration. The WAN address is the external IP address assigned by your ISP. ISP's have a certain range of internet IP addresses available to them to assign to customers. You can't give yourself an external IP address. LAN addresses are normally within the range 192.168.1.x and can be assigned by you or by the DHCP server of your router. Only those within your network (behind your router) can see the LAN address of the server and connect to servers via that address.

Amidala from Chop Shop 08-18-2005 07:59 PM

Go to http://www.whatismyip.com to get the external IP address assigned to you by your ISP. That is the IP address your friends should use with the /connect command.

Go to http://www.chopshopservers.com/education/ and click on the link "Running a Server from Home".

hi_all 08-23-2005 06:26 PM

same here
 
I have the exact same problem, except i'm using an SMC 7004VBR router.
But, same problem nonetheless.

Please help if you can. I can see my own server, but my friend cannot. When he adds my IP as a favourite, in the favourites list he can only see my ip address and not server name and such. But i can see it fine in my list.

DaveCreator0430 08-24-2005 12:33 AM

Yeah I figured it out. Apparently there were two addresses. One was 192 the other 69. SO NOW my server is up and running. Thanks for all your help and come visit RPG Galaxy on JA+ if you get a chance. Later all

acdcfanbill 08-25-2005 11:27 AM

192.168.xxx.xxx are all internal ips.


All times are GMT -4. The time now is 09:06 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.