LucasForums (
-   Tech Center (
-   -   XWA doesn't see my 3D hardware (

AquaX 01-23-2006 10:16 PM

XWA doesn't see my 3D hardware

XWA will only run in software rendering mode. In the preferences, under Video Options, it does not see that I have any 3D hardware. It simply reports "no 3d hardware".

My setup:
AthlonXP 2400+
Radeon 9800 Pro w/most recent Catalyst drivers.
WinXP Pro SP2 and all updates
DirectX 9c
XWA 2.0.2

I have tried all the compatibility modes (W95, W98, NT4, W2K), with no success. I've reinstalled XWA and DirectX multiple times.

It plays fine in software, but it sure is ugly.

Any help would be greatly appreciated.


Brettzies 01-23-2006 10:29 PM

I couldn't get mine to say those exact words, so I'm not sure where it says that. The first two options are where you set it.

Video Display Driver = Primary Display Driver
3d Hardware = Yes (click this to toggle between yes and no, default is no)

Not sure that will help you, but that's how mine is set to get 3d acceleration

AquaX 01-24-2006 01:15 AM

Yeah, that's the part that is greyed out. It says "3d hardware = No" and won't let me change the settings to "Yes"

But thanks for the help.

Wildstar 01-24-2006 10:58 AM

I'm not sure this will help, but try uninstalling XWA, reinstalling it, and run it without the 2.0.2 patch and setting 3D hardware on before installing the patch.

AquaX 02-11-2006 02:54 AM

Aha! That method worked.

Thanks so much :-)

Darth_chaffinch 04-24-2007 07:47 AM

Thanks and Q
Thanks for the answer, had the same problem - can I ask if it's possible keep/copy the saved game file before uninstalling pls?

Wildstar 04-24-2007 11:14 AM

Yes...the saved game files have a .plt extension and are located in the main game folder. Just be sure to load the pilot file back from the launcher after you reinstall. :)

Darth_chaffinch 04-24-2007 02:39 PM

Thanks Wildstar, I aslo had to set antialiasing to off instead of application-dependent (for others with same prob!) The text is a little bitty now, is that normal?

Wildstar 04-24-2007 03:32 PM

There are a few files found on LucasFiles that deal with that problem. The first one, the "all resolutions" fix, seems to work well. If you're using a newer nVidia card (say, models that came out in the last year), you may also find that the targeting box in the HUD view around the craft you're targeting is not to be found. We are aware of this problem too and are researching it.

ltkermit 04-26-2007 05:36 PM

Same problem
I am having a similar issue, a few days ago I found my X-Wing Alliance Cd and decided to play it. I installed it and played it just fine for a few days then all of the sudden I got a BSOD. The BSOD referenced the video card, I restarted and tried to reload the game but then I got an error that said no 3d hardware found switching to software mode. I have un-installed/re-installed both Xwing and my video drivers and I keep getting the same error. I also reinstalled DX9.0c. I can not install Xwing without the 2.0.2 patch as it is included with my game. I have had no issues up until that BSOD. Any ideas?

AMD XP 3200
ATi 9800 Pro (latest drivers as of 4-25-07)
XP Pro Sp2
XWA w/2.0.2 English

Thank you

LouisdeFuines 08-14-2013 06:24 AM

I have a very similar problem.

I can chose the 3D-Hardware, but when the mission-loading-screen appears, the game tells me, that it wasn`t successfull in detecting my 3D - hardware.

This is VERY annoying, since it worked before my system new installation.

I`v got a ATI Radeon HD 5570 card.

Please help me somebody! The hints above don`t work with my system...

LouisdeFuines 08-16-2013 10:51 AM


I deinstalled my driver and software and installed the same driver, but a software from 2010 (Catalyst), it worked.

Wildstar 08-17-2013 11:09 AM

Great, I'll get the word out, Louis :)

All times are GMT -4. The time now is 04:49 AM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.