LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   JA Mapping (http://www.lucasforums.com/forumdisplay.php?f=540)
-   -   Doors with Switches in Jedi Academy (http://www.lucasforums.com/showthread.php?t=167721)

CalcProgrammer1 07-18-2006 08:32 PM

Doors with Switches in Jedi Academy
 
I am having problems with the func_door entity when I target it with a trigger_multiple that a player can press. I want a door that can only be opened when the button is pressed and stays open until it is pressed again, and then it closes and can be opened by press of the button. The problem I have is that when I walk up to the door, it opens and I don't want it to. I tried the Lock checkbox, and the door locks but then if I push the button it opens and then closes and now opens if I walk up to it. I also checked trigger and tried again, but with the same results.

Lord Kaisen 07-19-2006 06:01 AM

Try to check the 'Toggle' checkboc. I think that would do it. ;)

CalcProgrammer1 07-21-2006 12:24 AM

I tried that, and it works fine when i do the /devmap <mapname> before i package map, but when i play the map online (lugor mod) the doors don't work right. I don't know if it's something to do with lugormod or if its something with my map. Probably something with lugormod.

CalcProgrammer1 07-22-2006 07:20 PM

i got it to work, you have to have toggle and player_use checked to make lugormod not enable the opening of the door when a player nears it.

CalcProgrammer1 08-01-2006 11:02 PM

i got another question related to this- I want to make a secret area much like the ones found in Jedi Home levels, where the stairs drop down revealing a door, but I don't know what to apply to the door to make it work
I don't want the door to open when pressed or walked up to, instead i want it to open by a switch located far away, stay open for about 20 seconds, and then return to its original position, and not open again until the switch is pressed, I also want it to work on Lugormod, since my friends and I play on my lugormod server, and I have noticed problems with doors under Lugormod.

CalcProgrammer1 08-02-2006 07:35 PM

never mind, i got it, I had to upgrade my server to Lugor Mod 1.1, but that fixed it


All times are GMT -4. The time now is 03:13 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.