LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Open Jedi Project (OJP) (http://www.lucasforums.com/forumdisplay.php?f=542)
-   -   Accessing the OJP Source (Pre-SVN Posts) (http://www.lucasforums.com/showthread.php?t=171459)

razorace 12-16-2003 07:37 AM

Ok everything should be cleaned up now.

Everything has been placed in the appropiate folders, except for the Basic/Enhanced source files. For them, they are both stored in the /Basic folder with all the files branched in two branches.

MAIN (HEAD) is the primary branch of the project (the trunk). This stores all the files for the Enhanced version of the project.

OJP_BASIC is the secondary branch for storing all the Basic distro's files.

I've set things up this way so it will be as easy as possible to merge code additions tfrom Basic into Enhanced.

Be sure to keep your branches straight when doing changes since a screw up can create a lot of extra work as you can see from some of the revision logs. :)

In addition, I've put tags (PRE_REORGANIZATION_2 and POST_REORGANIZATION_2) to make it easier to find the file versions from before and after the lastest reorganization. However, all I did was delete everything from the Enhanced folders and made sure all that stuff was in the new branched structure.

razorace 12-22-2003 08:46 AM

There's now a new branch specifically for the saber system I'm working on. This is so people can play with/test the system before we put it in the game proper.

Teancum 12-24-2003 09:46 AM

I signed up and tried to join the project, but I kept getting errors that would not let me join. Has the account/pass changed?

razorace 12-24-2003 10:11 AM

Try "openjedisource" instead of "opensourcejedi" for the password. I can never remember what it is suppose to be. :)

Teancum 12-25-2003 06:54 AM

It was 'openjedisource'. Question, though: How do I actually get the source? I went to get the MP icon, and it just took me to some directory. I couldn't find where to d/l it.

Darth Sun 12-25-2003 12:34 PM

I stumbled upon this same problem as well.

Also, when downloading the source code, it refused my username (even though I joined the OJP repository) so I was "forced" to download the source code using the ojp/ojp read-only account you created.

Teancum 12-25-2003 08:06 PM

Quote:

Originally posted by Darth Sun
Also, when downloading the source code, it refused my username (even though I joined the OJP repository) so I was "forced" to download the source code using the ojp/ojp read-only account you created.
Me too

razorace 12-25-2003 09:50 PM

Please describe what you did and what sort of error you're getting.

Darth Sun 12-25-2003 11:20 PM

When I try to download the code in the download page it asks for the login (which is normal), yet once the login is entered it refuses and refuses till it goes to a 401 error page saying I have no access to the content I'm trying to download.

If I use the ojp/ojp login it allows me to download the code though.

razorace 12-26-2003 03:48 AM

hmmm, ok. Please email the freepository.com support email. It's probably something they did.

Teancum 12-26-2003 09:28 AM

I have the source now, but why do all of the files have a ",v" after the extension? I tried merely removing the ,v but then Windows says it's an invalid file.

razorace 12-26-2003 09:36 AM

I'm guessing you downloaded the source tarballs instead of the actual files. I'm not sure how you're suppose to get the files from that....

keshire 12-26-2003 09:46 AM

The raw CVS is like a mobile repository. Use that. set it up as a new module. With out Razor setting up write access though all you can do is donwload it. You can't upload. I need to get ahold of some people on my side to give me a few permissions. They've been blocking ports like crazy. Pretty soon They'll get to the ports JKA uses.

razorace 12-26-2003 09:54 AM

Yeah, I just checked things and it looks like the "pure" source option of the download tarballs is busted. It only seems to get the stuff from the main directory only. I'm trying the raw type right now.

Either way, I recommend that everyone just get direct access, it's WAY easier to deal with once everything is setup.

Kenshire, please get on your IM and msg me if you can. I think I've figured out where the saber is being told to face the owner all the time while you're trying to stick it.

NickR 12-27-2003 12:07 AM

Razor knows I've had problems with direct CVS access using TortoiseCVS. And according to the owner of freepository, it's probably because he recently disabled direct access to new account members. I might be wrong about the exact nature of this, but that's what I believe to be the problem. It could also just be a port problem though.

razorace 12-27-2003 05:14 AM

NickR, They're talking about something. :) But the information is appreciated.

According to the admin, there's a problem with the tarball system at the moment. He's working on a fix.

NickR 12-27-2003 06:16 PM

Sorry, didn't really read through all the posts. I now realise you guys are talking about joining the project via the website. I joined and I had no problems, except for getting remote access with TortoiseCVS so I can download and upload files without having to use the freepository web interface.

toolman639 12-28-2003 01:30 PM

Hey when will the fix for the vehicle limit be out and what will the limit be.

razorace 12-28-2003 07:46 PM

Quote:

Originally posted by toolman639
Hey when will the fix for the vehicle limit be out and what will the limit be.
Wrong thread. The correct thread for this is here.

I'm not sure when we will have our next public release but I know the vehicle limit will be 64 different types of models (with 128 vehicles allowed ingame at once).

razorace 01-25-2004 09:54 AM

Good news.

I've figured out a much easier way to get things set up for a direct access so it shouldn't take too long if anyone is interested.

razorace 02-23-2004 09:12 AM

Some reminders for those that are actively committing changes to the repository:

- Always document your changes. Internal changes can be explained with the CVS comment but the external stuff needs to be documented at all times. If people don't know about the change, it's useless to everyone.

- If you're adding or changing something to both Enhanced and Basic (basically everything in Basic), add your modifications, commit to the Basic branch (OJP_BASIC), and then merge to the Enhanced (HEAD) branch. See below for new files note.

- For new files, please clear them with me first. After that, add a basejka version of the file to the HEAD branch (if a basejka version exists). Lastly, add/commit the modified version to each branch where it is needed. These steps ensure an easier to understand/use revision history so please try to follow them.

Thanks,
Razor Ace

razorace 02-24-2004 04:42 AM

The SaberSys branch has been merged into the Enhanced branch so the SaberSys branch is no longer in use.

razorace 03-28-2004 06:31 AM

1. The password at the beginning of the thread was bad. It has now been fixed. Sorry about that.

2. We're probably going to create a temp branch for the AotC folks to get their code merged and ready before we merge to main. I'll keep everyone posted.

razorace 05-19-2004 10:48 PM

Ok, the AotC TC branch isn't going to happen but I finally came up with tutorial on how to direct access the CVS repository.

================================================== ========
Tutorial - Getting Direct Access to the OJP CVS Repository
================================================== ========
Note: This tutorial is only for Windows OSes.

1. Go to https://www.freepository.com/ and sign up for an account. Do NOT use spaces in your username.

2. go to http://www.tortoisecvs.org/ and download the tortoiseCVS program. You can use a stable or beta

version, whatever works best for you.

3. Install tortoiseCVS. You might have to reset your computer to get all the Windows Explorer extensions

to work.

4. Log onto freepository with your new account.

5. Click on "join a freepository".

6. Sign up for the OJP repository
freepository name = OpenJediProject
freepository pass-code = openjedisource

7. Using the pulldown tab on the left, select OpenJediProject

8. Click on Secure ID entries. This will send you an email.

9. Check your email for that email. The email will have something like
:sserver:razorace@freepository.com:3025/mnt/usbhd/fp/fp1/222yx9P6fFHQYOpenJediProject
This is your CVSROOT. You'll need this later.
Note: if you don't get the email, you can still get your CVSROOT by clicking on the Secure ID

entries button again.

10. Here comes the fun part. You need now need to log your tortoiseCVS into the repository so that the

program will know what your password is. Download this file...
http://ojp.jediknight.net/files/CVS1.zip

11. Unzip CVS1.zip to where ever you installed tortoiseCVS.

12. Open up login.bat with a text editor.

13. You now need to modify your CVSROOT by adding a ";version=1" next to the ":sserver"
This...
:sserver:razorace@freepository.com:3025/mnt/usbhd/fp/fp1/222yx9P6fFHQYOpenJediProject
would become this...
:sserver;version=1:razorace@freepository.com:3664/mnt/usbhd/fp/fp1/222yx9P6fFHQYOpenJediProject

But remember that you need to use your own original CVSROOT, not the one used here.

14. Replace the example CVSROOT with your CVSROOT in the login.bat.
set

CVSROOT=:sserver;version=1:razorace@freepository.c om:3664/mnt/usbhd/fp/fp1/222yx9P6fFHQYOpenJediProject
will be
set CVSROOT=<yourCVSROOTHERE>

15. Save the file and then run it. I recommend that you run it from the command prompt so that you'll see

everything that goes on.

16. The program will prompt you for your password (use your freepository account password, not the one used

for the repository as a whole). If it worked, your .cvspass file in your tortiose directory will have some

stuff in it (use a text editor). Otherwise, you have a problem. You can't use backspace or delete while

typing in your password or it will not work. Be careful.

At this point the program should spend a long time downloading the repository to your system.

Brad Oliver 06-04-2004 07:20 PM

I just built a Mac SDK for Jedi Academy. In the grand scheme of things, that was childs play compared to trying to download the OJP source. :)

Here's what I've done so far. Maybe someone can help get me the rest of the way.

1. I registered at freepository.com, signed on, saw stuff.

2. I downloaded and compiled the cvs 1.11 with sserver support that is required by freepository.

3. I renamed my cvs to cvs111 to avoid a conflict with the pre-existing cvs (1.10) provided by OSX and installed it into ~/bin/

4. I grabbed the cert.pem file from freepository.com, renamed it to .cvsSSLkeys and put it in my home directory.

5. I logged in with "cvs111 -L login" and was able to get the status of the repository. That is, it told me no modules had been checked out. :)

6. I then tried "cvs111 -L checkout OJP" and was greeted with a "connection refused" message.

7. I tried to login again, and got a "connection refused"

8. Now I can no longer telnet to freepository.com or ping it, as mentioned in the freepository.com troubleshooting notes.

So after all this, I suspect the server went down right when I was getting ready to get down to business, but that seems like really strange timing.

Can anyone else currently log in?I can't grab the "full source" tarballs from freepository.com - they returned essentially empty .tar files with some readmes and some guy's resume. I also can't use the GUI CVS client for OSX, since the cvs required by freepository is a special build.

Is there an easier way to grab the source that I'm missing?

razorace 06-04-2004 08:00 PM

Yeah, I know what you mean. The setup is terrible but it's the only place that has a hosting deal that allows for our type of project.

Anyway, the server seems to be up for me. This seems to happen a lot with new accounts. Personally, I think he's overly paranoid. Using weird security proticals only makes it hard for us to access the repository.

I beleive there's a way to grap the raw data and then create a local mirror of the repository but I've never tried it. Keshire is the one to ask about that.

keshire 06-05-2004 06:17 AM

Ya you can grab the actual module and set up a local "sand box" type deal with it.

No fuss no muss. But as far as uploading your changes you'd have to lobby Razor to give you the web access to freeRepository.

first Download the raw CVS format (this includes all the ,v files).

then make a new module.

:local:C:\Location_Of_Raw_CVS\

what it should do is make a new module but import it from it from the raw cvs making it act like it was from the actual freeRepository server. From there you can checkout the module from this local version.

And here is the output.

C:\cvs.exe -q import -m OJP tcvs-vendor tcvs-release CVSROOT=:local:C:\OJPSDK

No conflicts created by this import

Success, CVS operation completed

C:\cvs.exe -q checkout -d jkasdk OJP
CVSROOT=:local:C:\OJPSDK

razorace 06-07-2004 02:23 AM

Oh yeah, Brad, it sounds like it's probably something on freepository's end, I suggest you email the support email address for freepository (support@freepository.com, I think) about it. This seems to be a common issue with new accounts.

GangsterAngel 06-07-2004 03:31 AM

This is ****in me off , i have the ,v files how do i use them ,, and where is TortoiseCVS

keshire 06-07-2004 03:46 AM

TortoiseCVS

install it. Reboot.

unzip the OJP and cvsroot to where ever you want the source files.

right click| CVS| make new module

set protocol to locally mounted folder

set repository folder to directory where the CVSROOT is

click fetch list

set module to OJP

click OK

it will set up a sand box that works exactly like the server version.

read the tortoise instructions on how to do anythign else. You also need to know how to compile code as that is what it is.

GangsterAngel 06-07-2004 04:30 AM

http://www.arc.ufgclans.net/untitled.JPG

keshire 06-07-2004 04:40 AM

go back a directory and try again.

I'll post a screen shot here in a little bit.

*edit*
http://mediaservice.photoisland.com/...3225699549.jpg
*edit*

GangsterAngel 06-07-2004 04:55 AM

that image is 2 blury , u in 800 & 600 or somthin ?

keshire 06-07-2004 04:58 AM

when you do the fetch list it pulls all the module names from the cvsroot folder.

OJPS is not one of them. Your trying to do this inside the OJP folder it looks like.

use the openjediproject-raw-cvs folder as the local directory. DO THE FETCH LIST! "SELECT" OJP! hit ok.

GangsterAngel 06-07-2004 05:24 AM

1
 
i have stuff like
\jka-universalSource\OpenJediProject-raw-cvs\Basic\source\cgame
but no .dsw ?

keshire 06-07-2004 05:30 AM

First, you hit new post instead of reply. You can tell when it tells you it can't post without a subject.

Second, that would be because its .NET project files. Use Google to search for prjconverter.exe. After that direct all your questions to the coding forum.

GangsterAngel 06-07-2004 05:38 AM

d
 
Some files are still ,v files ??!?

jka-universalSource\OpenJediProject-raw-cvs\OpenJediProject-raw-cvs\OJP\Basic\source\game

keshire 06-07-2004 05:41 AM

ignore them or delete them. You have everything you need to modify or compile the source.

keshire 06-07-2004 05:43 AM

Read the tortoise tuitorials on how to access different branches. Any questions that should be directed to the tortoise people :).

jbminn 06-10-2004 10:21 PM

Quote:

Originally posted by razorace
Yeah, I know what you mean. The setup is terrible but it's the only place that has a hosting deal that allows for our type of project.

Anyway, the server seems to be up for me. This seems to happen a lot with new accounts. Personally, I think he's overly paranoid. Using weird security proticals only makes it hard for us to access the repository.

I beleive there's a way to grap the raw data and then create a local mirror of the repository but I've never tried it. Keshire is the one to ask about that.

Terrible? Paranoid?

That's a bit harsh, razor ace. I consider myself very security-conscious, and am proud of the contribution freepository made or continues to make to thousands of projects across the globe since it went live in 1999.

Script kiddies try to crack freepository over a 1000 times per day. The security measures in place on the site protect your code from them.

Sserver is actually quite mainstream these days. The sserver connect method is now included by default in CVSNT, which is the binary used by TortoiseCVS. That's why you can now use TortoiseCVS to connect directly to your freepository.

When I began designing the secure remote command line interface to freepository, I wanted to use ssh. But that simply _couldn't_ work in the silo'ed fashion necessitated by the many thousands of repositories on the freepository server. Fortunately, Corey Minyard had recently released his sserver reference implementation. This was exactly what freepository needed: a secure pserver-like protocol.

I began using sserver when almost no one had heard of it. Today, sserver (natively or via plugin) is available in virtually every mainstream cvs cleint.


All times are GMT -4. The time now is 11:36 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.