LucasForums (
-   The Work Bench (
-   -   Black screen after Telos (

Zanda 01-02-2007 08:15 AM

Black screen after Telos
After get on the Ebon Hawk and Atris talks with the handmaidens. I get a black screen. I can exit and look at every other screen: the inventory, equipped items, all that stuff. But the mapall white where the map would be and the main screen is all black.

I have quite a few savegames before the bug and I tried with all of them to get into the ebon hawk and everytime I ended up with the black screen.
When I save the game at that point it won't load that savegame, it is corrupt.

I have a Nvidia gforce 7900 gtx but I don't believe it is videocard related since I saw on these boards that people on Xbox and with Ati cards experienced the same problem, so I think it is a game glitch.

Like in these 2 closed threads:

I'm sorry for asking again, but in these threads there still isn't any satisfying answer. Does anyone know already? I'm not running any mods or cheats, I have the latest patch.

Thanks in advance!

Anakin Skywalker 01-02-2007 12:04 PM

hmm.......... Interesting.... It probably is a glitch....... are you sure it is the latest patch? I've had this happen, but I saved and loaded and I could play again....

btw Welcome to the Forums

Zanda 01-03-2007 05:49 AM


Yes when I press update from the launcher it says I have all the updates.

Anakin Skywalker 01-03-2007 12:08 PM

hmm....... it could possibly be your settings......... turn off Grass, shadows, movies, enable V-Sync (if you haven't already)

Kitty Kitty 01-03-2007 03:42 PM

What it's acting like, though with no mods etc it doesn't make a whole lot of sense... is when you have a bad / corrupt module.

I've had the same thing happen to me when I've tried to use the module editor and done something wrong re-building the thing to a compiled state. It loads and plays, but it's all black. You can hear sounds and access menus, but that's it.

Might try backing up your savegames and just completely uninstall/reinstall if playing with settings as Anakin suggested doesn't help. Then if it is some sort of file corruption it should be solved, though bear in mind that if all the saves you have contain the area information that's "bad", any save you load may well contain the problem, so a new game might also be required.


Zanda 01-04-2007 11:53 AM

But I did all that :)
I turned off Grass, Shadows, movies, enable V-Sync. Uninstalled and reinstalled the game and ran the updates again and tried all different settings again.

Then I still get a blackscreen when I go into the ebon hawk and still can't load the savegame saved at the blackscreen.

Since I heard that usually some script with a handmaiden starts when you enter the ebonhawk upon leaving the hidden jedi acedemy, my guess is I did something wrong in the previous steps?
I did start the battles with the handmaidens for example, but I didn't finish the final fight with the 5 handmaidens for example, I tried but they were too hard to beat. Maybe that corrupted things?

jedmindtriks 02-04-2007 03:18 PM

same happened to me, just loaded a game, BEFORE i start talking about fighting with the handmaidens, after i load, i didnt talk to them about fighting, and everything worked perfect. :)

btw, beating all 5 didnt help either

All times are GMT -4. The time now is 12:09 AM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.