LucasForums (
-   Tech Help (
-   -   Cant patch to 1.3 (

moizeus 12-16-2007 10:49 AM

Cant patch to 1.3
well I got th Best Of PC pack and I installed 1.2 for Battlefront but I cannot install 1.3 it saids that I need 1.2 but I already have it. :smash: help me

jawathehutt 12-16-2007 01:40 PM

dont get 1.3, no one plays on it and its fixes were really useless. Just stick with 1.2 where most of the remaining people play.

moizeus 12-16-2007 08:28 PM

ok thanks, since it really doesn't give me more improvement then I shall not install bad I meant Battlefront I, sorry for posting in the wrong section...
So does BF I gets any changes from 1.3?

All times are GMT -4. The time now is 09:31 AM.

Powered by vBulletin®
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.