LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Open Jedi Project (OJP) (http://www.lucasforums.com/forumdisplay.php?f=542)
-   -   Serious Issues! (http://www.lucasforums.com/showthread.php?t=186061)

Endreon 02-07-2008 03:44 PM

Serious Issues!
 
Hello,

I just recently downloaded OJP Enhanced. Looks awesome by the way. The installer I received was from the main sticky, and I used ModDb to download. Everything went fine. I also clicked on the two pk3s and dlls in I think were in maxstate (?) siggy. I downloaded those as well. I followed the instructions of the downloader, deleted the old pk3s, and installed the new ones. I then proceeded to try to start the game. Two errors occur, I have screenies XD.

This first is if I click the shortcut installed. (Note: There is no runojpenhanced.bat in my folder... Only a runojpenhanceddedicatedserver (names arent exact) so yeah, its like I cant just... start the game.) Anyways, shortcut error....

http://i17.photobucket.com/albums/b9...lth/error2.jpg

Now, seeing as that didn't work, I tried elsewise. I started JAMP, then went to the Mod screen, and clicked, after about 10 seconds, I get this...

http://i17.photobucket.com/albums/b9...lth/Error1.jpg

This game is pretty well clean. It is v1.01, or whatever the most updated is. I have the CD, this is a laptop XP version, made in the last year or so. I have UU, and one skin. No other mods whatso-ever, unless you count Ultra Utility. So im really at a loss of what to do, any help?

razorace 02-07-2008 04:05 PM

*sigh* This could be avoided if people used the autobuilder to create builds like they're supposed to.

Anyway, so you don't have any of the .bat files? They aren't /GameData folder?

Endreon 02-07-2008 06:32 PM

>.> Autobuilder....?

Anwyays. I have one .bat file in the ojpenhanced folder (which is in gamedata). However, there are none in the gamedata itself folder. Heres a photo of my c/programfiles/.....etc/JediAcademy/Gamedata/ojpenhanced folder. I always show better than tell, so yeah...

http://i17.photobucket.com/albums/b9...ncedfolder.jpg

Thats that one. In my gamedata I have only a few things they are: libxca.so.1, jamp.exe, Jampded.exe, jasp.exe, eaxman.dll, ifc22.dll, jagamex86.dll, openal32.dll, servercache.dat, base folder, and ojpenhanced folder.

Should I just re-install everything, including JKA?...

Maxstate 02-07-2008 08:28 PM

You should remove the mod, then reinstall the one from my sig and run it normally. It should work no problem, if it doesn't, it's not our fault since it has worked for dozens of people so far ;9.

The ones from my sig lack an actual .bat that you can run them with, hold on..


http://www.mediafire.com/?4dyu3xmx1ww

That goes in gamedata, run the game with it.

JRHockney* 02-07-2008 09:02 PM

Quote:

Originally Posted by razorace
*sigh* This could be avoided if people used the autobuilder to create builds like they're supposed to.

Anyway, so you don't have any of the .bat files? They aren't /GameData folder?

Um, we did use it...er the installer creator at least, but it kept creating a build with faulty a Enhancedstuff pk3 so we had to make another download with a working one. We'll probably have to do this until we figureout why it keeps doing that. My installer creator doesnt even work. So far, the ones we have put out were made by Jack or darth.

Endreon 02-07-2008 09:51 PM

Hmmm

Well, I un-installed the game, and then installed. After that, I went to gamedata, made ojpenhanced folder, put JUST the two pk3s in... Then I went back to gamedata and put the .bat file. I got the exact same errors... I hadnt even added any skin/models yet. Then, out of curiousity, took the files from the installer (except the pk3s) and put them in that folder. Still, the exact same thing... So, any ideas? I even un-installed UU... If I put the playojp.bat thing in the ojpenhanced folder, it flashes black for all of a second, then dies... if its in gamedata, it gets that first console error seen above. And yes, my completely regular JA is working. So its not the CDs or anything.

P.S. Yes, I updated to 1.01 first...

Vesnik 02-07-2008 10:09 PM

I'm not sure why this works for some people and then not for others.

All I did was install JKA, then installed the 1.01 patch. From there I got OJP and used the installer to install, and then dragged and dropped the new pk3 stuff and dll files in the folder to overwrite.

The way I start my game is with the icon it put on my desktop that I chose to create at the end of the installer.

That's it. Everything works fine for me, not sure why not for some others.

Endreon 02-07-2008 11:22 PM

Hmmm

This is so wierd... I re-installed OJP, it worked fine. However, when I try to put the new dll and new pk3s in, THATS when I get the errors. The old pk3s and stuff seem to have some bugs, but atleast they work... Any further ideas :/....

Maxstate 02-08-2008 05:43 AM

That's weird, thanks for telling me, though. I'll get some people to test it out and see what's wrong.

JackBaldy 02-08-2008 08:57 AM

Quote:

Originally Posted by razorace
*sigh* This could be avoided if people used the autobuilder to create builds like they're supposed to.

Anyway, so you don't have any of the .bat files? They aren't /GameData folder?

Problem is (Which I have told Hocks and I am disappointed that he still does not know), there are missing files in the repository. When the installer/auto builder is used, the missing repository files cause the installer not to place them in the EnhancedStuff.pk3 (Which makes sense, obviously). If all the proper files were in the repository, the auto builder should work like a charm as it has in the past.

razorace 02-08-2008 02:37 PM

What files are missing? That's definitely not so good.

So, until we get this resolved, what's the last working install file?

We need to make sure that we're pointing to that in the "Get OJP" thread so that common users won't get frustrated. :)

Endreon 02-08-2008 03:37 PM

Okay, further details....

I re d/led both those files, again. I put the enhancedstuff.pk3 in, and it worked like a charm. The only issue was the sabers still looked kinda funny, and the niman backstab animation glitch. I then attempted to put the enchanceddll.pk3 in, and thats when I got all those silly errors. I kinda said w/e and went online to try OJP out. (Tis massively awesome, I love Niman, Makashi, and Shii Cho) There I met with a couple people, and they were able to supply me with a working dll, so that the only glitch I can see is sabers are still wierd :/ So, something about that dll file in your siggeh maxstate is what appears to have given me those errors. However, thanks to said people, I was able to get a working version, and youve got a new player for OJP ^^

So yeah, I dont have issues anymore, but others might, so you might want to check out that dll file...

JRHockney* 02-08-2008 05:50 PM

Quote:

Originally Posted by JackBaldy
Problem is (Which I have told Hocks and I am disappointed that he still does not know), there are missing files in the repository. When the installer/auto builder is used, the missing repository files cause the installer not to place them in the EnhancedStuff.pk3 (Which makes sense, obviously). If all the proper files were in the repository, the auto builder should work like a charm as it has in the past.

I had darth look into that after you told me what file it was and I thought he added it back for the update. Its still not in there?

UPDATE: yeah your right. WTF! I could have sworn we added those back for the update :/ Something must have gone wrong in communitcation or update. Darths adding them back and we can all expect another update soon.


All times are GMT -4. The time now is 12:37 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.