LucasForums (
-   JA Modeling (
-   -   New skeleton (

New_New_New 01-14-2009 03:35 PM

New skeleton
Is it possible to create a new (for example nonhuman) skeleton? What programm could be used for it? I tried to create a new (very simple) skeleton for a nonhuman model in Softimage XSI 6.01 Mod Tool, I did hierarchy, bones weighting, simple animation and exported to xsi 3.0. It was a miracle, but carcass made .gla and .glm without mistakes. When I opened my model in ModView it looked perfect, but when I tried to play animation It all was messed up, I mean model was moving but not the way it should (wrong direction). After that i did another animation just for another test but now when i try to compile it carcass displays 'cubic keys' error...
I know that there are models with custom skeletons (droideka and acklay_mst for example) so it's possible, but how? Maybe there is a tutorial or something?...
P.S. sorry for my english...

Psyk0Sith 01-14-2009 05:24 PM

XSI should be able to do this, that's what raven used for the game after all. 3D studio max 4.x and 5 can definately do this, later versions im not sure (compatibility issues with the export plugin, i believe it stops at version 8)

The wonky movement could be a result of bone pivot point orientation. I know that 3D max's coordinate system is different from the game's so the same thing is probably happening with XSI. When i made the AT-TE skeleton with 3D max, some of the bones didnt match the orientation in modview. When troubleshooting, i simply rotated the problem bone 90 degrees (in reality i changed it's pivot point) to the left for example, and when modview played back the animation, the orientation was correct.

This was because i created the bone in the improper viewport or simply the pivot point conflict between max and the game. If you can identify a bone that behaves correctly in modview and check its pivot point in XSI you should be able to point out the game's coordinate system difference between both of them.

New_New_New 01-15-2009 03:33 PM

I wanted to check your advice about pivot point orientation but now whatever I do carcass always gives me "File contains 'cubic' scale keys" error, though my windows regional settings are set to US. I have no idea how it worked the first time... And I have no idea what to do about this error... Thanks anyway...

By the way, one of my friends tried to do skeleton in 3Ds Max 5 (XSI exporter v.1.6.1) but not successful. He's got something wierd.
When model's meshes and bones are linked as usual, then (after carcass compiling) in ModView model looks very strange. All bones are situated normal but something wrong with the surfaces/meshes. Those meshes which are weighted to one bone (fore example mesh "head" is weighted to bone "head_bone", mesh "neck" is weighted to bone "neck_bone") are separated, situated in different dinstances from they bones and rotated . One mesh which weighted to several bones (for example the upper part of mesh "tail" is weighted to bone "tail_bone1", the middle part to "tail_bone2", the lower part to "tail_bone3") is deformed and also rotated and situated in some distance from skeleton. And something wrong with the scene_root orientation - looks like it's rotated too... But meshes and bones are connected, it can be seen while playng animation.
Can it be because of pivot points too?

Psyk0Sith 01-15-2009 04:51 PM

Cubic scale keys:

Yeah this is tricky i'm not exactly sure what's causing this now, i used to think it was regional settings...but doesnt work for everyone. Try switching your keyboard to english when you export your file from XSI.

As for your friend's problem, he should always apply a reset xform before doing the weights. This has caused many problems to modders, it's a problem related to max's tools. To reset xforms, check the first part of this tutorial:

root orientation:
-before exporting the scene, select the "mesh_root" object from your scene and delete it.

In Assimilate check "Keep motion bone" and "make it's own skeleton" change the path to "models/players/_humanoid/"the name of your new animation" dont name it _humanoid.gla!!!! you can also change the path so it points to your character dir (just make sure you remove c: ) Next go to the "frames target" option (press + on the folder...) hit clear where it says ROOT do not change anything else.

New_New_New 01-16-2009 05:58 AM

I've got it!!!!! There is no more 'cubic' scale keys error!!!!
I desided to search XSI help documentation using word "cubic", as a result I got a lot of articles and among them I found something interesting. It was "Export Crosswalk Options" and in that article there was information about animation resampling and types of interpolations which included FCurve Interpolation, Constant, Linear and Cubic. I thought that something like that could be in XSI export options. So I looked closely to XSI export options and found that they were more then I first saw, I just didn't scroll down. So I found there Animation Filtering, turned it on by checking 'Plot' and changed interpolation to Linear. Now it all works, and animation plays as it should. I'm so happy :) Now I'm going to create full skeleton and animation...
I told my friend all your advices and I'm going to wait his results. So I suppose it's not my last post here.
Psyk0Sith, thank you very much for your help!

Psyk0Sith 01-16-2009 03:52 PM

Glad to know it works! altho i'm afraid i wasnt much help :D, you found the REAL problem yourself.

Weirdly enough Max doesnt have these export settings and changing regional settings fixed the problem for me (unless i changed something in the export dialog without knowing).

By the way are you making new humanoid animations or custom character / vehicle?

New_New_New 01-16-2009 05:49 PM

I'm making a custom character (it's a monster).
And you were right, it's really tricky...
I load one xsi file (it was asassin's droid both_stand1idle1) from "" to learn more about hierarchy, bones, envelopes and i just thought that i could compile this model to check my theory about connection between that linear interpolation and "'cubic' scale keys" error. I exported that model with splile interpolation (wich is default) and carcass compiled file without any errors. So I supose that something was wrong with my model, not with export options. And i found some more strange issues... So i'm going to study closely models from to make my model properly. And maybe i'll have to study more closely some parts of xsi help documentation too...

nizwiz 01-17-2009 03:46 PM

Maybe you should first try and make some new animations for the default playermodel skeleton and see if you can get them compiled and in-game.

New_New_New 01-18-2009 04:09 PM

No-no, my custom model is compiled very well, animation which i've made looks good both in ModViw and in game. But now there is another problem, it should be a flying creature with wp_melee attack, but there is no proper flying class (wich i must write in .npc file) in JA. Class_probe, class_interrogator, class_seeker and class_rockettrooper are not exactly what i need, they can fly but stay in some distance from player, so there is no melee attack....
I think i'll write in .npc file an ordinary class (maybe gran or something that uses melee attack) and make a spawnscript which change npc's gravity to 0...

nizwiz 01-19-2009 01:47 PM

Have you tried CLASS_BOBAFETT?

New_New_New 01-20-2009 04:05 AM

Yes, i've tried... Somehow it shows blaster fire and flame-thrower though i wrote wp_melee in .npc file. Anyway zero gravitation works fine.

New_New_New 11-16-2010 05:07 PM

To not start a new thread...
I've made a little droid (in XSI Mod Tool v 6.01), made custom sceleton, hierarchy, weighting, animation, exported it to xsi (3.0, animation filtering - raw data (tried also standard - constant and standard - linear)) , assimilated it. Everything is good and in ModView I see that all animation works fine. But when I get my model in the game only animation of upper part is playing, legs stays unmoveable :( I don't understand why(
Details: as my droid model is simple, there are no tags , no motion bone and no stupidtriangle_off mesh. Can they have any affect on animation?
I've studied assasin_droid model - it has no stupidtriangle_off mesh and no motion bone, and still it walks...
Also for example gonk model has no tags and still it walks...
I don't want it to look like complaining. I just wonder maybe someone have encountered with this problem.
I think I've found the problem but I still don't know how to solve it. Problem is:
I've got such hierarchy: mesh_root linked to hips, hips linked to torso right_leg left_leg etc
skeleton_root linked to pelvis, pelvis linked to lower_lumbar left_leg (root) right_leg (root) etc
Torso weighted to lower_lumbar, hips weighted to pelvis, right_leg and left_leg linked to their bones. In this case lower animation is not working in game. But when I link left_leg (root) and right_leg (root) to lower_lumbar all animation is playing in game, and legs are moving, but in that case if I move torso (lower_lumbar) then legs are moving too...

All times are GMT -4. The time now is 05:51 PM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.