LucasForums (
-   JA Mapping (
-   -   GTK Radiant Shader Issue and More (

Augwich 06-12-2009 01:39 PM

GTK Radiant Shader Issue and .bsp issue
The whole story is slightly complicated, so I'll try to run through it as concisely as I can:

Recently, I decided to make some maps in JKJA. However, with no knowledge of Radiant, I had no idea where to begin. Luckily, I found this great tutorial by RichDiesal - Let me say that it has been great! However, I notice that the tutorial was written originally for JO, not JA.

Anyways, I followed through to making my first room using JK2Radiant as it had suggested. But when I tried to load it in JKJA, it said that it couldn't find the .bsp version of my map. Not sure what it meant, I copied the .map version and renamed it so that it was .bsp instead. Now the error in the game was something to the effect of "cannot load map because version is 19something-or-other (should be 1)". I assumed that this was because JK2Radiant was just that - for JK2, and as such didn't work with JKJA.

After looking around online, I found a newer version of Radiant (1.4.0) and installed it in the same place as where JK2Radiant was. But now, for all the texture images it had a checker-board of red and black squares with an overlay saying "shader image missing". I uninstalled the 1.4.0 version, and then installed the GTKRadiant v1.5.0, to no avail. Since I really am still a noob in this area (I'm not even sure of the difference between a shader and a texture :rolleyes:), could anyone please explain to me what I'm doing wrong that's making the shader image missing thing happen, and how to fix it? (btw, JK2Radiant still sees all the "shader images" - I haven't yet uninstalled it).



acdcfanbill 06-13-2009 12:03 AM

the raven 1.4 version of Radiant should be installed to it's default location with the JKA specific files in the JKA folder. You may need to reinstall. Also, make sure GtkRadiant is in JKA editing mode.

As to finding the bsp, you have to compile the map, which rich deisel lists in section 102 lesson 2. Don't rename your .map files, this just changes the extension that windows sees and does nothing to make them playable in game. .map files are basically a list of every object (by origin, vertex, name, edge, etc) that you have placed ingame. a bsp contains much more data. consult your manual/help in radiant for info on all kinds of stuff like this (Help -> manual, or hit the F1 key)

A texture is a file that is a picture. These 'pictures' are what cover the polygons in the game. A shader is a text file that modifies a texture in some manner. Shaders can do ton's of things, make the texture move, emit light, or even give the game engine specific hints on how to display the world.

Augwich 06-13-2009 12:53 AM

Got it all to work - thank you so much! Not sure why trying to compile it after this particular re-install worked, but it did.

As for the textures - turned out I had installed the JKJA files in the default choice - which happened to be in a old location that I didn't know still existed.

Again, thanks so much for your help!:^:

Augwich 06-21-2009 06:14 PM

Ok, now I'm having problems where GtkRadiant won't correctly draw brushes in the 3D view that aren't entirely in the window. It shows the edges, but that's it. It makes it really hard to assign textures to the brushes, as well as discern where the brush is. Here's a picture:

Also, I've discovered that it won't draw them if I move too far away.


EDIT: I have noticed that detail brushes are being drawn fine. As soon as I make a brush a detail, it shows up normal. However, I know that I don't want to just make them all detail brushes as this will create leaks. Any ideas on how to fix the problem?

Any help would be appreciated.

acdcfanbill 06-22-2009 12:05 AM

1 Attachment(s)

Ok, if you see the buttons I have arrows pointing at, the one on the left is your texture view mode, make sure this is not on wireframe as that can cause brushes to appear as wireframes. The one on the right, is called cubic clip and this clips brushes and entities from view if they are far away. This can be very nice in some maps with a lot of stuff to draw since drawing is software based, it can get very slow in complicated maps, but in large maps or just starting, it can clip stuff you want to see, so I leave it off and only turn it on occasionally if I need to speed up the drawing in the 3d window for any reason.

Augwich 06-22-2009 04:45 PM

The cubic clip button fixed the issue with brushes disappearing by going to far away from them, but I'm still having the wireframe issue. The texture view mode is not set on wireframe (it's on Bilinear Mipmap), yet non-detail brushes are being drawn as wireframes if they're not entirely in the 3D view window (detail brushes are being drawn fine).

acdcfanbill 06-22-2009 09:08 PM

Maybe that's a graphics card bug, are you running an ATI?

Augwich 06-22-2009 11:21 PM

I'm not sure - it sounds familiar. How do I find out again? I'm feeling really tired right now and can't remember exactly.

acdcfanbill 06-23-2009 12:24 AM

goto start -> run and type in 'devmgmt.msc' without the quotes.

Open the drill down menu for Display Adapters and it should tell you what card you have. If you do have an ATI card, you could try ticking the box in Radiant Prefrences -> 2D rendering -> ATI cards with broken drivers - bug #802

Then restart Radiant and see if that helps.

Augwich 06-23-2009 10:08 AM

Aha! Now it works! Again, thank you so much!:)

acdcfanbill 06-23-2009 12:40 PM

good to hear, now go build some cool maps :)

-=*Raz0r*=- 06-23-2009 09:56 PM

Just out of curiosity, acdcfanbill, do you build your maps and then texture them?
I guess that would make sense seeing as I can't see a texture window in that screenie :P
Do you find that easier to do?
I guess it's good practice (building with caulk to increase fps)

acdcfanbill 06-24-2009 02:16 AM

I generally build in the default texture so i can test architecture in game and sometimes sparingly use other textures, then caulk everything and retexture it all. But I've seen guys who texture as they go and do a very nice job, whichever you prefer as long as everywhere that needs caulk gets caulk :)

All times are GMT -4. The time now is 02:20 PM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.