LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   JA Modeling (http://www.lucasforums.com/forumdisplay.php?f=535)
-   -   Nearly finish : I need an older carcass version (http://www.lucasforums.com/showthread.php?t=198765)

stefbuet 06-29-2009 10:26 PM

Nearly finish : I need an older carcass version
 
Hi all!

I'm trying to make a new vehicule to the game : a hummer :D
After having some difficulties to make my XSI 3.0 model as I got 3dsmax 9 and my pc didn't had US regional setting, I final managed to get the XSI file ! :)

I'm following the tutorial :
http://io.meskinaw.net/vehicle_impor...al_for_ja.html

Now I'm coming on the compiling step, with carcass thought assimilate.
I get an error message :
"adding new bone - ("XSISceneRoot") exists more than once in this file, bad skeleton!"
I saw that :
http://www.lucasforums.com/archive/i.../t-131892.html

Particularly :
The XSI 3.0 exporter from Raven or any XSI exporter, adds the root and effector to every bone chain, since that's how Softimage XSI and 3D handle the chains.
The problem comes because you're using the latest version of carcass, the one that compiles the XSI 3.5 files. For some reason that version goes bananas when trying to compile XSI 3.0 files that make it's own skeletons.


I get my carcass.exe from the JA SDK from filefront and I tried from the first and second version of the SDK : same error.

So, I'm looking for the old carcass.exe (carcass30.exe?) which load XSI 3.0 and not XSI 3.5 files. Anyone got it? Please, share it :thmbup1:

Thank you very much!!

Stef.

Psyk0Sith 06-29-2009 11:10 PM

Isnt it the version in the Jedi Outcast SDK? ive been using that one since 2002.

http://jediknight3.filefront.com/fil...ing_Tools;2433

Let me know if that worked. Someone else just told me about this issue today. Also, i thought compiling vehicles stopped with max 6 or 7 and characters stopped with max 8...im a bit surprised it still works with max 9.

stefbuet 06-30-2009 07:53 AM

I have just one thing to say :omg
I've realised after many hours of research, I was all the time changing assimilate and not the compiler it's using : carcass.
So, in fact I already had your link SDK, but I changed previously the assimilate instead of the carcass file, what a shame! I'm shocked :p

However get still some error : I had lot of objects, and in order not to apply a skin to everything, I decided to convert all objects to a group which is considerared as an object. But now carcass just can't get there objects... Working on it, you'll have some new from me ;-):thmbup1:

stefbuet 06-30-2009 10:21 AM

Ok, I applied the skin modifier on the group made from all objects, then I just ungroup it and all objects had the skin modifier. Now, it compile great with carcass, yihaa! :p

BUT, when trying to open my model.glm widht the model wiewer, I can saw parts of my car desassembled and not really at the good place (translations).

However I decided to continu...
I made the pk3 structure, made a skin file with this structure:
object_name,texture_name

All objects are serapared by a new line. I got now a first question : are PNG texture file suported, or it's only JPG and TGA file ?

I had a npc file with the correct structure (like in the tutorial)

Then, I made the veh file, importing a swoop veh file and changing name, model and and title...

Turn the whole thing into zip and renamed in pk3 and putted it in JA Base.

Result :
/npc spawn vehicle hummer_stef :
->could spawn hummer_stef vehicle

He find the veh file as when I forget to put the pk3 it told me "vehicle not found" but however something is wrong... Does the 3dsmax object size count? Because we set anothe size in the npc file.

Maybe the error is in the animation.cfg file generated by assimilate as it contain the following data :

// Format: targetFrame, frameCount, loopFrame, frameSpeed
0 101 0 30 // fix me - invalid enum -


Thanks for helping ! :thmbup1:

Psyk0Sith 06-30-2009 10:22 PM

I'll do my best to help based on my limited knowledge of vehicles.

-PNG shouldnt be a problem, pretty much the same thing as a .TGA.

-There is a scale factor that you need to follow. I know this because i scaled my AT-TE way too big on first attempts and it didnt work right in the game (i cant remember in modview).

If you load the JA skeleton, you'll have the correct size and units for a player model. When i set the default units within max to "international", the player's head stops at 104 units, the maximum scale for a vehicle is roughly 275-280 units.

-If i remember correctly, there is a limit on the number of frames each animation sequence can have, the magic number is 100 (or 99 + 0) i believe. That would be the cause of "invalid enum" error.

-I believe the scale in the .NPC file is a conversion for in-game units. You can see the units of the box in modview, its mostly used to create the bounding box of the object, for collisions and whatnot.

stefbuet 07-01-2009 01:17 AM

Je viens de voir sur ton portfolio que tu parles apparament Français :)
On va peut être continuer le thread en Anglais histoire de donner l'opportunité à tous de résoudre des problemes similaires :thmbup1:

You're probably right, my model is too big. In fact in the tutorial I'm following we can see that the model is standing on about 3 or 4 squards of the central grid, however my model is about 2 or 3 times the whole grid! :tng1:

So firstly I'm going to scale down whole object parts and then I'll do again the skining thing without using a group as I think this probably change my model parts property (bad translations when I view the glm model).

I'll put back some news in there.

Thank for helping! :)

stefbuet 07-01-2009 06:25 PM

Hey, here are some news!

So, after having working so much on my Hummer, I just didn't anderstand what was going on. My model is a little strange I must say, but I will tell you more about that a little later.

So I decided to make a really fast modeling with simple forms to try finaly making a vehicle! And, surprising me, this actually worked at the first time! How could this be possible ? Oh well I just get a few error about my texture which wasn't squard dimentioned.

So here are some screens of my first ever vehicle, made in about 10 minutes :indif: Well, I just made the first thing I had in mind, so don't ask anything about it lol!

http://img522.imageshack.us/img522/7219/fishfunny.jpg
http://img505.imageshack.us/img505/7272/fishfunny2.jpg

But now, after having fun, lets go back to my Hummer. I managed to spawn it in JA (yeah! ^^) but it's desassembled, as I was seeing it in MODView.

Here are somes screens to show you more precisely :
The model in JA (not textured because I didn't completed skin file)
http://img268.imageshack.us/i/hummerprobleme2.jpg/
The model in GLM Viewer in wireframe mode
http://img142.imageshack.us/i/hummerprobleme3.jpg/

From 3dsmax (5) but modelised in 9 :
http://img528.imageshack.us/img528/1541/screeng.png

I think the main probleme is that I'm using some special objets in my Model.
I mean, for exemple I modelised a first wheel, then I duplicated it 3 times as an instance of it. In an other hand I used some geometric tools in 3dsmax for exemple to make the left of the car really faster from the right objects. I had some problemes with weighting everything as some objects had some strange behavior, that's to say when everything was weighted to the main bone, moving it was translating some objects in a way, others (copy of them by symetry) goes to the opposite way...

Need to fix this probleme, how could I let all my objects fixed together ? I'll think about it, but, what do you think about it? (And what about my other model? lol :tng1:

Psyk0Sith 07-01-2009 08:25 PM

Eh oui je parles français :).

The first thing you want to do before skinning weights, is reset xform your meshes.

Follow the last 2 steps in the "Loading and importing your character mesh "
http://www3.sympatico.ca/psykopat/tu.../skinwrap.html

If you see your vehicle blow up to pieces like in the probleme images, that means your xform were messed up. This happens when manipulating objects out of the sub object mode.

Another quick solution is to pick a non xformed object...the "chassis" of the hummer looks correct, so you could go in sub object mode, attach everything to it (not the other way around) and detach the pieces back when necessary (like wheels so they can animate independantly from the body).

Do not use grouping for the game model, grouping is a tool used strictly in max, the closest thing the game engine uses is linking, so linking or attaching is fine.

I'm not too sure about the last problem, it could be mirrored bones that have their normals inverted so they react the opposite way, or instanced meshes instead of cloned meshes.

...and the fish vehicle is pure genius, seriously, who wouldnt want to ride such a beast?! :D

stefbuet 02-16-2010 04:19 PM

Shame on me.
I made a new jeep model and I'm not able to export it to XSI 3.0.
How did I do ? Arrrr, I can only export to XSI 6.0 and I don't event remember how I did export this to 3.0 :mad:

Psyk0Sith 02-17-2010 05:01 PM

In max plugins there's sometimes version compatibility you can select...see if there's one available?...that's the only thing i can think of right now.

stefbuet 02-19-2010 10:27 AM

Oh, well I remember now.
I used 3dsmax 5 (Yes I found it somewhere on the internet...) with a XSI 3.0 exporter (the same as Duncan_10158 is using in his tutorial).

I made a new Hummer model, avoiding symetric things, and things which made me fail last time with this vehicle. The fish wasn't enought for me :p

So here is my new vehicle, with its own 6 x bullet rifle (new effects & sounds).
Pretty cool :thmbup1:

http://img519.imageshack.us/img519/5061/hummerjaok.png

Thank you for having helped!

Bye.

Psyk0Sith 02-19-2010 02:35 PM

Hehe looks great! glad i could help. :)


All times are GMT -4. The time now is 01:33 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.