LucasForums (
-   Squad Tech Support (
-   -   Strange glitchy thingy (

Ubermensch 11-17-2009 02:40 PM

Strange glitchy thingy
Hi all.

I've been experiencing something going wrong in multi player (not just in RC, all my games, though RC copes with it a little better)

At a random time during the game, RC simply cuts out. I'm left being able to move around but nothing happens. All the players move into the nearest wall, and I'm left dead. It's like lag I suppose, but I've had it happen in servers where my ping is only 60-70. This, in turn, ,makes me have to disconnect from the server, then reconnect, then it says 'Your CD key is invalid or being used by another player'. I understood the CD key was unique...

Can I have some help?


HockeyGoalie35 11-17-2009 05:15 PM

from what i know, it seems as if its just a lag problem even though you have pretty good ping.....i'm sorry i cant help

Ubermensch 11-18-2009 08:59 AM

Hmm... It happens in EVERY server I go to, and even in my other games...

I'll email Lucasarts and see what they can help me with. Thanks anyway, Hockey

K1lingdr3ad 11-18-2009 11:26 PM

Yes the "Your CD key is invalid or being used by another player" thing happened to me to. This usually occurs if you got the CD Key off the internet or borrowed the disk from a friend and used their CD Key. As for the lag thingy, the only thing I can think of is if you borrowed someone's disk and upon giving the disk back ran the game through Republic Commando>Game Data>System>Republic Commando exe (Which is how you play without the disk, but this tends to create some lag.) Other than that, no idea. Welcome to LF by the way Ubermensch. :D

Gamma097 11-19-2009 06:07 AM

First off, I'm pretty sure that the lag where people are running into walls happens when people abuse multiplayer cheats. Secondly, there's a program in the Republic Commando files called "CDKey.exe." If you installed the game to its default directory, then it'll be at:
C:\Program Files\LucasArts\Star Wars Republic Commando\Install
Find the icon that looks like the LucasArts logo and double-click on that. A dialog box will open, prompting you to retype your CD key. Type it in and hit OK. That should solve your problem.

Ubermensch 11-20-2009 10:18 AM

K1lingdr3ad: I got the CD key straight from the manual, didn't borrow or take it from the internet. It only seems to happen after I quit a game due to the lag and try to reconnect. And thanks for the welcome ^^

Gamma097: Thanks for the advice. I've yet to try it, but I'll report back when I have.

Thanks everyone :D

EDIT: I tried Gamma's method, didn't work... Lucasarts still haven't replied.

EDIT 2: I reinstalled on all my computers, it STILL doesn't work!

K1lingdr3ad 11-21-2009 08:54 PM


Ubermensch 11-22-2009 07:27 AM

Indeed it is. I'll send another email to LA.

Edit: I asked a couple of friends and they said my router could be faulty, so I'll try getting a new one. If you guys wanna see what happens in TF2 and RC there's a video posted on Xfire ( (

EDIT 2: I worked out what the problem was! The router was taking too much internets. Twiddled a few wires and it works fine now. Thanks for the help!

All times are GMT -4. The time now is 09:28 AM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.