LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Technical Help (http://www.lucasforums.com/forumdisplay.php?f=159)
-   -   Serious graphics problem, need help. (http://www.lucasforums.com/showthread.php?t=202641)

Forceboat 02-03-2010 11:08 PM

Serious graphics problem, need help.
 
I am having the same kind of graphics problem that a couple of people had in the past, but I don't think a definitive answer was reached, but, i need help if someone can. Firstly, my characters at the selection menu only show half of them, and then, there's all of this as well:

http://i46.tinypic.com/2ivgxw5.jpg

As you can see in that first pic, my character looks like she is sinking into the ground! That should not be happening at all. And then there's this:

http://i49.tinypic.com/2a5es76.jpg

The creek is high up instead of down at Jaden's feet where it should be, and i don't see the ship or Rosh for that matter either. And this problem appears to probably only plague the Yavin maps, as I tried ones like Korriban and t2_trip and they were fine, it's just the Yavin maps that are completely screwed up. Please, someone let me know what to do to fix this!!

nizwiz 02-04-2010 01:14 AM

Have you updated your video drivers, recently?

Forceboat 02-04-2010 08:57 AM

I think they are up to date; just in case, I have DirectX 9.0c and my graphics drivers/card is a Nvidia GeForce4 MX 420, and I installed ForceWare Release 90 Version 93.71 WHQL (installed both last night). Now, are either of these things good enough to run the game anymore, or is there newer versions of either thing that would fix the problem, or, do I need to maybe get older Nvidia drivers? After downloading both, I still had the same issues, so it didn't work. :confused: I've also tried uninstalling and doing fresh re-installs of the game a few times, and that didn't fix it, either. This appears to only plague the character and saber selection screens and only the Yavin levels (the rest of them are fine). Let me know what you think. Thanks for the help, nizwiz, I do appreciate it. :)

nizwiz 02-04-2010 03:24 PM

Oh, ok, so I guess you've used that set of drivers for quite some time now. I was actually suspecting that a glitch crept into a newer set of drivers (may happen from time to time, especially with the OpenGL parts), but that's obviously not the case here. Anything else you changed on your system since the last time the game worked without glitches?
To be honest, I don't really have any other suspicions right now.

Forceboat 02-04-2010 05:35 PM

Well, thanks for trying to help me. I don't know what's wrong with it, i have tried everything, so I guess it's permanently screwed up. With the kind of day I have had today, it's one of many things that went wrong today, so, the hell with it. Thanks for the help in any case.

UPDATE: some nice guy over at Filefront helped me solve this, didz93, and here's what he said to fix it, I never even knew about this, this would be a good stickied ref for anyone else who ever has the problem I did:
Quote:

That looks like a rendering primitive issue. In your console try doing r_primitives 0 then r_primitives 1, then 2 then 3. But don't go over 3 or your whole view will vanish and you don't want that.

Elvenwarrior2001 05-28-2010 05:49 PM

I hate to wake up a dead thread, but I'm having this EXACT problem. The screenshots are identical (except my character is a male human...). My question is what are these "primatives" and how do they help? I'd kinda like to know what I'm doing before I start fooling around with "primative rendering," whatever that is.

Forceboat 05-28-2010 11:12 PM

I think it has something to do with the way the graphics are rendered. Why so many people are beginning to have this error, I have no idea, I wish I knew why it has affected so many people's copies of their game. But try it, it will correct the problem.

Elvenwarrior2001 05-29-2010 01:45 PM

Thanks for the tip. This worked just great for me. Didn't see a difference at 0, 1 got rid of it but it looked weird, 2 was kind of where it was before, and then 3 looked good. I guess it's like changing gears on a stick shift, you just up-shift through them to 3.

Well however it works, it worked. Thanks, man! :)


All times are GMT -4. The time now is 09:19 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.