LucasForums (
-   Troubleshooting (
-   -   [Xbox 360] Hoth DLC not working (

Legion1987 02-26-2010 03:40 PM

Hoth DLC not working
So I've purchased and downloaded the Hoth mission pack DLC over the Xbox Live Marketplace. When I go to the extras mission menu in Force Unleashed, all the others I've downloaded are there but Hoth is not. I have redownloaded Hoth at least 5 times... Help!

iss407 02-27-2010 05:03 PM

Me too
I just bought the Hoth Mission Pack today and I can't find it anywhere. Both the Jedi Temple and Tatooine Mission packs worked fine. I think I've now spent twice as much $ on DLC as I did on the original game. That's bad enough but to pay even more for DLC with NO REFUNDS that doesn't even work?!?

Lucasarts games have been wonderful for the most part. The creative teams do a great job. But the idiot monkeys in suits that run the business side (and do a better job trying to choke every last $ out of us than Vader could ever hope to do with his force grip) are going to push too far one day and I'll just give up. I love playing a fun and entertaining game, but I like not being treated as bottomless ATM even more.

LordOfTheFish 02-27-2010 11:11 PM

I'd suggest that both of you post your problem here at the LucasArts Tech Support Forums. Usually there is someone there that can answer your problem. ;)

Best of luck to the both of you, and welcome to LucasForums! :)

Shem 02-28-2010 01:14 AM

You guys need to START a new game to play it!

Legion1987 03-01-2010 09:42 AM


Originally Posted by Shem (Post 2709381)
You guys need to START a new game to play it!

That makes no sense.. why would I need to start a new game to do one mission? Especially when ALL the other DLC missions are already there in the extras menu.

Shem 03-01-2010 07:02 PM


Originally Posted by Legion1987 (Post 2709601)
That makes no sense.. why would I need to start a new game to do one mission? Especially when ALL the other DLC missions are already there in the extras menu.

So you're stubbornly not going to try that method. Fine, don't play the mission. It's obvious you want it done in a certain way or you won't play at all and complain about it. I don't understand the harm. You hit start a new game. They'll ask if you want to do the default story, the Jedi Temple, Tatooine, or Hoth mission and then you select the Hoth mission.

Now, if you want to try my suggestion, do it and let me know how it turns out so you can testify to others that the method I suggested works or you can continue to be stubborn. Your choice, but don't complain that I've taken away a reason to complain about this.

Ser'eck 03-02-2010 12:22 AM

Shem is right, you have to select new game to play any DLC. This does not mean that you will have to play the entire game, just the new level you downloaded. This was the method established by the game producers to access the DLC levels.

LordOfTheFish 03-04-2010 10:39 PM

Well, that's LucasArts for ya. :dozey:

Shem 03-07-2010 02:16 AM


Originally Posted by LordOfTheFish (Post 2710416)
Well, that's LucasArts for ya. :dozey:

What are you talking about?

Gatzu 05-28-2010 10:21 AM

I am having the same issue. I did try starting a new game, however it takes me right to Vader. I re-downloaded and tried again, however there is nothing. Also, I bought the DLC lightsaber, how do I access that?

Gedder 11-07-2010 05:08 AM

I'm having a similar problem, but it's both the Tatooine & Hoth packs that I can't get to load. I've read a few posts elsewhere on how to get round this issue but even starting a new game has not helped - I only have the option of either a new campaign or the Jedi Temple pack (which I downloaded ages ago). Understandably I'm more than a little annoyed given the 1600 points that these two cost me. Anyone got any ideas or solutions for me on this? Cheers!

mfinnie 06-30-2011 12:52 PM

im having a more similar problem, i own ultimate sith edition but the TATOOINE onew ont load -.-

balancer1138 01-12-2014 03:08 PM

thanks for the help with the hoth dlc -_-' boy do I feel dumb haha but now the Tatooine DLC that I have redownloaded 5 times won't even show up in the "NEW GAME" selection . . . Mesa could use help!?

All times are GMT -4. The time now is 11:42 AM.

Powered by vBulletin®
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2015 - All rights reserved.