LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   General Tech Discussion (http://www.lucasforums.com/forumdisplay.php?f=691)
-   -   My external harddrive has stopped working (http://www.lucasforums.com/showthread.php?t=203565)

HK-42 04-17-2010 07:01 PM

My external harddrive has stopped working
 
My 500 WD 500GB Passport has stopped working. I have used it for a few months and have about 200GB on it.

Now when I plugged it into my computer(vista) it says you need to format the disk in drive F: before you can use it. Yes or No, but this will erase my data. I have used it on this computer many times and have no idea why it is messing up now. Any idea how I can save my data?

Astrotoy7 04-18-2010 12:58 AM

That sucks. Tried it in any other pcs?

What does windows disc manager say?
Start>type in manage>computer management>select 'disk management' under storage and see what it says about the partitions(healthy, active etc)

Have you tried checking the disc for errors?
(go into computer>r click the drive in question>properties>tools>error checking)

Inside the shell of those things is a plain old laptop drive. Sometimes the circuitry that allows the SATA>USB interface gets affected - quite often from people who simply yank it out rather disconnect it from the USB manager (among many other reasons)

Also, just to be sure, try some different USB cables/ports if possible ;)

mtfbwya

HK-42 04-18-2010 01:06 PM

The Disk manager says it is healthy primary partition, and I cant check the disc for errors, cause when I right click on it freezes. And I tried all 4 ports, I havent used another computer because I dont have any.(but I did try my xbox and it did not appear)

DarthSlinky 04-18-2010 03:00 PM

Yeah sticking it into another computer might help, try an XP that sometimes works.

stingerhs 04-19-2010 12:31 AM

this is going to sound like an obvious question, but have you tried using a different USB cable??

i'm asking because it sounds like the signal from the drive is either being corrupted somehow or just flat out not responding properly. hopefully, its something as simple as the cable because if it isn't, then its likely the HD itself.

i'm going to assume that its under warranty; so if it is the HD, it should be a simple matter of contacting WD for support. ;)

HK-42 04-19-2010 04:39 PM

I dont have any extra usbs for this HD, but I did try a random usb that could fit and that did not work either. Also on XP it read the device(making the device inserted sound) but could not install it.

Would it be safe to format the HD besides the fact it erases my memory?(if its not already gone)

Q 04-19-2010 06:59 PM

Yeah, it should be perfectly safe to do that. I'd still try hooking it up to another PC first. Just borrow someone else's for a couple of minutes.

HK-42 04-25-2010 05:08 PM

well ive been trying to format it but so far it has been saying the parameter is in incorrect.

EDIT: Nevermind fixed. The format took all day slow as hell, but formatted and working. Thanks for helping!

DarthSlinky 04-26-2010 08:33 AM

Good job :thmbup1:

Sometimes portal hard drives, and flash drives just need to be plugged into another computer and reformatted.

Does anyone know if 7 corrupts portable drives like this? or is it just a Vista thing?

CapNColostomy 05-02-2010 01:36 PM

I'm having a similar problem myself. I have a seagate go 500gb external hd that crapped out on me yesterday. I don't particularly wish to reformat it. I've tried disk management. It freezes up if the drive is connected. Also, booting up takes me to blank black screen with only a cursor. If I ctrl-alt-del, I can get by that, but a system 32 window pops up. Without the drive connected, booting up is normal. When I hook the drive up, I get prompted with a "safely eject hardware" message in the taskbar. If I click on that, it shows the seagate drive there. It doesn't show up in the My Computer anymore. I've tried connecting it to other computers with no luck. I hate to admit defeat, but it looks like I may have to reformat it to me. Any ideas?

Astrotoy7 05-04-2010 10:53 AM

Quote:

Originally Posted by CapNColostomy (Post 2722352)
I'm having a similar problem myself.

Gday CapN. Nice to see you around these parts, though I wish it were under better circumstances as far as your HDD goes. :eek:

*Does that drive replicate that behaviour when you plug it into another PC?
*tried a different USB cable/port/both?
*Have you run chkdsk on it?

mtfbwya


All times are GMT -4. The time now is 09:54 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.