LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   General Tech Discussion (http://www.lucasforums.com/forumdisplay.php?f=691)
-   -   Mortimer on XP or later? (http://www.lucasforums.com/showthread.php?t=204624)

KievanMereel 07-06-2010 05:48 PM

Mortimer on XP or later?
 
I recently picked up the CD for Mortimer and the Riddles of the Medallion at a used game store, but I can't get it to run on Windows XP, even in Win95 compatability mode. I've done some searching and found a site where people are getting the same error, but I'm not finding a solution here on the forums.

The error is:
Code:

The procedure entry point SUnMapL5_IP_EBP_12 could not be found in KERNEL32.dll
(or something close to that)

Astrotoy7 07-09-2010 01:01 PM

If youre getting kernel paging issues, youre not going to have much luck forcing compatibility in an OS with a different kernel. You could try vmware with a Win95 image, but there are no guarantees even in that.

mtfbwya

guypsd 08-25-2010 07:02 PM

My solution
 
Hey, I get the same error message.

Here is what I did to fix it:

Copy all the contents of the CD to a directory on the hard drive eg: c:\games\Mortimer\ (Including the hidden files Dsetup16.dll and Dsetup.dll).

Now you can remove the CD.

In the directory you copied the game into right click the file Shell.exe. Choose “Create Shortcut”.

Right click the new shortcut called “Shortcut to Shell.exe” and choose “Properties”.

In the field called "Target:" add (desired username).mrm eg c:\games\Mortimer\shell.exe player1.mrm

Hit OK and now you should be able to run the game using this shortcut. Make sure you have a joystick plugged in or it won’t work (The game displayed a corrupted screen when I didn’t have a joystick plugged in).

This skips the game's Launcher where you create your character, so you have to play as the boy. Also I'm not quite sure what difficulty it defaults to; but it runs.

If you have any old saved games just copy them into the folder and refer the shortcut to them.

If you want to play as the girl and choose your difficulty level you can run the game’s launcher through Virtual PC 2007 (running win 98). Run Mortimer.exe and create your character using the launcher. It won’t run the game but you can copy the character file it creates in C:\MORTIMER\ (on the virtual drive) into the game’s directory (on your real hard drive). Then just refer the shortcut to the .mrm file that was created.

Also I don’t know how necessary this is but Lucasarts has an updated shell.exe in its support section:

http://www.lucasarts.com/support/update/mortimer.html

I replaced my shell.exe with this file and it works just fine.

I hope this works for everyone!

KievanMereel 09-11-2010 07:01 PM

Wonderful! I forgot to plug in my joystick at first and was stuck at the corrupted image, but after following your instructions it works fine. Thanks!

The only issue I have left is that I don't know how to exit the game. I hit Esc and nothing happens. I have to Alt-Tab out and manually close the game from there. Thanks for any help!


All times are GMT -4. The time now is 04:00 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.