LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   The Work Bench (http://www.lucasforums.com/forumdisplay.php?f=554)
-   -   KOTOR 2 TSL: Crash after character creation + intro movie (http://www.lucasforums.com/showthread.php?t=206235)

Corran Halycon 12-21-2010 12:59 AM

KOTOR 2 TSL: Crash after character creation + intro movie
 
Hi all,

First time poster, long time Star Wars fan and KOTOR player. I've recently left home to travel Australia, so I bought myself a little notebook to entertain me/skype family/get internet access. The CPU is an Intel Atom N450 and the GPU is an integrated GMA3150 (windows 7). Nothing to really set the world on fire at all. Now I know that intel chipsets aren't really supported by KOTOR (1 or 2) but I managed to play through the first game and completed it a few days ago with little problem (some instances of <10 fps but it was playable).

Kotor 2 seemed to work fine, loaded up, went through the character creation process and the intro movie, heard a few seconds of sound from the game and then got a KOTOR2.exe has stopped working error. Firstly I would like to state I have read and tried multiple times to do what the sticky thread suggests to get a game working , followed it to the letter.

I was so sure 3D-analyzer would get the game to work by emulating the hardware h&l (something that boosted my fps in kotor). Alas that didn't work.

I'm at a loss to get this game working, I found it odd that my system can load the character model at the main menu and character creation screen, but then crash trying to load the game world. Obviously it's a gfx card issue, but as I can run kotor at an acceptable level I would assume that kotor 2 isn't much more than a stones throw away.

I know there have been a lot of other people with a variety of intel chipsets getting the same problem,and they haven't solved it. Does anyone with more technical knowledge suspect it is fixable? Or am I just grasping at straws?

Kind regards and many thanks to anyone that takes the time to read through this!

p.s the system scan green lights everything apart from my gfx card that gets a yellow light.

Qui-Gon Glenn 12-22-2010 01:18 PM

Have you searched our forums? Especially the Tech forums?

Sounds to me like a mss33.dll issue. Or it could be a Vista/7 issue.

Try reinstalling the game according to the second post of this thread.

Get that working, or try to, first. Then we can see what else you might be struggling with.

Corran Halycon 12-22-2010 07:18 PM

I've done everything in that thread, twice :( Including changing the ms3d.dll file or whatever it's called. The game loads up fine, it isn't until you try to enter the "game world" that it crashes, i.e after chracter creation/intro crawl or trying to load up a downloaded save file. So It can load chracter models no problem....

I wish I could get windows 7 to give me more details on the crash!

Afrobent 03-24-2011 02:44 PM

Same Problem
 
Hey Guys

I am trying to run the game (Kotor 2) on windows vista following the directions provided at the link provided by Qui-Gon Glenn, but I still have the same problem. Following character creation and the intro movie the game crashes.
I'm .dll-fixed and patched and everything but I can't make it work...

Do you have any ideas?

Q 03-24-2011 04:01 PM

And now for the obligatory canned response.
Try using the game's configuration utility to post your system specs:
Quote:

Originally Posted by stingerhs (Post 1774888)
Post your system specs
Sometimes we're just not going to be able to help you if we don't know what kind of hardware you have on your machine. If you don't know what you have on your machine, then follow these steps below:
  • Bring up the launcher menu for Kotor 1 or 2.
  • Click on "Configure".
  • Click the "Scan Hardware" button on the lower center of the window.
  • Click "Yes" to continue.
  • Click "Details" to view your system specs.
  • Click "Save Report" and save the file to your desktop.
  • Whenever you post your problem, open the file you just saved and copy and paste the contents to your post.

And please specify which version of Windows you are using because the game can't ID anything newer than XP.

Afrobent 03-25-2011 10:47 AM

Report
 
I'm using Windows Vista 32-bit SP2

And this is how the report turned out: (I left out the [keymapping] part for convenience - don't think that's the issue here)

[SWKotOR]
ReportDateTime=25-03-2011 15:33:48
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=1795
CPUFamily=6
CPUModel=15
CPUStepping=13
CPUVendor=Intel
CPUName=Intel(R) Core(TM)2 Duo CPU T5670 @ 1.80GHz
Status=Pass

[Memory]
RAM=2016
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=34.33GB
Q: (NTFS), UNICODE=3.16GB
S: (NTFS), UNICODE=691MB
Status=Pass

[CD-ROMs]
DriveLetters=E:\
Drives=HL-DT-ST DVDRAM GSA-T30N

[Video]
Video Card Name=
Video Memory=1024
Desktop Resolution=1280x800x32 @ 50Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.2202
OpenGL Vendor=Intel
OpenGL Renderer=Mobile Intel(R) 4 Series Express Chipset Family
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (Conexant High Definition SmartAudio 221)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=800
Height=600
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=0
Voiceover Volume=0
Sound Effects Volume=0
Movie Volume=0
Number 3D Voices=16
Number 2D Voices=24
2D3D Bias=0.50
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
V-Sync=0
Anisotropy=0
Frame Buffer=1
Anti Aliasing=0
Texture Quality=0
Grass=0
Soft Shadows=0
Shadows=0
Brightness=57
RefreshRate=60
Height=600
Width=800
EnableHardwareMouse=1
FullScreen=1

[Game Options]
UnlockedPlanetSongs=1
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1


As I explained earlier - I have followed the very specific and detailed installation and patching guide for the KotOR games here on these forums.
KotOR 1 works fine, but KotOR 2 crashes right after the initial cutscene with the floating text and the damaged Ebon Hawk - when entering "the game world" as Corran put it.

I hope you have some suggestions as to what I can do to make it work. So far, disabling sound and running with a single processor has not done the trick...

Thankyou in advance for giving the issue your attention! =)

Q 03-25-2011 06:03 PM

Well, first off:

1) I see no Dantooine lag fix.
2) Your game version is 2.0, not 2.1, which means that your game is not patched.
3) Are you setting CPU affinity to a single core every time you launch the game?

IcyVoid 04-20-2011 11:47 AM

Hi Forum Brothers!

I don't post very often but figured I would here and now. =)

As everyone else with the Intel Onboard GPU's, I am having the same problem with KOTOR 2: TSL.

I've did all the fixes, replaced the kotor2.exe, replaced the famed .dll, vertex buffer disabled, dantooine lag fix, etc etc....... updated. Ran in admin mode with xp sp 2 compatibility.

I've even used 3d analyze. =) I couldn't get it even to work in wireframe mode. LoL

So yeah, I've tried every solution and it just doesn't want to work. I can run Star Wars Battlefront 1 & 2 fine for example though.

So, with my Intel Series 4 Chipset GPU, I say it just DOESN'T work with TSL. Sucks because Kotor 2 was like one of my favorite games though!

Anyway, after hours of searching hopefully I can save another individual who is clueless from the dark side of the KOTOR 2 no worky.

For any new individual reading this encountering the "character creation crash" as some call it or others "opening cutscene crash" indeed, you are likely experiencing a graphics issue! Indeed you most likely have an Intel series built in GPU. Don't expect to get it to work. ;) You can try emulating T&L requirements in 3d analyze but that won't help either.

If you are an Intel Series 4 Chipset and did somehow get yours to work, congrats to you! :thmbup1:

@Evil Q: I like the dog! :)

Q 04-20-2011 04:19 PM

1) Try using the original .exe; the one you replaced with the one that you download from SecuROM.

2) Try disabling the movies (launcher>configure>check disable movies>apply>exit).

IcyVoid 04-22-2011 03:13 AM

Thanks for those suggestions. I did indeed try them but it still didn't work. I heard a rumor that it may have to do with the chipset using shared memory but I don't know. I am going to try and analyze the crash dump and debug, pinpoint the exact instruction that caused the problem. Windows 7 crash dumps are stored in the AppData junction somewhere.

Q 04-22-2011 03:49 AM

It could be Data Execution Prevention (DEP) acting up for some reason.

The TechAngel 07-20-2011 07:20 PM

Hi,

I'm new to this forum and forum posting in general; and I have this same problem (Above Topic). I have tried all of the above solutions and still can't get the game world to run after the character creation sequence and the intro credits and movie. Here's my system requirements report. I updated to v2.1, but mabey someone can tell me if I'm missing anything?

Thanks

The TechAngel 07-20-2011 07:33 PM

Hi everyone,

I'm new to this forum and forum posting in general; and I have the same problem with the game (SWKOTOR 2) crashing after the character creation process and the intro credits and movie. I think its the game world that won't load, which "I think" is (what) causing the "swkotor2.exe" to crash. I've tried all of the above solutions and I can't seem to get it running. Here's my system requirements saved from the configuration setting in the main menu:

Mabey someone could tell me if I forgot an update or fix or something??
p.s. I'm running on Windows 7


[SWKotOR]
ReportDateTime=7/20/2011 6:00:48 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\Games\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=8
CPUSpeed=1995
CPUFamily=6
CPUModel=10
CPUStepping=7
CPUVendor=Intel
CPUName= Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
Status=Pass

[Memory]
RAM=4096
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=499.49GB
D: (NTFS), UNICODE=1.60GB
Status=Pass

[CD-ROMs]
DriveLetters=E:\,G:\
Drives=hp DVDRAM GT31L,hp DVDRAM GT31L ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=1024
Desktop Resolution=1600x900x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.0.0 - Build 8.15.10.2342
OpenGL Vendor=Intel
OpenGL Renderer=Mobile Intel(R) HD Graphics
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers and Headphones (IDT High Definition Audio CODEC)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
EAX=0
Sound Init=0
Disable Sound=0
Force Software=0

[Graphics Options]
EnableHardwareMouse=1
FullScreen=0
RefreshRate=60
Width=1024
Height=768
V-Sync=0
Texture Quality=2
Anti Aliasing=0

[Game Options]
Disable Movies=0

[config]
firstrun=0

The TechAngel 07-20-2011 07:34 PM

Sorry for the seperate posts the second one is the important one to read.

Al_Ciao 07-20-2011 10:04 PM

I have your answer!

I too have a netbook with Windows 7 and I too had the same problem with crashing right after the character creation.

You have to do two things.

First, download the patch and install it.

Second, open Windows Explorer, and go to the folder where the main swkotor2.exe file is (for me, it's C:/Program Files/LucasArts/SWKotor2/swkotor2.exe), right click on it, and select Properties.

Under Properties, open the Compatibility tab, select the check box next to "Run this program in compatibility mode for" and choose "Windows XP (Service Pack 2)".

Click "Apply" at the bottom and then "Ok".

Now your game should run fine.

Q 07-20-2011 10:10 PM

Actually, you need to to reinstall the game according to the large-print instructions at the top of the second post in this thread.

skittle7 09-20-2011 09:17 PM

[SWKotOR]
ReportDateTime=9/20/2011 8:16:32 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.10.427
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=4
CPUSpeed=2527
CPUFamily=6
CPUModel=5
CPUStepping=5
CPUVendor=Intel
CPUName=Intel(R) Core(TM) i3 CPU M 380 @ 2.53GHz
Status=Pass

[Memory]
RAM=3896
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=398.15GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\
Drives=HL-DT-ST DVDRWBD CT30N

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=2048
Desktop Resolution=1600x900x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.2182
OpenGL Vendor=Intel
OpenGL Renderer=Intel(R) HD Graphics
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (Realtek High Definition Audio)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=0
Anti Aliasing=0
Texture Quality=0
Grass=0
Soft Shadows=0
Shadows=0
Brightness=68
RefreshRate=60
Height=600
Width=800
EnableHardwareMouse=1
FullScreen=0



im having the same problems but im on windows 7 64bit so any helpo would be nice and ive done everything you guys have said even re installing it

Q 09-21-2011 05:58 AM

1) I see no Dantooine lag fix.

2) Try using the original swkotor2.exe from the patch instead of the one from SecuROM.

noname2020x 09-22-2011 01:48 PM

I am having the same problem. I have reinstalled, tried installing graphics updates (couldn't find any that worked for my Intel(R) HD Graphics current driver: 8.15.10.2125), used the vista fix, used the patch, changed graphics settings (not 3d settings though as my 3d settings are very limited and dont have the option for the flipping policy), compatibility settings, affinity change (my task manager wont let me do it), dx9, etc. No luck. I might just have to get the game for xbox because I MUST PLAY IT! (haven't played it in years)

windows 7 64 bit home premium btw

Q 09-22-2011 03:00 PM

Are you using the original .exe or the one from SecuROM?

noname2020x 09-22-2011 03:40 PM

I've tried both =(. While screwing around I realized I could just try to delete the one intro movie and see if that would skip past it. Thoughts? any idea on which one it is?

also, any idea on how i can change flipping settings and affinity settings?

Q 09-22-2011 04:28 PM

You can't change the flipping policy with the newer drivers.

As for affinity: Are you using an administrator's account?

Qui-Gon Glenn 09-22-2011 04:54 PM

As for SecuRom, is it a patch you downloaded from our forums or another place, or did you get it through sending an analysis.sro to SecuRom from your PC?

Affinity can be set manually in XP by doing a CTRL-ALT-DLT to your task manager, find the process swkotor2.exe, right-click on it and choose Affinity, select it to core 0 (in my experience) or 1, just not both.

In Vista, I think you do it the same way. 7 is supposed to do it automatically.... Q would know more there and in general.

noname2020x 09-22-2011 05:27 PM

I am using an admin account. I downloaded the patch from your forums.
That is the method I am using for setting affinity and it isn't working.

do you think i could use vmware player and boot xp and play it off of that?

Q 09-22-2011 07:14 PM

No. AFAIK, virtual machines can't run graphics-intensive stuff like games.

If you can't set affinity (and I have no clue why you can't), don't worry about it. On my machine, Windows 7 sets it automatically for KotOR2.

Contact SecuROM by following the link in the second post of the Vista fix thread and request a new .exe.

dvlower 09-29-2011 12:24 AM

can somone help me [SWKotOR]
ReportDateTime=9/28/2011 9:08:32 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.10.427
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=Win9x
Version=Windows 9X v6.1 build 7600
Service Pack=None
Status=Fail

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=2
CPUSpeed=2128
CPUFamily=6
CPUModel=5
CPUStepping=5
CPUVendor=Intel
CPUName=Intel(R) Pentium(R) CPU P6200 @ 2.13GHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=204.83GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\
Drives=

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=2048
Desktop Resolution=1366x768x32
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.2302
OpenGL Vendor=Intel
OpenGL Renderer=Intel(R) HD Graphics
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (High Definition Audio Device)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=1
Anti Aliasing=0
Texture Quality=0
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=0
RefreshRate=60
Width=800
Height=600

[Game Options]
UnlockedPlanetSongs=1
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1
Disable Movies=1

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=0

dvlower 09-29-2011 12:25 AM

i guess its my Os but idk what to do with it will i ever get it to play

Q 09-29-2011 07:55 AM

What OS are you using?

EDIT: N/M

Try to stay in one thread, OK?

dvlower 09-29-2011 01:19 PM

[OS]
Name=Win9x
Version=Windows 9X v6.1 build 7600
Service Pack=None
Status=Fail


this is the one that failed and my videocard got a warning idk how to fix this os

Q 09-29-2011 01:49 PM

The answer's in the thread you started.

dvlower 09-29-2011 01:52 PM

ok sweet what all patches do i install im getting the 1.0b right now

ok i did everything and it said wrong disk inserted?

omg i hate this game lol

well im going with its not gonna work...damn

has anyone got this game to work on windows 7 64bit with intel hd graphics if so can you tell me how you did it

Quote:

Originally Posted by dvlower (Post 2792138)
has anyone got this game to work on windows 7 64bit with intel hd graphics if so can you tell me how you did it

or can it be played on windows 7 visual xp mode if anyone has tryed that...

Q 09-29-2011 10:42 PM

Quote:

Originally Posted by dvlower (Post 2792128)
ok i did everything and it said wrong disk inserted?

Are you using the original game disc?

EDIT: :dozey:

shinderhizzle84 10-02-2011 10:47 PM

Having this problem, too. I have two computers, both running the exact same version of Windows 7, except that one has an Intel GPU Chipset while the other has an NVIDIA Chipset. Both get the exact same problems described by the OP. I've tried every fix out there, including the mss32.dll file, as well as "Disablex vertex shadows" or whatever that fix is that I have to copy and paste into my swkotor.ini file. What gives, LucasArts? I guess it's because the game isn't made by Bioware :P

Code:

[SWKotOR]
ReportDateTime=10/2/2011 10:45:29 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\LucasArts\Star Wars Knights of the Old Republic II\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
?:\pagefile.sys=0

[CPU]
CPUCount=4
CPUSpeed=2294
CPUFamily=6
CPUModel=10
CPUStepping=7
CPUVendor=Intel
CPUName= Intel(R) Core(TM) i5-2415M CPU @ 2.30GHz
Status=Pass

[Memory]
RAM=1024
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=14.31GB
E: (HFS)=42.59GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,F:\,G:\,H:\,I:\,J:\,K:\
Drives=MAT****A DVD-R  UJ-8A8 ATA Device

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=1024
Desktop Resolution=1280x800x32 @ 58Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=3.0.0 - Build 8.15.10.2246
OpenGL Vendor=Intel
OpenGL Renderer=Intel(R) HD Graphics Family
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=@oem49.inf,%syntek.devicedescm811%;STK1160 ATV BDA
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=16
Number 2D Voices=24
2D3D Bias=0.50
Force Software=0
EAX=0
Sound Init=0
Disable Sound=1

[Graphics Options]
V-Sync=1
Anisotropy=1
Frame Buffer=1
Anti Aliasing=0
Texture Quality=0
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=0
Disable Vertex Buffer Objects=1
RefreshRate=60
Width=800
Height=600

[Game Options]
UnlockedPlanetSongs=1
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
TooltipDelay Sec=1
Disable Movies=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[config]
firstrun=0

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=4


Q 10-03-2011 06:57 AM

Your game is not patched.

If you haven't already, reinstall the game according to the large-print instructions at the top of the second post in this thread.

When it comes to the part with replacing the swkotor2.exe with the one from SecuROM, DO NOT overwrite the original .exe; just rename it. If the game still crashes right after character creation after completing the installation, try using the the original .exe instead of the one from SecuROM.

If that doesn't work, there is a link in that post that will allow you to contact SecuROM and request a new .exe.


If you're trying to use a crack; forget it. The KotOR2 cracks will not work on Intel mobile chipsets.

shinderhizzle84 10-03-2011 11:21 AM

Quote:

Originally Posted by Q (Post 2792358)
Your game is not patched.

If you haven't already, reinstall the game according to the large-print instructions at the top of the second post in this thread.

When it comes to the part with replacing the swkotor2.exe with the one from SecuROM, DO NOT overwrite the original .exe; just rename it. If the game still crashes right after character creation after completing the installation, try using the the original .exe instead of the one from SecuROM.

If that doesn't work, there is a link in that post that will allow you to contact SecuROM and request a new .exe.


If you're trying to use a crack; forget it. The KotOR2 cracks will not work on Intel mobile chipsets.

I definitely patched to 1.0b. I don't know if that's the latest patch but I literally ran the patch installer and it said "Star Wars: KOTOR II has been successfully patched to version 1.0b". I'll try re-installing via the directions in that thread you linked. What do you mean by rename it? Do you mean to copy and paste the securom .exe into the installation directory and then afterwards rename it to swkotor2.exe and then tell Windows 7 to overwrite the original file? Because obviously the game won't work with the Securom executable if it's not named swkotor.exe, right?

Q 10-04-2011 12:57 AM

It's already named swkotor2.exe. Rename the original swkotor2.exe before moving it in there.

I can tell that your game isn't patched because GameVersion=v2.00.424 when it should be 2.10.427.

koumas 02-01-2012 10:32 PM

Hi everyone. I'm experiencing error in installing the patch 1.0b. After i double click it, it starts extracting but then it shows this error,"Old file not found. However, a file of the same name was found. No update done since file contents do not match." Pls anyone help me with this

Q 02-02-2012 03:29 AM

You could have the UK version. There are 2 patches for it, and you'll have to apply both of them. You can get them here.

Matten 03-11-2012 01:43 PM

Okay, so what I did was, that I removed a Vista/7 Fix, from the folder, and replaced it with the Original .dll file..
What happened was, that rather than crashing immidiatly after the Intro movie, i saw the animation of T3M4 waking up, and the crash happened appromexly 6 seconds in the game. So the Graphics loaded up, it can be displayed, everything was alright, and THEN the game crashed. Same thing happened to the SaveGame file, which I downloaded.

So what is it. With the updated .dll file it Crashes, and with the original the Game is Actually LOADED?

What should I do to actually PLAY it? XD

btw. I use cracked version of the game. I can't get the original anywhere :(

Darth Xander 03-15-2012 06:53 PM

I've done everything I can think of, and followed a lot of instructions on this and still, my game crashes after the scrolling text intro-movie, I get a few seconds of sound of the prologue level and then it crashes.

I have: Updated it to 0.1a & then to 0.1b (I'm in the UK), I have set the .exe (From SECUROM) to use as admin & set it to run in XP SP2, I've changed the 3D settings of my Intel driver by changing the flipping policy to blit, I've added the Dantooine Lag fix (I think), I've reinstalled it countless times, the original .exe wants me to insert the play disk (even with the disk in the drive) [This error only occured since I followed Q's lengthy instructions on the other helpful thread.]

Not all in that order however.

The last thing I've done is added the disable vertex buffer objects, which I am pretty sure is the Dantooine lag fix, strangely enough after this, my game doesn't crash, however it doesn't seem to transition from the intro movie to the prologue level (I skip the movie.) I can hear the loading screen's music track playing but whilst I gaze at a black screen waiting to hear my first few seconds of audio from the level, nothing happens. (And I waited patiently for a good few minutes.)

Edit: Back to crashing.

Here's my error report, I'm sorry if this post is a little inconvenient but I totally give up trying to fix this myself now.

Thank you.

Quote:

[SWKotOR]
ReportDateTime=15/03/2012 22:21:50
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=Service Pack 2
Status=Pass

[SwapFiles]
C:\pagefile.sys=1524

[CPU]
CPUCount=1
CPUSpeed=1995
CPUFamily=6
CPUModel=6
CPUStepping=1
CPUVendor=Intel
CPUName=Intel(R) Celeron(R) CPU 550 @ 2.00GHz
Status=Pass

[Memory]
RAM=1016
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=10.16GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,E:\
Drives=TSSTcorp CDW/DVD TS-L462D ATA Device

[Video]
Video Card Name=
Video Memory=256
Desktop Resolution=1280x800x32 @ 60Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.0.0 - Build 7.15.10.1666
OpenGL Vendor=Intel
OpenGL Renderer=Intel 965/963 Graphics Media Accelerator
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=Speakers (Realtek High Definition Audio)
Status=Pass


;Game Options from swkotor2.ini

[Display Options]
FullScreen=1
Disable Movies=0
Disable Intro Movies=0
Sort Modules=1
Width=640
Height=480
BitsPerPixels=32
RefreshRate=60

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
Force Software=0
EAX=0
Sound Init=0
Disable Sound=0

[Graphics Options]
V-Sync=0
Anisotropy=1
Frame Buffer=1
Anti Aliasing=0
Texture Quality=0
Grass=1
Soft Shadows=1
Shadows=1
Brightness=57
EnableHardwareMouse=1
FullScreen=0

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
UnlockedPlanetSongs=1
TooltipDelay Sec=1

[config]
firstrun=0

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=4


All times are GMT -4. The time now is 06:20 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.