LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   The Work Bench (http://www.lucasforums.com/forumdisplay.php?f=554)
-   -   [TSL] Windows 7 (http://www.lucasforums.com/showthread.php?t=208352)

CptPriceless 09-04-2011 11:25 PM

[TSL] Windows 7
 
I know that this issue has been brought up multiple times, but after following several different guides for Windows Vista and Windows 7, I have been unsuccessful in trying to get the game (KOTOR 2 TSL) to work.

I have patched TSL.
I have replaced the mss32.dll file.
I have ran installation (setup.exe) and game (swkotor2.exe) as admin and in compatibility mode for Win XP and Win 2000, neither have worked.
I have cracked the game.

I have updated my video card driver to most recent.

NOTHING WORKED.


Here are my TSL Settings:

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
EAX=0
Sound Init=0
Disable Sound=0
Force Software=1
[config]
firstrun=0
[Graphics Options]
DisableVertexBufferObjects=1
AllowWindowedMode=1
Anisotropy=2
Frame Buffer=0
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
FullScreen=0
EnableHardwareMouse=1
RefreshRate=75
Width=800
Height=600
V-Sync=0
Texture Quality=2
Anti Aliasing=0
[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
UnlockedPlanetSongs=1
TooltipDelay Sec=1
Disable Movies=1

[Keymapping]
Action286B=8
Action286A=7
Action285B=10
Action285A=9
Action284B=54
Action284A=51
Action283B=54
Action283A=51
Action282B=69
Action282A=73
Action281B=53
Action281A=76
Action280B=69
Action280A=73
Action268=52
Action265=58
Action264=57
Action263=43
Action262=85
Action261=84
Action260=83
Action259=82
Action258=81
Action257=80
Action256=79
Action255=78
Action254=77
Action253=31
Action245=75
Action244=55
Action243=67
Action242=74
Action241=87
Action240=56
Action239=68
Action238=82
Action236=83
Action234=81
Action232=80
Action230=79
Action228=78
Action226=77
Action225=70
Action224=90
Action223=31
Action222=25
Action221=24
Action220=29
Action219=28
Action218=42
Action217=87
Action216=65
Action215=63
Action214=60
Action213=62
Action212=61
Action211=66
Action210=59
Action209=71
Action208=89
Action207=72
Action206=30
Action205=55
Action204=67

[Autopause Options]
End Of Combat Round=0
Mine Sighted=0
Enemy Sighted=1
Party Killed=1
Action Menu=0
New Target Selected=1

[Movies Shown]
Movie10=0
Movie 9=0
Movie 8=0
Movie 7=0
Movie 6=0
Movie 5=0
Movie 4=0
Movie 3=0
Movie 2=0
Movie 1=0
Movie 0=0


Here are the results from the TSL hardware scan:

OS Passed Windows XP v5.1 build 2600 Service Pack 2
CPU Passed Pentium(R) Dual-Core CPU E5800 @ 3.20 GHz
RAM Passed 4064 MB
HD Passed C: (NTFS), Unicode 736.41 GB Free
Video Warning RDPDD Chained DD 2058MB
Audio Passed @wdma_usb.inf%usb/class_01.devicesc%US B Audio Device
OpenGL Passed Intel -2.1.0 - Build 8.15.10.2413
DirectX Passed DirectX 9.0c (4.09.00.0904)


System Specs:

Windows 7 Service Pack 1

Manufacturer: Acer
Model: Aspire X3910
Rating: 3.5 (due to gaming graphics)
Processor: Pentium(R) Dual-Core DPU E5800 @ 3.20 GHz 3.20 GHz
Installed memory (RAM): 4.00 GB
System type: 64-bit Operating System
Pen and Touch: No Pen or Touch Input is available for this Display



I'd really appreciate it if someone assisted me through this 'crisis' :P Thanks!

Q 09-05-2011 12:10 AM

I need the whole report up to, but not including, keymapping and anything after that.

CptPriceless 09-05-2011 12:14 AM

Here you go Q.

[SWKotOR]
ReportDateTime=9/4/2011 9:13:25 PM
SysInfoVersion=v1.00.60
GameExists=1
GameVersion=v2.00.424
GameInstallLocation=C:\Program Files (x86)\LucasArts\SWKotOR2\

[OS]
Name=WinXP
Version=Windows XP v5.1 build 2600 Service Pack 2
Service Pack=None
Status=Pass

[SwapFiles]
?:\pagefile.sys=0
?:\pagefile.sys=0

[CPU]
CPUCount=1
CPUSpeed=3192
CPUFamily=6
CPUModel=7
CPUStepping=10
CPUVendor=Intel
CPUName=Pentium(R) Dual-Core CPU E5800 @ 3.20GHz
Status=Pass

[Memory]
RAM=4064
Status=Pass

[Disk Free Space]
C: (NTFS), UNICODE=735.75GB
G: (NTFS), UNICODE=25.03GB
Status=Pass

[CD-ROMs]
DriveLetters=D:\,J:\
Drives=HL-DT-ST DVDRAM GH60N

[Video]
Video Card Name=RDPDD Chained DD
Video Memory=2048
Desktop Resolution=1440x900x32 @ 75Hz
DirectX=DirectX 9.0c (4.09.00.0904)
OpenGL Version=2.1.0 - Build 8.15.10.2413
OpenGL Vendor=Intel
OpenGL Renderer=Intel(R) G45/G43 Express Chipset
Vid Card Status=Warning
Vid Card Driver Status=Pass
GL Status=Pass
DX Status=Pass

[Audio]
Sound Card Name=@wdma_usb.inf,%usb\class_01.devicedesc%;USB Audio Device
Status=Pass


;Game Options from swkotor2.ini

[Sound Options]
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Number 3D Voices=32
Number 2D Voices=32
2D3D Bias=1.00
EAX=0
Sound Init=0
Disable Sound=0
Force Software=1

[config]
firstrun=0

[Graphics Options]
DisableVertexBufferObjects=1
AllowWindowedMode=1
Anisotropy=2
Frame Buffer=0
Grass=1
Soft Shadows=0
Shadows=1
Brightness=57
FullScreen=0
EnableHardwareMouse=1
RefreshRate=75
Width=800
Height=600
V-Sync=0
Texture Quality=2
Anti Aliasing=0

[Game Options]
Enable Tooltips=1
Keyboard Camera Deceleration=2000.000000
Keyboard Camera Acceleration=500.000000
Keyboard Camera DPS=200.000000
TextureVariation=0
BodyVariation=0
AppearanceType=0
PCGender=0
GameCompleted=0
CurSithLord=0
Hide InGame GUI=0
Use Small Fonts=0
Hide Unequippable=0
Tutorial Popups=1
Subtitles=1
Mini Map=1
Floating Numbers=1
Status Summary=1
Enable Mouse Teleporting To Buttons=1
Mouse Sensitivity=44
Difficulty Level=1
Auto Level Up NPCs=0
Mouse Look=0
AutoSave=1
EnableScreenShot=0
Reverse Mouse Buttons=0
Reverse Ingame YAxis=0
Reverse Minigame YAxis=0
Combat Movement=1
UnlockedPlanetSongs=1
TooltipDelay Sec=1
Disable Movies=1

Snard 09-05-2011 12:43 AM

Well, could you tell me what exactly happens when you try to launch K2?

CptPriceless 09-05-2011 01:02 AM

Quote:

Originally Posted by Darth Snard (Post 2790201)
Well, could you tell me what exactly happens when you try to launch K2?

Oh yeah, thanks for reminding me; that's the important part. I can launch TSL just fine. Loads fine, gets to character creation. After the first loading screen when you create a character; right after the prologue begins, before it even fades in, TSL crashes.

Snard 09-05-2011 01:22 AM

Oh, this has happened to me before (though I can't remember exactly how I fixed it).

I noticed you have Disable Movies=1. Why would it fade in if the movies are disabled?

Also, this may be an issue with your movies. Try to remove all the movies and put them in a Temporary Deleted Files folder. Then, try to play again and tell me what happens.

CptPriceless 09-05-2011 01:54 AM

Quote:

Originally Posted by Darth Snard (Post 2790206)
Oh, this has happened to me before (though I can't remember exactly how I fixed it).

I noticed you have Disable Movies=1. Why would it fade in if the movies are disabled?

Also, this may be an issue with your movies. Try to remove all the movies and put them in a Temporary Deleted Files folder. Then, try to play again and tell me what happens.

It's not a movie, it's more like a cutscene; you know, like the scene where Kreia drained the lives of all the Jedi masters. That's not a movie.

And I removed all the movies; moved them to a separate "Temporarily Deleted Movies" folder. The game still crashed the same way.

Q 09-05-2011 02:06 AM

Did you install the game according to the instructions in the second post of this thread?

If you did, and it still isn't working, try using the original swkotor2.exe from the patch and not the one from SecuROM. If you overwrote it, start over.

Snard 09-05-2011 02:07 AM

Oh, ok I understand what you're saying.

For those who have never played the prologue or even the game(shame on you)
Show spoiler

CptPriceless 09-05-2011 02:08 AM

Quote:

Originally Posted by Darth Snard (Post 2790213)
Oh, ok I understand what you're saying.

For those who have never played the prologue or even the game(shame on you)
Show spoiler

Right before it even shows T3. Right when you hear a slip of dialogue, it crashes. Still black screen too.

EDIT: And Q, I'll try to install again.

Snard 09-05-2011 02:14 AM

Cpt, before you do that, this may be the problem.

Try to reinstall all your mods. This happened to me when there was a problem with TSLRCM.

CptPriceless 09-05-2011 09:56 AM

Quote:

Originally Posted by Darth Snard
Cpt, before you do that, this may be the problem.

Try to reinstall all your mods. This happened to me when there was a problem with TSLRCM.

This happened to me right after install; no mods at all.


EDIT:
Quote:

Originally Posted by Q
Did you install the game according to the instructions in the second post of this thread?

If you did, and it still isn't working, try using the original swkotor2.exe from the patch and not the one from SecuROM. If you overwrote it, start over.

Reinstalled with the exact instructions. Didn't work.

Q 09-05-2011 06:25 PM

Try contacting SecuROM for a new .exe. It will take a few days.


All times are GMT -4. The time now is 10:13 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.