LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Glottis' Garage (http://www.lucasforums.com/forumdisplay.php?f=236)
-   -   Graphics Problem (http://www.lucasforums.com/showthread.php?t=209436)

oldhomehaibane 02-03-2012 06:04 AM

Graphics Problem
 
This is what I'm experiencing in certain areas of the game. It's like the pixels of some characters get "spread out" over the screen. It happens to some characters and not to others, for some reason. What's really weird is that I only started having this problem in year 2. I experienced no graphical glitches whatsoever in year 1.

http://img.photobucket.com/albums/v6...30-29-93-1.jpg

Processor: 2.8 GHz Intel Core 2 Duo
Video Card: ATI Radeon HD2600
OS: Windows XP

I also have a problem with the sound lagging a bit during cutscenes, but there's no actual audio loss so it's not bothering me too much. This problem with the visuals though is really getting on my nerves. Any help would be appreciated.

Gownaar 02-03-2012 06:58 AM

If you already tried DD/D3D fix, you could try fiddling with Catalyst settings. Sometimes when I get graphics corruption in old games, I make it go away simply by shutting Catalyst down.
Sound problems during cutscenes are usually a result of running in compatibility mode, you don't need that if you fixed core affinity.

oldhomehaibane 02-03-2012 07:08 AM

I haven't tried the DD/D3D fix. I don't know what that is. I don't know what Catalyst is either or how to shut it down. Haven't fixed core affinity either as it's another thing I don't know anything about. I am running the program in Windows 98 compatibility mode.

So yeah basically if you could explain these things to me it would be very helpful.

Gownaar 02-03-2012 07:47 AM

Take a look at the neighboring thread called 'Another alternative installer/launcher'. Reinstall the game with that - it will take care of core affinity and put DD/D3D fix at your disposal (see launcher readme). Catalyst, well... it's what pops up when you double-click that ATI icon in the system tray. To shut it down completely, start task manager and kill processes CCC.exe and MOM.exe.

oldhomehaibane 02-03-2012 07:01 PM

I just tried using the alternative installer. It says "sorry, unrecognized game language." Very strange because the game is in English when I play it.

There is no ATI icon in my system tray. There also aren't any processes called CCC.exe or MOM.exe in my task manager.

Gownaar 02-03-2012 09:39 PM

I assumed you had Catalyst because you have an ATI card but now it seems you're using a generic driver from MS. For proper performance generally, I recommend you install ATI drivers. Who knows, it may even solve your graphics problem.
About unrecognized language... I'm very glad you told me because I've had almost no feedback and that little that I have was positive. Not that you want this information but GrimInstaller's language detection is based on VOX0000.LAB crc, I really didn't expect variations of that file within the same language. I'd be grateful if you could tell me the CRC32 value of your file (GRIMDATA\VOX0000.LAB), you can calculate it e.g. with HashMyFiles.
Anyway, I have uploaded the launcher separately and also the patched files (v1.01 + core affinity) - get it from here and unpack the stuff to your game folder. If you get the 'files missing' error from the launcher, it means you installed the game with the original installer - in that case you'll have to copy the files manually from CDs or use Bgbennyboy's installer or launcher. Sorry if all this is complicated, it comes with the game and it's the reason why I created GrimInstaller/GrimLauncher, it was supposed to be the few-clicks-and-no-geekiness-required solution, I hope I can fix it (send me that crc). I'm going to bed...

oldhomehaibane 02-03-2012 10:00 PM

Well actually I am running Windows XP as a partition on my iMac. Would it really still be okay to install those drivers?

95085d43 is apparently the CRC32 value of my vox0000.LAB according to HashMyFiles.

I'm not sure exactly what you're wanting me to do in your last paragraph. I uninstalled the game in order to try reinstalling it with your installer so right now there's nothing in the game folder on my computer except for my saves. Do you want me to reinstall it with the original installer and then unpack the patched files (v1.01 + core affinity) or what exactly are you asking me to do?

Gownaar 02-04-2012 11:44 AM

I don't know much about Macs but if a Radeon HD2600 is inside yours and you're running XP then those drivers should be fine. Btw, Catalyst requires .NET Framework.

Thanks for posting the crc I asked. I updated GrimInstaller, it should work for you now and if it does, you can just skip that stuff from the last paragraph.

oldhomehaibane 02-04-2012 06:16 PM

Your installer worked perfectly, and it solved my problem with cutscene playback. It didn't solve the graphical glitch, but disabling directdraw did. So, the game is running flawlessly now. Thanks a lot!

Gownaar 02-04-2012 06:31 PM

Happy end for both of us. Enjoy the rest of the game.


All times are GMT -4. The time now is 08:46 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.