LucasForums

LucasForums (http://www.lucasforums.com/index.php)
-   Holowan Laboratories (http://www.lucasforums.com/forumdisplay.php?f=324)
-   -   Icons and Values (http://www.lucasforums.com/showthread.php?t=211983)

MiladyRevan 03-10-2013 10:20 AM

Icons and Values
 
I'm trying to make three new armors, each of these being the mandalorian armor+helmet disguises (blue, red and yellow).

Let's take the red one for example:

TemplateResRef: g_a_class88
Tag: G_A_CLASS88
Base Item: Defense Bonus 9
Cost: 10000
Additional Cost: 10000
Palette ID: 1
Upgrade Level: 0

Plot Item: Not crossed
Stolen: Not crossed
Charges: 0
Stack Size: 1
Model Variation: 88
Body Variation: 8
Texture Variation: 2

Saves as mand_r.uti

The problem is, every time I try to set the price and the model variation, they reset when I have saved. I used the g_a_class9010 armor for base, so every time I try to write 88 in M/V, it has reset to the original M/V 0 when I have saved and re-opened the editor. And the Cost value also reset, from 10000 to 8000.

The armors shows up in my inventory when I type their giveitem tag, and I can wear them, but their icons remain white boxes. As I've understood it, to attach an icon to the armor, I need the same tag number in both TemplateResRef, Tag and Model Variation, so I named the icon:

ia_class9_88

So with the Model Variation keeps resetting I can't get the icons.

What causes the values to reset?

Fallen Guardian 03-10-2013 11:13 AM

Model variation doesn't affect the icon, texture variation does. Honestly I have no idea what model variation does. But for your armor, you would put the texture variation as 88, and then the icon file as ia_class9_088 (there always has to be three digits in the last part of the icon file name).

MiladyRevan 03-10-2013 11:47 AM

Aha! It worked!
Thank you so much!


All times are GMT -4. The time now is 08:28 AM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
LFNetwork, LLC ©2002-2011 - All rights reserved.